cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1381
Views
0
Helpful
5
Replies

GLBP with One-way voice Issue

Hi!

I'm experiencing problems with my phones (7945), we have 2 4506-E, WS-X45-SUP6-E and this is the background:

We have just 1 voice vlan in the beggining, suddenly we start experiencing one-way audio between phones in the same vlan, all deskphones are 7945 running SCCP45.9-0-2SR2S. Then comes the issue with the wireless phones 7921 also, and everyone becomes crazy.

This is the int vlan config:

4506_1:

interface Vlan106
description "IP Phones"
ip address 10.141.6.252 255.255.255.0
ip helper-address 10.141.2.14
ip helper-address 10.141.2.16
no ip redirects
ip ospf message-digest-key 1 md5 7 001..........
ip ospf priority 100
glbp 106 ip 10.141.6.254
glbp 106 timers msec 300 1
glbp 106 timers redirect 600 7200
glbp 106 priority 150
glbp 106 preempt
glbp 106 load-balancing host-dependent
glbp 106 authentication md5 key-string 7 000.................

4506_2:

interface Vlan106
description "IP Phones"
ip address 10.141.6.253 255.255.255.0
ip helper-address 10.141.2.14
ip helper-address 10.141.2.16
no ip redirects
ip ospf message-digest-key 1 md5 7 01.......
ip ospf priority 200
glbp 106 ip 10.141.6.254
glbp 106 timers msec 300 1
glbp 106 timers redirect 600 7200
glbp 106 priority 200
glbp 106 preempt
glbp 106 load-balancing host-dependent
glbp 106 authentication md5 key-string 7 155..............

So we create another voice vlan without glbp in the main switch:

4506_1:

interface Vlan130
description IPT_TEST
ip address 10.141.30.254 255.255.255.0
ip helper-address 10.141.2.14
ip helper-address 10.141.2.16
no ip redirects
ip ospf message-digest-key 1 md5 7 001.....
ip ospf priority 100

And start migrating phones to that vlan to mitiate the issue, for some time the problems were gone, but it is rising again.

Now I have desk phones in 2 voice vlans, and wireless phones in another vlan. this is driving me crazy.

Does anyone knows about how to troubleshoot this issue?

thanks!!

5 REPLIES 5
cbeswick
Beginner

Hi,

I am no expert in Voice or in the implementation of GLBP. But my understanding is that there is an inherent risk in utilising GLBP with any service that is sensitive to "out of order" packets. With HSRP flows always follow the same path to the destination, with GLBP packets are load balanced (depending on the mode) across different switches per packet - again this is my limited understanding.

I agree with you, from that point of view. But there are another topics saying that is not a problem, well... I have a problem!!!

Can you provide your port configs where the phones are connected?  Also a show version?

-Matt

Phone1

4506_2:

interface GigabitEthernet3/44
description Phone1
switchport access vlan 120
switchport mode access
switchport voice vlan 130
  spanning-tree portfast
spanning-tree bpduguard enable

Phone2

4506_1

interface GigabitEthernet6/3
description Phone2
switchport access vlan 121
switchport voice vlan 106

I also removed the QoS from the Interfaces connecting to each other switch.

The original problem was Phone1 speak and listen / Phone2 speak and cannot listen

Then I changed the voice vlan from 106 (with glbp configured) to 130 (no glbp) and it worked!

EDIT

sorry, this is the show version:

4506_1#sh ver
Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-ENTSERVICESK9-M), Version 12.2(53)SG1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 30-Oct-09 18:26 by prod_rel_team
Image text-base: 0x10000000, data-base: 0x1279617C

ROM: 12.2(44r)SG5
Darkside Revision 4, Jawa Revision 20, Tatooine Revision 140, Forerunner Revision 1.74

4506_1 uptime is 6 weeks, 6 days, 23 hours, 31 minutes
System returned to ROM by power-on
System restarted at 22:27:46 CET Fri Dec 31 2010
System image file is "bootflash:cat4500e-entservicesk9-mz.122-53.SG1.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C4506-E (MPC8548) processor (revision 6) with 524288K bytes of memory.
Processor board ID FOX123XXXXX
MPC8548 CPU at 1.33GHz, Supervisor 6-E
Last reset from PowerUp
26 Virtual Ethernet interfaces
48 FastEthernet interfaces
154 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
511K bytes of non-volatile configuration memory.

Configuration register is 0x2102

--------------------------------------------------------------------------------------------------------------------

4506_2#sh ver
Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-ENTSERVICESK9-M), Version 12.2(53)SG1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Fri 30-Oct-09 18:26 by prod_rel_team
Image text-base: 0x10000000, data-base: 0x1279617C

ROM: 12.2(44r)SG5
Darkside Revision 4, Jawa Revision 20, Tatooine Revision 140, Forerunner Revision 1.74

4506_2 uptime is 6 weeks, 6 days, 23 hours, 32 minutes
System returned to ROM by power-on
System restarted at 22:27:43 CET Fri Dec 31 2010
System image file is "bootflash:cat4500e-entservicesk9-mz.122-53.SG1.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C4506-E (MPC8548) processor (revision 6) with 524288K bytes of memory.
Processor board ID FOX123XXXXX
MPC8548 CPU at 1.33GHz, Supervisor 6-E
Last reset from PowerUp
26 Virtual Ethernet interfaces
96 FastEthernet interfaces
106 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
511K bytes of non-volatile configuration memory.

Configuration register is 0x2102

An Update on this..

I set the all vlans spanning-tree root primary at 4506_1 and secondary at 4506_2 and the problem still occur.

I just shutdown the interfase vlan 106 on the 4506_2 and everything seems to be OK. Just left UP/UP int vlan 106 on the 4506_1. I guess is a layer 3 issue.