cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11618
Views
9
Helpful
17
Replies

Help!!! Multicasting Issue

wangchunhao20001
Beginner
Beginner

Hi there,

I got a multicasting problem while I was testing a stimulated solution. Below is the digram I'm working on. Two layer 3 switches, both are running EIGRP and PIM-SM, and the multicasting server plays a video through VLC Player, then the multicasting client can watch that video after it joins in that group. So far, all of configurations have been done according Cisco's document, however the client couldn't receive any multicasting packets. I'm assuming the multicasting packet haven't been forwarded the C3560 from C3650. Please give me any suggestions and comments you have. I really appreciate that. 

Thanks,

Bob

Configuration: (All of the configuration I have. Rest of configuration is default like FACTORY SETTINGS. )

C3650:

ip routing
!
ip multicast-routing
!
!
!
!
!
!
interface Loopback0
ip address 30.30.30.30 255.255.255.255
ip pim sparse-mode
!
!
interface GigabitEthernet1/0/1
switchport access vlan 500
switchport mode access
!
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 172.16.10.3 255.255.255.0
ip pim sparse-mode
!
interface Vlan500
ip address 192.168.50.1 255.255.255.0
ip pim sparse-mode
!
!
router eigrp 100
network 0.0.0.0
eigrp stub connected summary
!
ip forward-protocol nd
ip pim rp-address 30.30.30.30
ip pim send-rp-discovery Loopback0 scope 10

=============================================

C3560:

ip routing
!
!
ip multicast-routing distributed
!
!
!
!
!
vlan configuration 300
vlan internal allocation policy ascending
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface GigabitEthernet1/0/1
switchport access vlan 300
switchport mode access
!
!
interface TenGigabitEthernet1/0/3
switchport access vlan 100
switchport mode access
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 172.16.10.1 255.255.255.0
ip pim sparse-mode
!
interface Vlan300
ip address 192.168.10.1 255.255.255.0
ip pim sparse-mode
!
!
router eigrp 100
network 0.0.0.0
eigrp stub connected summary
!
ip forward-protocol nd
ip http server
ip http secure-server
!
ip pim rp-address 30.30.30.30
!

Verification:  

C3650:

C3650#  show ip mrouter 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.250), 01:55:29/00:02:36, RP 30.30.30.30, flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Vlan500, Forward/Sparse, 01:55:28/00:02:36

(*, 239.0.0.1), 01:55:29/00:02:37, RP 30.30.30.30, flags: SJC
 Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Vlan500, Forward/Sparse, 01:52:25/00:02:37

(*, 224.0.1.39), 00:41:13/00:02:51, RP 30.30.30.30, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:41:13/00:02:51
Vlan500, Forward/Sparse, 00:41:13/00:02:36
Vlan100, Forward/Sparse, 00:41:13/00:02:29

(*, 224.0.1.40), 02:11:31/00:02:52, RP 30.30.30.30, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Vlan100, Forward/Sparse, 00:41:10/00:02:27
Loopback0, Forward/Sparse, 00:41:13/00:02:52


C3650#show ip pim interface

Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
172.16.10.3 Vlan100 v2/S 1 30 1 172.16.10.3
192.168.50.1 Vlan500 v2/S 0 30 1 192.168.50.1
30.30.30.30 Loopback0 v2/S 0 30 1 30.30.30.30
C3650#show nei     ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
L - DR Load-balancing Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.10.1 Vlan100 02:08:05/00:01:36 v2 1 / S P G

C3650#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
239.255.255.250 Vlan500 01:56:11 00:02:55 192.168.50.3
239.0.0.1 Vlan500 01:53:07 00:02:51 192.168.50.3
224.0.1.39 Loopback0 00:41:55 00:02:09 30.30.30.30
224.0.1.39 Vlan500 00:41:55 00:02:53 192.168.50.1
224.0.1.39 Vlan100 00:41:55 00:02:46 172.16.10.3
224.0.1.40 Vlan100 00:41:52 00:02:41 172.16.10.1
224.0.1.40 Loopback0 00:41:55 00:02:10 30.30.30.30

================================================================

C3650-CX:

C3560#show ip mrouter  e
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.250), 00:01:04/00:01:55, RP 30.30.30.30, flags: SP
Incoming interface: Vlan100, RPF nbr 172.16.10.3
Outgoing interface list: Null

(*, 224.0.1.39), 00:43:05/00:02:31, RP 30.30.30.30, flags: SP
Incoming interface: Vlan100, RPF nbr 172.16.10.3
--More--   Outgoing interface list: Null

(*, 224.0.1.40), 02:07:32/00:02:31, RP 30.30.30.30, flags: SJPL
Incoming interface: Vlan100, RPF nbr 172.16.10.3
Outgoing interface list: Null


C3560#show ip pim interface

Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
172.16.10.1 Vlan100 v2/S 1 30 1 172.16.10.3
192.168.10.1 Vlan300 v2/S 0 30 1 192.168.10.1

C3560#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
224.0.1.39 Vlan100 00:45:23 00:02:17 172.16.10.3
224.0.1.40 Vlan100 02:11:48 00:02:20 172.16.10.1

17 Replies 17

Hi,

The post quite old, but I hope if anyone can reply,

1) I have 4 Routers, R1, R2, R3, and R4.
2) R1 and R2, are directly connected via P2P OSPF, and the same configuration applies to R3 and R4.
3) Between R1, R2, and R3, R4 GRE tunnels are established via P2P OSPF, R2 is an RP (Phantom RP).
The multicast network seems to be running fine because I can verify this from RPF and PIM neighbors, etc, etc...
4) on each Router, I have created a loopback to test multicast.

On R1
int lo10
ip address 192.168.1.1 255.255.255.255
ip igmp join-group 239.10.10.10
ip ospf network point-to-point
ip pim sparse-mode
!
On R2
int lo10
ip address 192.168.2.1 255.255.255.255
ip igmp join-group 239.10.10.10
ip ospf network point-to-point
ip pim sparse-mode
!
On R3
int lo10
ip address 192.168.3.1 255.255.255.255
ip igmp join-group 239.10.10.10
ip ospf network point-to-point
ip pim sparse-mode
!
On R4
int lo10
ip address 192.168.4.1 255.255.255.255
ip igmp join-group 239.10.10.10
ip ospf network point-to-point
ip pim sparse-mode
!
All routers can reach each other's loopback via ospf. The problem which I face is when ping initiated from R1: ping 239.10.10.10 source Lo0 then only R2 Lo10(192.168.2.1) would reply to the multicast group, but at the same time, the Routers R3 and R4 which lies at the other end of the GRE Tunnels, their loopbacks don't reply, only their tunnels and the connected interface between R3 and R4 real ip address would be answering to the multicast group, and I expect that their loopbacks interfaces should be replying to the multicast group because they are a member of it, I don't know why their respective loopback interfaces don't reply, and vice versa on R3/R4 when ping initiated, however, when the same scenario implemented in the GNS3 then the result is OK, but when it comes to production Routers then the output is not the same.
Is it because of the platform limitation that they cant simulate the multicast source? , or perhaps some other reason.

I have tried a lot to dig about this but couldn't find an answer.

 

Regards


wangchunhao20001
Beginner
Beginner

Any comments and suggestions are welcomed, Please!!!

Thanks,

Bob

I know this is an old post but I’ll respond anyway.. your configuration is close but you need to bind the rp to the multicast group either with an access-list or route-map. The loopback address closest to the source video sending the 239.x.x.x group become the rp for this group the switch the next hop switch would have an >ip pim rp-address using the loopback/rp address of the switch closest to the source sender. You add the name of the access list right after the loopback/rp address in your ip pim rp-address statement. Permit 239.x.x.x is all you need in the access-list and you’d have a simple multicast routing pim sparse-mode static rp. When you show ip mr group you’ll see a rpf neighbor and the Unicast address of the source sending 239.x.x.x

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers