cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
476
Views
0
Helpful
3
Replies
Highlighted

Help with switching and routing

What am I missing?

I've got a verizon fios router (IP 10.1.1.2) acting as DHCP server for network 10.1.1.0/24. I have a route configured: destination: 192.168.10.0/24 and gateway 10.1.1.2.

Connected to a Cisco C2950G all in VLAN1 (to be edited later) distributing the 10.1.1.0/24 network, that connects to an Apple Airport extreme in bridge mode.

A Cisco 2611XM router f0/0 ip 10.1.1.249 connected to the airport extreme listed above. Interface f0/1 ip: 192.168.10.235 and a DHCP server configured on this router for the 192.168.10.0/24 network.  Interface 0/1 is connected to a Cisco 3512 also all on VLAN1.

1) Host connected to Cisco 3512 (192.168.10.0/24 network) won't get a default gateway from my router.  Why?

2) Host connected to Cisco 3512 (192.168.10.0/24 network) can't ping my Verizon router (10.1.1.2) - I get a "PING: transmit failed. General failure". Why?

3) Host connected to Airport Extreme (10.1.1.18) can ping Cisco 2611XM router f0/0 (10.1.1.249) and f0/1 (192.168.10.235) but cannot ping a host (192.168.10.2) connected to the 192.168.10.0/24 network via Cisco 3512.  Why?

4) I can't ping google.com from the switch.  Why?

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

boot-start-marker

boot-end-marker

logging buffered 51200 warnings

aaa new-model

aaa authentication login default local

aaa session-id common

clock timezone EST -5

no network-clock-participate slot 1

no network-clock-participate wic 0

no ip dhcp use vrf connected

ip dhcp pool america

import all

network 192.168.10.0 255.255.255.0

dns-server 10.1.1.2

ip name-server 10.1.1.2

multilink bundle-name authenticated

vlan internal allocation policy ascending

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 10.1.1.0 255.255.255.0 FastEthernet0/1

ip route 192.168.10.0 255.255.255.0 FastEthernet0/0

no ip http server

no ip http secure-server

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption

hostname TESTBED-01-2611XM

boot-start-marker
boot-end-marker

logging buffered 51200 warnings

aaa new-model

aaa authentication login default local

aaa session-id common
clock timezone EST -5
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef

ip dhcp pool america

import all
network 192.168.10.0 255.255.255.0
dns-server 10.1.1.2

ip name-server 10.1.1.2

multilink bundle-name authenticated

vlan internal allocation policy ascending

interface FastEthernet0/0

ip address 10.1.1.249 255.255.255.0

duplex auto

speed auto

interface FastEthernet0/1

ip address 192.168.10.235 255.255.255.0

duplex auto

speed auto

no ip http server

no ip http secure-server

control-plane

Thanks,

G

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Participant

Hello.

Can you post a topology diagram?

If the DHCP server is in a different vlan from where the users are you should have a relay agent to help the users reach the server leasing ip addresses.

What IP address are the users currently getting?

Regards.

Wilson B

View solution in original post

Highlighted

Ping Transit Failed is because of routing Loop or bad Routes.

Jawad

View solution in original post

3 REPLIES 3
Highlighted
Participant

Hello.

Can you post a topology diagram?

If the DHCP server is in a different vlan from where the users are you should have a relay agent to help the users reach the server leasing ip addresses.

What IP address are the users currently getting?

Regards.

Wilson B

View solution in original post

Highlighted

Ping Transit Failed is because of routing Loop or bad Routes.

Jawad

View solution in original post

Highlighted

Thanks to those who replied...and yes, my routes were bad.

Instead of the following routes:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 10.1.1.0 255.255.255.0 FastEthernet0/1

ip route 192.168.10.0 255.255.255.0 FastEthernet0/0

I should have had the single static route:

ip route 0.0.0.0 0.0.0.0 10.1.1.2

Q1)  I did not have the "default-router" configured in my DHCP pool - why my client wouldn't get a default gateway.

Q2) Answered via proper static route above

Q3) Also attributable to not having a default router configured for the DHCP pool.

And now it works.  I hope this helps someone in the future.

Content for Community-Ad