cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
614
Views
2
Helpful
4
Replies
Highlighted
Beginner

Home network

Hi all, I'm trying to experiment with a Layer 3 switch (Cisco 4948-10GE). My aim is to set this switch as part of my home network.

I'm trying to get routing working on it but seem to be hitting a wall somewhere. I've searched alot a round and cannot see what I am missing.

My basic setup is a BT Home infinity (FTTH) hub (192.168.1.254) connected directly to my L3 switch port G1/1, Config for this is

inteface GigabitEthernet1/1

description BT ADSL 300Mb

no switchport

ip address 192.168.1.10 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.254

Gateway of last resort is 192.168.1.254

I also have 2 test VLANS 10 and 20. Config for these are:

inteface vlan10

ip address 10.10.10.1 255.255.255.0

interface vlan20

ip address 20.20.20.1 255.255.255.0

Now if I have a port Gi1/10  in vlan 10  and connect a PC to it, I cannot access the Internet. although the default route is set as mentioned above.

The PC picks up a 192.168.1.x address from the DHCP on the BT Infinity Hub. So could this be the problem? i.e. a 192.168.1.x device in VLAN 10 ?

I can ping the gateway from the switch but not from the PC.

I've not tried pinging a device from vlan 10 to vlan 20 as yet. I just wanted to sort out the Internet access first.

Any advice guys?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Home network

Hello Hussain,

It's my understanding that you have the following scenario and configuration:

  +------------+          +------------+

  |BT Home    |    Gi1/1|Cat4948    |

  |Infinity Hub+----------+            |

  |192.168.1.254          |            |

  +------------+          +------------+

                                |G1/10

                                |Vlan 10

                                |

                                |

                                |

                          +------+-----+

                          |            |

                          |  PC      |

                          |            |

                          +------------+

                          192.168.1.X

inteface GigabitEthernet1/1

description BT ADSL 300Mb

no switchport

ip address 192.168.1.10 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.254

interface vlan10

ip address 10.10.10.1 255.255.255.0

-----------------------

Based on what you have described, I would suggest trying a different approach regarding the configuration of the Catalyst 4948 switch.

One quick question, are you able to ping a destination on the Internet from the switch?

Try ping 8.8.8.8

* Please keep in mind that even if you manually configure the PC manually to have an IP address in subnet 10.10.10.0/24, you'll need to ensure that the BT Hub performs the network address translation (NAT) so that the traffic from the PC can be routable on the Global Internet by translating its private IP address to a public IP address.

* Please consider defaulting the configuration of interface Gi1/1 connecting to the BT HUB:

configure terminal

default interface Gi1/1

end

!

* You can create a new SVI or use VLAN 10 SVI but with an IP address in the 192.168.1.0/14 network.

configure terminal

interface vlan10

ip address 192.168.1.10 255.255.255.0

no shut

end

!

* Then you could assign both interfaces Gi1/1 and Gi1/10 to VLAN 10

configure terminal

interface Gi1/1

  switchport

  switchport mode access

  switchport access vlan 10

  spanning-tree portfast

  no shut

  exit

  !

interface Gi1/10

  switchport

  switchport mode access

  switchport access vlan 10

  spanning-tree portfast

  no shut

  end

  !

* Make sure that IP routing is enabled on the switch and also that you still have the default route pointing to the BT HUB.

configure terminal

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.1.254

end

!

* After this, the PC should still receive an IP address in the 192.168.1.0/24 network and should be able (if the proper NAT rules are in place) to surf the Internet. You should also be able to ping the BT home hub and a destination on the Internet, like 8.8.8.8, from the PC.

Please let me know if this configuration solves your issue.

4 REPLIES 4
Community Manager

Re: Home network

Tawqeer,

I am moving your post to the Switching community space for better visibility and access to feedback.

Switching

Kelli Glass

Moderator for Cisco Customer Communities

Cisco Employee

Re: Home network

Hello Hussain,

It's my understanding that you have the following scenario and configuration:

  +------------+          +------------+

  |BT Home    |    Gi1/1|Cat4948    |

  |Infinity Hub+----------+            |

  |192.168.1.254          |            |

  +------------+          +------------+

                                |G1/10

                                |Vlan 10

                                |

                                |

                                |

                          +------+-----+

                          |            |

                          |  PC      |

                          |            |

                          +------------+

                          192.168.1.X

inteface GigabitEthernet1/1

description BT ADSL 300Mb

no switchport

ip address 192.168.1.10 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.1.254

interface vlan10

ip address 10.10.10.1 255.255.255.0

-----------------------

Based on what you have described, I would suggest trying a different approach regarding the configuration of the Catalyst 4948 switch.

One quick question, are you able to ping a destination on the Internet from the switch?

Try ping 8.8.8.8

* Please keep in mind that even if you manually configure the PC manually to have an IP address in subnet 10.10.10.0/24, you'll need to ensure that the BT Hub performs the network address translation (NAT) so that the traffic from the PC can be routable on the Global Internet by translating its private IP address to a public IP address.

* Please consider defaulting the configuration of interface Gi1/1 connecting to the BT HUB:

configure terminal

default interface Gi1/1

end

!

* You can create a new SVI or use VLAN 10 SVI but with an IP address in the 192.168.1.0/14 network.

configure terminal

interface vlan10

ip address 192.168.1.10 255.255.255.0

no shut

end

!

* Then you could assign both interfaces Gi1/1 and Gi1/10 to VLAN 10

configure terminal

interface Gi1/1

  switchport

  switchport mode access

  switchport access vlan 10

  spanning-tree portfast

  no shut

  exit

  !

interface Gi1/10

  switchport

  switchport mode access

  switchport access vlan 10

  spanning-tree portfast

  no shut

  end

  !

* Make sure that IP routing is enabled on the switch and also that you still have the default route pointing to the BT HUB.

configure terminal

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.1.254

end

!

* After this, the PC should still receive an IP address in the 192.168.1.0/24 network and should be able (if the proper NAT rules are in place) to surf the Internet. You should also be able to ping the BT home hub and a destination on the Internet, like 8.8.8.8, from the PC.

Please let me know if this configuration solves your issue.

Advisor

Re: Home network

If you want the switch to route, then the question is whether the BT Hub knows about the 10.x.x.x network. My guess is that it does not. Do you have the ability to configure that device or is it managed by your ISP? If you can configure it then you need to add a route to it that points the 10.x.x.x subnet to the 192.168.1.10 address. If the ISP manages it then you will not be able to do routing unless the switch is capable of NAT. which I don't believe it is. All this trouble is because your ISP is expecting data only from the 192.168.1.x subnet.


I hope this is helpful.

Beginner

Re: Home network

Hi Andres, First of all apologies for a late response.

To answer your question, yes I could ping 8.8.8.8 from the switch but obviously not from the PC.

I have configured as you mentioned and it all works great. I can access the internet fine now.

My next step is to be able to do inter-vlan routing between VLAN 10 and VLAN 20 for example.

I know I'll need to setup a router for this as the 4948 switch for some reason will not do NATing although the commands are there.

Will have a look at this next time.

Thanks for your help.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards