cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
586
Views
1
Helpful
14
Replies

How can you distribute IP addresses to several vlans with Windows DHCP

atamullayevh
Level 1
Level 1

Hello everyone, I have this situation, I installed a DHСP server on a Windows server 2012r and connected a Cisco Catalyst 3650 L3 as an access to the port. The server should distribute IP addresses to more than 50 vlans, but I only distribute one vlan. How can I distribute the IP address to each vlan separately?

14 Replies 14

balaji.bandi
Hall of Fame
Hall of Fame

each VLAN add IP helper address (DHCP Server IP)

interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip helper-address 192.168.1.1 (192.168.1.1 - helper address of MSDHCP Server) .

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks for the answer, I wrote this command for each vlan but it still doesn’t work, the port to which I connected the server should be access or trunk?

 Of dhcp direct connect to l3sw then you need to 

1- ip routing in SW 

2- ip helper address under each vlan 

3- port connect to dhcp is access port 

MHM

ip routing
!
no ip domain-lookup
ip domain-name uzbeksteel.uz
no ip dhcp snooping information option
!
!
login on-failure log
qos queue-softmax-multiplier 100
!
crypto pki trustpoint TP-self-signed-333237927
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-333237927
revocation-check none
rsakeypair TP-self-signed-333237927
!
!
crypto pki certificate chain TP-self-signed-333237927
certificate self-signed 01
30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33333332 33373932 37301E17 0D313630 31313631 31323435
315A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3333 33323337
39323730 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
B92F15BA 93E7CE5E 14C59EC7 6E011B68 C529F404 F96A6321 A729177B 9C8FE217
15F9EAE6 3EC55EA3 40A9739F 6BD15F23 6198E760 2B149C34 BD881418 A7913897
712433AE 734D7572 0670CF5D F5DE9757 C84DF856 D3EAAD5B F8BDB4CE A9D4F0F4
4A773D21 100D901D 324E2384 042C40B6 7D465318 01B9B240 A9EA22A5 A36A8E4F
02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
23041830 1680143D 725AEE8B 440935AA E5D66BEA E4AE1A8D C703B830 1D060355
1D0E0416 04143D72 5AEE8B44 0935AAE5 D66BEAE4 AE1A8DC7 03B8300D 06092A86
4886F70D 01010505 00038181 00338F9B A4BBE72D D03A8BE0 7A6A9F06 80AD6E88
DF2A8161 C639612B A2C5CACC 8A5F4476 448A009D C98D1440 2DF0A9A1 10B249AA
568D97EE 25F85460 B97146F2 29145A4B E85ED1F2 5DD014A5 8661754C DB6444D4
B78BA61F 1E6075C4 7BCEAF6A DBC9A57B 11CF2BD5 460DC646 5D211D08 88E526F8
C81255DA BDCFB466 07988C04 B3
quit
errdisable recovery cause storm-control
diagnostic bootup level minimal
archive
log config
logging enable
notify syslog contenttype plaintext
hidekeys
path tftp://167.124.0.12/ku4-11
write-memory
time-period 10080
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 30-33
spanning-tree vlan 7-8 priority 24576
hw-switch switch 1 logging onboard message level 3
!
redundancy
mode sso
!
!
!
class-map match-any non-client-nrt-class
!
policy-map port_child_policy
class non-client-nrt-class
bandwidth remaining ratio 10
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
no ip address
negotiation auto
!
interface GigabitEthernet1/0/1
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 7
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 8
switchport mode access
!
interface GigabitEthernet1/0/4
switchport mode access
!
interface GigabitEthernet1/0/5
switchport mode access
!
interface GigabitEthernet1/0/6
switchport mode access
!
interface GigabitEthernet1/0/7
switchport mode access
!
interface GigabitEthernet1/0/8
switchport mode access
!
interface GigabitEthernet1/0/9
switchport mode access
!
interface GigabitEthernet1/0/10
switchport mode access
!
interface GigabitEthernet1/0/11
switchport mode access
speed 1000
!
interface GigabitEthernet1/0/12
switchport mode access
!
interface GigabitEthernet1/0/13
switchport mode access
!
interface GigabitEthernet1/0/14
switchport mode access
!
interface GigabitEthernet1/0/15
switchport mode access
!
interface GigabitEthernet1/0/16
switchport mode access
!
interface GigabitEthernet1/0/17
switchport mode access
!
interface GigabitEthernet1/0/18
switchport mode access
!
interface GigabitEthernet1/0/19
switchport mode access
!
interface GigabitEthernet1/0/20
switchport mode access
!
interface GigabitEthernet1/0/21
switchport mode access
!
interface GigabitEthernet1/0/22
switchport mode access
!
interface GigabitEthernet1/0/23
switchport trunk allowed vlan 1,7,8,100
switchport mode trunk
!
interface GigabitEthernet1/0/24
switchport trunk allowed vlan 1,7,8,100
switchport mode trunk
!
interface GigabitEthernet1/1/1
switchport mode access
ip dhcp snooping trust
!
interface GigabitEthernet1/1/2
switchport mode access
!
interface GigabitEthernet1/1/3
switchport mode access
!
interface GigabitEthernet1/1/4
switchport mode access
!
interface Vlan1
ip address 167.124.100.11 255.255.0.0
!
interface Vlan7
ip address 172.16.7.254 255.255.255.0
ip helper-address 167.124.100.101
!
interface Vlan8
ip address 172.16.8.254 255.255.255.0
ip helper-address 167.124.100.101
!
interface Vlan100
ip address 172.16.100.12 255.255.255.0
!
interface Vlan103
ip address 172.16.101.10 255.255.255.252
!
!
router eigrp 100
network 172.16.7.254 0.0.0.0
network 172.16.8.254 0.0.0.0
network 172.16.101.10 0.0.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server

 

everything you showed has already been written

Sw#show ip dhcp server statistics

 Share this

MHM

C3650(config)#do show ip dhcp server statistics
Memory usage 14833
Address pools 0
Database agents 0
Automatic bindings 0
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0
Renew messages 0
Relay bindings 0
Relay bindings active 0
Relay bindings terminated 0
Relay bindings selecting 0

Message Received
BOOTREQUEST 0
DHCPDISCOVER 7330
DHCPREQUEST 16
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 104
DHCPVENDOR 0
BOOTREPLY 0
DHCPOFFER 0
DHCPACK 0
DHCPNAK 0

Message Sent
BOOTREPLY 0
DHCPOFFER 0
DHCPACK 0
DHCPNAK 0

Message Forwarded
BOOTREQUEST 0
DHCPDISCOVER 2198
DHCPREQUEST 12
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0
DHCPVENDOR 0
BOOTREPLY 0
DHCPOFFER 0
DHCPACK 0
DHCPNAK 0

55% of DHCP issue in community not solve because we dont get how the topology is
So I draw topology according to info you provide 
check the topology is it correct ?
if Yes 
then show ip dhcp  server stat show that the Core SW (R2) is receive the DHCP request but there is no answer form the server 

check
1- if access SW using dhcp snooping , disable add the op82 information option 
2- the config of server DHCP network must include the default router IP which must be same as VLAN SVI of Core SW (R2)

Screenshot (136).png

The topology is the same as you drew. The switches have a static IP address in 1 vlan. I can’t distribute IP in vlan 7

First 

Are you use dhcp snooping?

Second can you share the config of dhcp server 

MHM

If you are using VLAN 1 as default and that should be in routing cable, make sure other side also have route back to switch.

what VLAN you getting DHCP ?

can you post show ip route and show ip eigrp  neigh

i do not see the Network in your EIGRP

167.124.100.11 255.255.0.0

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

C3650#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

167.124.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 167.124.0.0/16 is directly connected, Vlan1
L 167.124.100.11/32 is directly connected, Vlan1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.7.0/24 is directly connected, Vlan7
L 172.16.7.254/32 is directly connected, Vlan7

My dhсp server is on vlan 1. 167.124.100.11 255.255.0.0 this IP has not been added to dynamic routing. All switches are in 1 vlan. 

what VLAN you getting DHCP IP (what IP client get it ) ?what VLAN you are not getting IP from DHCP ?

i do not see any routes learned from EIGRP - is that working ?

show ip eigrp  neigh

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Yes this eigrp works

 

#show ip eigrp neigh
EIGRP-IPv4 Neighbors for AS(100)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.101.19 Vl103 13 13w0d 11 100 0 1508

From DHCP Server IP, can you ping the SVI (where the device not getting IP address) post the results here

as i mentioned you have routing and reachability issue - also enmable debug on the switch where the DHCP IP not getting see what is wrong ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Review Cisco Networking for a $25 gift card