cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1136
Views
0
Helpful
3
Replies

How to configure an etherchannel between a switch and a server

Adrian Garcia
Level 1
Level 1

Hello,


Does any one has a sample configuration of how to configure an etherchannel between a switch and a server?

I already checked the link:

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a008089a821.shtml

But I need some more detail information about how the port-channel interface configuration looks like.

Thanks.

3 Replies 3

schooram
Level 1
Level 1

Hi Adrian,

you just need the following config on the switch side:

switch#conf t
switch(config)#int Gi 1/0
switch(config-if)#switchport mode access
switch(config-if)#switchport access vlan 100      //enter your server VLAN.
switch(config-if)#spanning-tree portfast
switch(config-if)#channel-group 1 mode active

switch(config)#int Gi 2/0
switch(config-if)#switchport mode access
switch(config-if)#switchport access vlan 100       //enter your server VLAN.
switch(config-if)#spanning-tree portfast
switch(config-if)#channel-group 1 mode active
switch(config-if)#exit

rest you need to configure on the server as per the link.

OR

else you can configure the following ( depending on the sw) on the port channel itself:

Switch(config)#int port-channel 2
Switch(config-if)#?
  cdp               Global CDP configuration subcommands
  channel-group     Etherchannel/port bundling configuration
  channel-protocol  Select the channel protocol (LACP, PAgP)
  description       Interface specific description
  duplex            Configure duplex operation.
  exit              Exit from interface configuration mode
  mac-address       Manually set interface MAC address
  mdix              Set Media Dependent Interface with Crossover
  mls               mls interface commands
  no                Negate a command or set its defaults
  shutdown          Shutdown the selected interface
  spanning-tree     Spanning Tree Subsystem
  speed             Configure speed operation.
  storm-control     storm configuration
  switchport        Set switching mode characteristics
  tx-ring-limit     Configure PA level transmit ring limit

br,

sandeep

Hi sandeep,

Thanks a lot for the information.

About the Port-channel interface, are there any command lines I need to add?

Hi Adrian,

As per the config example, you dont need to configure anything on the port channel.

The idea is , either configure under the port channel  ( and the same config will be applied to the links in the channel-group)

OR

Configure under the physical interfaces directly

cheers,

sandeep

Review Cisco Networking products for a $25 gift card