cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
497
Views
10
Helpful
8
Replies
23nick
Beginner

HSRP on subinterface (Both router showing active)

Hello everyone,

 

I tried lot of troubleshooting and couldn't come up with solution. Both my routers are showing hsrp active for group 10.

All interface of both switches are in trunk(encapsulation is dot1q). EDGE-R1 cannot ping EDGE-R2 subinterface ip and vice-versa. But both routers can ping virtual hsrp ip. When debug on both routers i see both are sending hello packet but seems not receiving each other hellos which i suspect switch problem.

 

But switch config also looks good, all interfaces of switches are in trunk and vlan 10 created.

Could someone please tell me what i am missing here. Any suggestions would be helpful .

 

Topology: https://i.imgur.com/xSEA4pY.png

 

Configuration

EDGE-R1#sh run int gi2.10
Building configuration...

Current configuration : 168 bytes
!
interface GigabitEthernet2.10
encapsulation dot1Q 10
ip address 22.1.1.1 255.255.255.240
standby 10 ip 22.1.1.14
standby 10 priority 200
standby 10 preempt
end

EDGE-R1#sh standby bri
P indicates configured to preempt.
|
Interface Grp   Pri  P   State   Active  Standby   Virtual IP
Gi2.10     10   200 P   Active local   unknown   22.1.1.14
EDGE-R1#
EDGE-R1#sh standby
GigabitEthernet2.10 - Group 10
State is Active
2 state changes, last state change 00:16:38
Virtual IP address is 22.1.1.14
Active virtual MAC address is 0000.0c07.ac0a (MAC In Use)
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.368 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 200 (configured 200)
Group name is "hsrp-Gi2.10-10" (default)

 

-------------------------------

EDGE-R2#sh run int gi1.10
Building configuration...

Current configuration : 143 bytes
!
interface GigabitEthernet1.10
encapsulation dot1Q 10
ip address 22.1.1.2 255.255.255.240
standby 10 ip 22.1.1.14
standby 10 preempt
end

EDGE-R2#sh standby br
P indicates configured to preempt.
|
Interface Grp  Pri P  State  Active  Standby  Virtual IP
Gi1.10    10  100 P Active  local  unknown  22.1.1.14
EDGE-R2#
EDGE-R2#
EDGE-R2#sh standby
GigabitEthernet1.10 - Group 10
State is Active
2 state changes, last state change 00:14:35
Virtual IP address is 22.1.1.14
Active virtual MAC address is 0000.0c07.ac0a (MAC In Use)
Local virtual MAC address is 0000.0c07.ac0a (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 0.928 secs
Preemption enabled
Active router is local
Standby router is unknown
Priority 100 (default 100)
Group name is "hsrp-Gi1.10-10" (default)

 

-----------------------

SW1#sh run int e0/0 -->Connected to EDGE-R1
Building configuration...

Current configuration : 103 bytes
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end

 

SW1#sh run int e0/1 -->Connected to SW2
Building configuration...

Current configuration : 103 bytes
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end

 

SW1#sh spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol ieee
Root ID Priority 32778
Address aabb.cc01.3000
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address aabb.cc01.3000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Desg FWD 100 128.2 Shr --->Connected to SW2

 

 

 

======================================

SW2#sh run int e0/0 -->Connected to EDGE-R2
Building configuration...

Current configuration : 103 bytes
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end

 

SW2#sh run int e0/1--Connected to SW2
Building configuration...

Current configuration : 103 bytes
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
end

 

 

SW2#sh spanning-tree vlan 10

VLAN0010
Spanning tree enabled protocol ieee
Root ID Priority 32778
Address aabb.cc01.3000
Cost 100
Port 2 (Ethernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address aabb.cc01.4000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec

Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0 Desg FWD 100 128.1 Shr
Et0/1 Root FWD 100 128.2 Shr -->Connected to SW1

 

 

While i was debugging on SW1 i see below logs (22.1.1.1 is EDGE-R1 subinterface IP)

SW1#
*Sep 13 09:14:05.438: IP: s=22.1.1.1 (Vlan10), d=224.0.0.2, len 48, input feature, packet consumed, MCI Check(82), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Sep 13 09:14:06.394: IP: s=22.1.1.2 (Vlan10), d=224.0.0.2, len 48, input feature, packet consumed, MCI Check(82), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
SW1#
*Sep 13 09:14:08.217: IP: s=22.1.1.1 (Vlan10), d=224.0.0.2, len 48, input feature, packet consumed, MCI Check(82), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Sep 13 09:14:09.126: IP: s=22.1.1.2 (Vlan10), d=224.0.0.2, len 48, input feature, packet consumed, MCI Check(82), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

 

 

Thanks

Nick

8 REPLIES 8
23nick
Beginner

Router image is :X86_64_LINUX_IOSD-UNIVERSALK9-M  (CSR- 1000V)

Switch Image is : Cisco IOS Software, Solaris Software (I86BI_LINUXL2-ADVENTERPRISEK9-M), Experimental Version 15.1(20140814:053243)

This is LAB on eve-ng

Hope this is not a real environment? if this LAB environment - i have seen this issue but not able to recollect the solution

 

but I suggest 2 steps : (this is just for test)

 

1. configure other side priority less than 200 or more than 200 depends on which one you want to be active / standby.

2. use standby use-bia  - see if that fixes the issue?



BB


*** Rate All Helpful Responses ***

@balaji.bandi 

I replaced CSR with 7200router and also EDGE-R2 i configured priority of 110 and it is working now. EDGE-R1 has priority of 200

Seems issue with router. Images like this take lot of time to make thing works, also we waste time troubleshooting configs and end up finding issue with images.

 

 

Could you please tell what this line means - " use standby use-bia  - see if that fixes the issue? "

That is the first input required from you as user, if this was real gear works as expected

Lab images, many fake images from different people over google, so are you using the right image  ( check the is the feature supported).

 

Like to know more about use-bia :

 

https://www.cisco.com/c/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/13782-8.html#:~:text=Configure%20the%20standby%20use%2Dbia,interface%20does%20not%20get%20reset.



BB


*** Rate All Helpful Responses ***

marce1000
VIP Advisor

 

 - hello-comm-failure should get resolved as also discussed in this  thread :

            https://community.cisco.com/t5/switching/both-hsrp-switches-on-active-state/td-p/1965995

 M.

Well my both switches has vlan 10 created and interfaces are also in trunk, and by default all vlans are allowed on trunk. It should work, not sure if its bug with switch or something else

 

 - On both routers and switch examine software versions being used. At least make sure they are not very old. Consider , if applicable and or feasible to upgrade to advisory releases (anyway).

 M.

replaced CSR with 7200router and started working. Seems issue with csr.

Thanks @marce1000