cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
582
Views
0
Helpful
7
Replies
Beginner

IGMP Configuration

Hi All,

I Want to configure IGMP snooping for IPTV server  i configured IPTV vlan 30 all connectivity are okay just need commands for CORE switch CAT4507 And access switch 2960 only for IGMP.

IPTV-Server>>>>CAT4507+E>>>>>>2960PSL>>>>>STB+TV

Help will be appriciated 

7 REPLIES 7
Hall of Fame Guru

IGMP Configuration

Are you only trying to do this within vlan 30 or do you want to route between vlans for the multicast stream ?

Jon

Beginner

IGMP Configuration

Thanks for the Quick Respo... BRO

for vlan 30 only will be best becoz i have vlans for CAM,DATA,VOICE below are the ports for IPTV in access switch.

interface gigabitEthernet 1/0/4

switchport mode access

switchport access vlan 30

spanning-tree portfast

no shut

exit

interface gigabitEthernet 1/0/5

switchport mode access

switchport access vlan 30

spanning-tree portfast

no shut

exit

interface gigabitEthernet 1/0/8

switchport mode access

switchport access vlan 30

spanning-tree portfast

no shut

exit

interface gigabitEthernet 1/0/12

switchport mode access

switchport access vlan 30

spanning-tree portfast

no shut

exit

Best Regards

Hall of Fame Guru

IGMP Configuration

If you are only doing it in one vlan then you need to have  -

1) IGMP snooping enabled. This should be enabled by default

2) an IGMP snooping querier enabled so that the switch makes IGMP queries for that vlan. You only need to configure this on one switch. The 4500 would be a good choice. See this link for configuring it -

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/50sg/configuration/guide/multi.html#wp1163784

Jon

Beginner

IGMP Configuration

Thanks again ,,,

       Problem is i am havin very basic knowldge abt switching what i understand.

1) i have to enable IGMP on spesfic vlan (ip igmp snooping vlan 30 ) on core switch

2) IGMP snooping querier (ip address of IPTV server ?)

3) no need to do anything in access switch my port configuration is okay ?

interface gigabitEthernet 1/0/12

switchport mode access

switchport access vlan 30

spanning-tree portfast

but if someone leave the stream the switch port will relax means gose normal immediately.

HAPPY CRISTMAS


Hall of Fame Guru

IGMP Configuration

1) You shouldn't have to as it should be enabled by default on both switches

2) The address should be the L3 vlan IP assigned to vlan 30 on the 4500.

3) your configuration is fine for the ports.

Happy Christmas to you as well

Jon

Highlighted
Beginner

HI Mr JON,          I  don,t

HI Mr JON,

          I  don,t know you are still available or not but i am facing a issue with same network i added one more ip head-end (DVB-Streamer) but traffic  flooded on stb middleware ip head-end and all STB,s are in same vlan 30.

Streamer,s broadcast ip address range is

streamer1 -239.99.1.x 

streamer2 -239.88.1.x 

 

CORE1#sh ip igmp snooping querier 
Vlan      IP Address               IGMP Version   Port             
-------------------------------------------------------------
30        10.121.55.1              v2            Switch  

 

------------------------------------------------------------------------

CORE1#sh ip igmp snooping groups 
Vlan      Group                    Version     Port List
---------------------------------------------------------
30        239.88.1.1               v2          Gi1/28, Gi2/13, Gi2/25
30        239.88.1.2               v2          Gi1/19, Gi2/16
30        239.88.2.1               v2          Gi1/1, Gi1/36, Gi2/19
30        239.88.3.1               v2          Gi2/18
30        239.88.4.1               v2          Gi1/6, Gi1/17, Gi1/29, 
                                                           Gi1/34, Gi1/38, Gi1/46
30        239.99.1.32              v2          Gi1/9, Gi1/10, Gi1/13, 
                                                           Gi1/15, Gi1/16, Gi1/22, 
                                                           Gi1/25, Gi1/26, Gi1/27, 
                                                           Gi1/30, Gi1/32, Gi1/41, 
                                                           Gi1/42, Gi1/47, Gi1/48
30        239.99.1.33              v2          Gi1/24
30        239.99.1.34              v2          Gi1/2, Gi1/33, Gi2/14
30        239.99.1.35              v2          Gi1/7
30        239.99.1.50              v2          Gi1/4
30        239.99.1.52              v2          Gi1/21
30        239.99.2.32              v2          Gi1/45
30        239.99.2.36              v2          Gi1/5, Gi1/18, Gi1/20, 
                                                           Gi1/31, Gi1/35, Gi2/1, 
                                                           Gi2/6, Gi2/18
30        239.99.3.14              v2          Gi1/3, Gi1/14, Gi1/40, 
                                                           Gi1/43
30        239.99.5.7               v2          Gi1/8
30        239.99.5.21              v2          Gi2/4
30        239.255.255.250          v2          Gi1/1, Gi1/2, Gi1/3, 
                                                           Gi1/4, Gi1/5, Gi1/6, 
                                                           Gi1/7, Gi1/8, Gi1/9, 
                                                           Gi1/10, Gi1/13, Gi1/14, 
                                                           Gi1/15, Gi1/16, Gi1/17, 
                                                           Gi1/18, Gi1/19, Gi1/20, 
                                                           Gi1/21, Gi1/22, Gi1/24, 
                                                           Gi1/25, Gi1/26, Gi1/27, 
                                                           Gi1/28, Gi1/29, Gi1/30, 
                                                           Gi1/31, Gi1/32, Gi1/33, 
                                                           Gi1/34, Gi1/35, Gi1/36, 
                                                           Gi1/38, Gi1/40, Gi1/41, 
                                                           Gi1/42, Gi1/43, Gi1/45, 
                                                           Gi1/46, Gi1/47, Gi1/48, 
                                                           Gi2/1, Gi2/4, Gi2/6, 
                                                           Gi2/13, Gi2/14, Gi2/16, 
                                                           Gi2/18, Gi2/19, Gi2/25

 

=======================================================

CORE1#sh ip igmp snooping mrouter 
Vlan    ports
----    -----
  30    Switch

=====================================================

CORE1#sh processes cpu history

    211121121213221111111121211121211212131111111222422232323221
    683419325641925654565575945434483352607645454641216617190956
100                                                                         
 90                                                                         
 80                                                                         
 70                                                                         
 60                                                                         
 50                                                                     *   
 40                                                 *                   ** *
 30 *        * **         * *            *       *  * *********   *  *******
 20 **  ** *** ****** ******* * * ** ******* * * ***************************
 10 ########################################################################
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7.
             0    5    0    5    0    5    0    5    0    5    0    5    0 
                       CPU% per hour (last 72 hours)
                    * = maximum CPU%   # = average CPU%

 

 

Any Help

Regards

               

 

 

Beginner

Hi  sheraz i hope you are

Hi  sheraz 

i hope you are fine 

sheraz now i have new IPTV project for hotel 

but i'm just want to ask you about client interface on the access switch speed,

all my access switches are WS-C2960+48PST-S 

and core switch is CISCO 3650

the interface speed 100MB so there is any problem with it or now ?

and what about the interfaces bandwidth in your access switches 

please answer me because it's major case for my project 

have nice day 

 

thanks 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards