cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
503
Views
0
Helpful
4
Replies

Interface Config for ONLY voice vlan?

mac1234
Level 1
Level 1

We have most of our ports configured for both data and voice using the Cisco method of using switchport voice vlan.  Example of our config:

 

interface GigabitEthernet1/0/1
 switchport access vlan 10
 switchport mode access
 switchport voice vlan 20
 no mdix auto
 spanning-tree portfast
 spanning-tree guard root
end

However, I want to change this config to simply allow the voice vlan 20 on this port. What would be the proper config?

 

Would I  simply remove the switchport voice vlan 20 and set the access vlan to 20?  Or would I set this some other way?  Does "siwtchport voice vlan" do anything else behind the scenes (add headers, set QoS, etc)other than simply create an auxilary vlan for voice?

4 Replies 4

Reza Sharifi
Hall of Fame
Hall of Fame

If you just want to use the port for a phone (vlan 20), you can remove the data port

 

no switchport access vlan 10 

HTH


@Reza Sharifi wrote:

If you just want to use the port for a phone (vlan 20), you can remove the data port

 

no switchport access vlan 10 

HTH


Ok. Easy enough. 

 

However, does "switchport voice vlan" do anything else other than create a separate VLAN for voice traffic?  Would simply using:

 

interface GigabitEthernet1/0/1
 switchport access vlan 20
 switchport mode access
 no mdix auto
 spanning-tree portfast
 spanning-tree guard root
end

and then manually assign the vlan id 20 on the phone accomplish the same thing as using switchport voice vlan?

Well, the phone needs to be in voice vlan, because that vlan needs special options added like option 150 for TFTP.

HTH 


@mac1234 wrote:
no switchport access vlan <DATA VLAN>

This means the data VLAN gets assigned to VLAN 1.  Is VLAN 1 enabled in the network?  

Review Cisco Networking for a $25 gift card