cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
28206
Views
0
Helpful
15
Replies
nareh84
Participant

interface output errors

hi

on one end i have WS-C3850-48P and on the other end i have WS-C2960X-48FPD-L. Daily for sometime i receive alert for output error on particular interfaces which are part of portchannel of WS-C3850-48P. Daily i face this issue during business hours particularly on those ports. while on the other end (WS-C2960X-48FPD-L) there are no errors. what steps should i follow to troubleshoot this issue.

GigabitEthernet1/0/47 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 00a2.89d4.77af (bia 00a2.89d4.77af)
Description:  G1/0/47
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters 24w4d
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 2114058
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 5000 bits/sec, 7 packets/sec
5 minute output rate 24000 bits/sec, 25 packets/sec
1026930025 packets input, 112466646250 bytes, 0 no buffer
Received 24954970 broadcasts (12794372 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 12794372 multicast, 0 pause input
0 input packets with dribble condition detected
618833910 packets output, 93620061474 bytes, 0 underruns
2114058 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

On both end show int status show a-1000 and full duplex

#sh int status

Gi1/0/47  Switch  connected    trunk      a-full a-1000 10/100/1000BaseTX

#sh int gigabitEthernet 1/0/47 counters errors

Port      Align-Err FCS-Err   Xmit-Err     Rcv-Err  UnderSize OutDiscards
Gi1/0/47 0                 0        2114058         0          0               2114058

Port             Single-Col Multi-Col Late-Col Excess-Col Carri-Sen Runts
Gi1/0/47           0                  0             0              0             0          0

15 REPLIES 15
Julio E. Moisa
VIP Mentor

Hi

Have you replaced the cabling? or try using other port?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

yes, we replaced the cabling but not ports.

Aparently the problem is with the switch with port 47, output errors but not input errors. Try to clear the counters and verify again if there is unidirectional problem. 

clear counters g1/0/47




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

currently, output errors are not increasing. but i receive alert daily for 1~2 hours, only for output error.

I see, try to discard the port, changing that during a maintenance window. 

You also can diagnose the performance of an interface, using diagnose interface, i recommend use it during a maintenance window as well.

http://www.cisco.com/c/en/us/td/docs/server_nw_virtual/2-7-0_release/command_reference/commref/diag.html




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Could following be the issue?

I can see on WS-C3850-48P when i do sh int trunk. more vlans are  allowed

#sh int trunk | incl 13
Po13        on               802.1q         trunking      1
Po13        1-4094
Po13        1,100-101,103,200,212,221,259,310,322,340-342,347-348,361,410,920-925
Po13        1,100-101,103,200,212,221,259,310,322,340-342,347-348,361,410,920-925

But when i do sh int trunk on the other switch. few vlans are configured/allowed.

sh int trunk
Port        Mode             Encapsulation  Status        Native vlan
Po13        on               802.1q         trunking      1
Port        Vlans allowed on trunk
Po13        1-4094
Port        Vlans allowed and active in management domain
Po13        1,200,212,322,340-342,347,361
Port        Vlans in spanning tree forwarding state and not pruned
Po13        1,200,212,322,340-342,347,361

Could you please share the port (physical and logical ports) configuration of both switches? is there any vlan filtering under the etherchannel?




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

on 3850 switch:

------------------------

#sh run int gig 1/0/47
Building configuration...
Current configuration : 133 bytes
!
interface GigabitEthernet1/0/47
 description  @ G1/0/47
 switchport mode trunk
 channel-group 13 mode active
end
#sh run int gig 2/0/47
Building configuration...
Current configuration : 133 bytes
!
interface GigabitEthernet2/0/47
 description @ G1/0/48
 switchport mode trunk
 channel-group 13 mode active
end
#sh run int po 13
Building configuration...
Current configuration : 86 bytes
!
interface Port-channel13
 description sw03
 switchport mode trunk
end
On 2960 Switch:
-----------------------
interface GigabitEthernet1/0/47
 description  @ G1/0/47
 switchport mode trunk
 power inline never
 channel-group 13 mode active
end
ntl-per-sw03#sh run int gig 1/0/48
Building configuration...
Current configuration : 153 bytes
!
interface GigabitEthernet1/0/48
 description @ G2/0/47
 switchport mode trunk
 power inline never
 channel-group 13 mode active
end
!
ntl-per-sw03#sh run int po 13
Building configuration...
Current configuration : 86 bytes
!
interface Port-channel13
 description sw02
 switchport mode trunk
end

Hi

Thank you, Your configuration look fine, keep monitoring the port or try testing with other port.




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<
Leo Laohoo
VIP Community Legend

2114058 output errors

I know what this is:  Incorrect QoS configuration. 

Look at the value of the "output errors" and "Total Output Drops", the numerical values are exactly the same

Enter the command "sh  interface G 1/0/47 controller" and you'll find the same value to be reflected in "Excess Defer Frames" (left-hand column).  

yes both the values are same in

#sh int gig 1/0/47

2206900 output errors

#sh int gig 1/0/47 controller

2206900 Excess Defer frames

currently qos is not configured for this interface. could you guide me regarding the qos configuration on this interface or should i start with change the ports first?

 

Leo Laohoo
VIP Community Legend

currently qos is not configured for this interface. could you guide me regarding the qos configuration on this interface or should i start with change the ports first?

Sorry, I'm no QoS person.  Joseph Doherty is CSC's "in house" QoS person.  I've sent him a PM  to look at this thread.

Hi Leo,

 

In my case, the values are not the same.

 

Switch#sh int GigabitEthernet0/2 controller 

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 89

89 output errors, 0 collisions, 0 interface resets

 0 Excess defer frames 

Swicth#sh run int GigabitEthernet0/2
Building configuration...

Current configuration : 137 bytes
!
interface GigabitEthernet0/2
description **Conneceted to Firewall-Port 19**
switchport access vlan 140
switchport mode access
end

 

What needs to be done. Please advise

v.madhukar.ghole
Beginner

Hi
Also have same problem on WS-C3650-48TD switch getting output error on interface

Port Align-Err FCS-Err Xmit-Err Rcv-Err UnderSize OutDiscards
Gi1/0/26 0 0 434465 0 0 434465
\
Port Single-Col Multi-Col Late-Col Excess-Col Carri-Sen Runts
Gi1/0/26 0 0 0 0 0 0

what step to start troubleshoot this issue.