cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Interface port-channel btw N2K and Brocade VDX

Matthieu DURIEUX
Beginner
Beginner

Dear all,

I tried to configure a port-channel between a nexus 2K (2FEX) and a brocade VDX (VDX6710).

As you seen below, my configuration :

N2K

-------

Po10

switchport access vlan 200

Eth101/1/6

switchport access vlan 200

channel-group 10 mode active (used LACP)

Eth102/1/6

switchport access vlan 200

channel-group 10 mode active (used LACP)

VDX

------

interface Port-channel 27

vlag ignore-split

speed 1000

switchport

switchport mode access

switchport access vlan 200

spanning-tree shutdown

no shutdown

interface GigabitEthernet 21/0/31

channel-group 27 mode active type standard

lacp timeout long

no shutdown

interface GigabitEthernet 22/0/31

channel-group 27 mode active type standard

lacp timeout long

no shutdown

Unfortunately, we can't up the link for interfaces and so the port-channel.

We have the next message from the N5K for FEX :

%ETHPORT-5-IF_ADMIN_UP: Interface Ethernet101/1/6 is admin up .

%ETHPORT-5-SPEED: Interface Ethernet101/1/6, operational speed changed to 1 Gbps

%ETHPORT-5-IF_DUPLEX: Interface Ethernet101/1/6, operational duplex mode changed to Full

%ETHPORT-5-IF_RX_FLOW_CONTROL: Interface Ethernet101/1/6, operational Receive Flow Control state changed to off

%ETHPORT-5-IF_TX_FLOW_CONTROL: Interface Ethernet101/1/6, operational Transmit Flow Control state changed to on

%ETHPORT-5-IF_UP: Interface Ethernet101/1/6 is up in mode access

%ETHPORT-5-IF_DOWN_NONE: Interface Ethernet101/1/6 is down (None)

%ETHPORT-5-IF_DOWN_ERROR_DISABLED: Interface Ethernet101/1/6 is down (Error disabled. Reason:BPDUGuard)

Any idea about the configuration ?

Thanks for your help.

Matthieu

7 REPLIES 7

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Hi,

A FEX can only be a child of Nexus 5k, 6k and 7k and not other vendors (Brocade) switches.

HTH

Hi Reza,

I only forgot to say that my brocade is directly connected to my N2K. It's working fine with a catalyst switches but not with the VDX brocade.

                     N5K

                    |      |

                 N2K N2K

                    |      |

                     VDX

N5K and 2K are online. Not connection between the cisco and the brocade in my port-channel.

Thx for your help.

Matthieu

Fexes are really made to connect hosts and not switches .  So the ports should not see bpdu's so bpduguard is err-disabling the ports.          

Spanning Tree Protocol

HIFs go down with the BPDUGuard errDisable message

HIFs go down accompanied with the message, BPDUGuard errDisable.

Possible Cause

By default, the HIFs are in STP edge mode with the BPDU guard enabled.  This means that the HIFs are supposed to be connected to hosts or  non-switching devices. If they are connected to a non-host device/switch  that is sending BPDUs, the HIFs become error-disabled upon receiving a  BPDU.

Solution

Enable the BPDU filter on the HIF and on the peer connecting device.  With the filter enabled, the HIFs do not send or receive any BPDUs. Use  the following commands to confirm the details of the STP port state for  the port:

Hi,

Ok, it is clear now.  I see this in your log:

Error disabled. Reason:BPDUGuard

Is VDX a switch or a host? The 2ks are designed to connect to hosts and not other switches.

Or you can try disablring STP on the broacde and see if that works.

HTH

Hi,

The VDX is used as a switch. With the command 'spanning-tree shutdown' from the VDX, we didn't try to up the link (as shown in my original message). May I use the spanning-tree bpdufilter enable of my interfaces from N2K ?

Thx for your help.

Matthieu