06-21-2012 03:38 PM - edited 03-07-2019 07:23 AM
Hi folks,
it looks that if I specify the incoming interface for the EIGRP updates then the filter does not longer work, see router 7 under section "router eigrp"
If I don't specify the interface everything works perfectly.
Topology:
R8---R7---R3
Relevant configurations
--------------- R7 ---------------
version 12.4
!
hostname R7
!
ip cef
!
interface FastEthernet0/0
ip address 192.168.1.7 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.77.254 255.255.255.0
duplex auto
speed auto
!
router eigrp 23
network 192.168.1.0
distribute-list 1 in FastEthernet0/0
auto-summary
!
router ospf 2
log-adjacency-changes
redistribute eigrp 23 subnets
network 192.168.77.0 0.0.0.255 area 0
!
access-list 1 deny 192.168.88.0
access-list 1 deny 10.10.2.64 0.0.0.63
access-list 1 deny 10.10.3.128 0.0.0.63
access-list 1 permit any
access-list 2 deny 172.16.77.0 0.0.0.255
access-list 2 permit any
!
--------------- R8 ---------------
version 12.4
!
hostname R8
ip cef
!
interface FastEthernet0/0
ip address 192.168.1.8 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.88.254 255.255.255.0
duplex auto
speed auto
!
interface Ethernet1/0
ip address 10.10.1.254 255.255.255.224
half-duplex
!
interface Ethernet1/1
ip address 10.10.2.126 255.255.255.192
half-duplex
!
interface Ethernet1/2
ip address 10.10.3.190 255.255.255.240
half-duplex
!
interface Ethernet1/3
ip address 10.10.3.158 255.255.255.224
half-duplex
!
router eigrp 23
network 10.10.0.0 0.0.255.255
network 192.168.1.0
network 192.168.88.0
no auto-summary
!
--------------- R3 ---------------
version 12.4
!
hostname R3
!
ip cef
!
interface FastEthernet0/0
ip address 172.16.77.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.77.3 255.255.255.0
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
network 172.16.77.3 0.0.0.0 area 0
network 192.168.77.3 0.0.0.0 area 0
!
-------------------------------------
R7#sh ip ei top
IP-EIGRP Topology Table for AS(23)/ID(192.168.77.254)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.88.0/24, 1 successors, FD is 30720
via 192.168.1.8 (30720/28160), FastEthernet0/0
P 10.10.2.64/26, 1 successors, FD is 284160
via 192.168.1.8 (284160/281600), FastEthernet0/0
P 192.168.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 10.10.3.128/27, 1 successors, FD is 284160
via 192.168.1.8 (284160/281600), FastEthernet0/0
P 10.10.3.176/28, 1 successors, FD is 284160
via 192.168.1.8 (284160/281600), FastEthernet0/0
P 10.10.1.224/27, 1 successors, FD is 284160
via 192.168.1.8 (284160/281600), FastEthernet0/0
R7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
D 192.168.88.0/24 [90/30720] via 192.168.1.8, 00:04:25, FastEthernet0/0
C 192.168.77.0/24 is directly connected, FastEthernet0/1
172.16.0.0/24 is subnetted, 1 subnets
O 172.16.77.0 [110/2] via 192.168.77.3, 00:04:46, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
D 10.10.2.64/26 [90/284160] via 192.168.1.8, 00:04:25, FastEthernet0/0
D 10.10.3.128/27 [90/284160] via 192.168.1.8, 00:04:25, FastEthernet0/0
D 10.10.3.176/28 [90/284160] via 192.168.1.8, 00:04:26, FastEthernet0/0
D 10.10.1.224/27 [90/284160] via 192.168.1.8, 00:04:26, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
R7#
So the ACL 1 should filter some networks but it does not. If I remove the interface option then everything works as expected.
My understanding is that I can select the interface on which filter the updates but it does not work in my scenario.
Am I wrong with my understanding or/and with my configs?
I refer to this document:
http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080208748.shtml
Thx in advance for any help,
Alex
Solved! Go to Solution.
06-22-2012 04:40 AM
I'm running:
Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(15)T14,
And it works perfectly...
06-22-2012 02:46 AM
I found a similar case here:
06-22-2012 04:09 AM
Your understanding is correct and it works for me. What IOS version are you running? Are you doing this on real equipment or GNS?
06-22-2012 04:35 AM
Hi J,
thanks for your confirmation.
The version I'm playing with is 12.4(15)T7. I see this on GNS.
Meanwhile I've found this post
http://ieoc.com/forums/p/15537/131577.aspx
Likely it's a bug, wondering which one...
I'll see if with 12.4(24)T2 the weirdness disappears...
Do you perhaps have more info on that?
Thanks,
Alex
06-22-2012 04:40 AM
I'm running:
Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(15)T14,
And it works perfectly...
06-27-2012 01:20 AM
Hi J,
indeed with 12.4.17 I don't see the issue either. It must be a bug.
Thanks for your contribution to solve the issue
Alex
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide