12-04-2007 03:01 AM - edited 03-05-2019 07:48 PM
Hi all!
I have 3560g with EMI. I connect my PC to GEth0/3 3560g and create SVI with address x.x.x.209 255.255.255.240, on my PC address is x.x.x.210 255.255.255.240. I add Linksys SRW224G4 to GEth0/2 port 3560g. I have trunk between 3560g and Linksys. Linksys has management vlan 553 and 10.0.77.70/27 address in this vlan. I create SVI (vlan 553) on 3560g with address 10.0.77.65 255.255.255.224. Linksys has default-gateway 10.0.77.65.
3560G:
...
!
ip routing
...
!
interface Vlan201
ip address x.x.x.209 255.255.255.240
...
!
interface Vlan553
ip address 10.0.77.65 255.255.255.224
#sh ip route | i 10.0.77
C 10.0.77.64/27 is directly connected, Vlan553
#sh ip route | i x.x.x
x.x.x.0/28 is subnetted, 1 subnets
C x.x.x.208 is directly connected, Vlan201
I can ping 10.0.77.65 from my PC and I can ping x.x.x.209 from Linksys, but I can't ping 10.0.77.70 (Linksys) from my PC and I can't ping x.x.x.210 (PC) from Linksys.
I enable debug ip icmp packet, when I ping Linksys from PC or I ping PC from Linksys I'm not see anything. When I ping 10.0.77.65 from PC I see rows with echo requests and echo replies. I see is similar for Linksys.
What is problem may be?
12-04-2007 09:40 AM
Assign a port membership on G0/3 for Vlan 201
switchport mode access
switchport access vlan 201
and G0/2 should be assigned to 553
switchport mode access
switchport access vlan 553
I haven't played around with that LinkSys model but I think you are having problems with the trunk. You don't need a trunk for this configuration to work.
12-04-2007 10:53 PM
!
interface GigabitEthernet0/2
description ###LinkSYS###
switchport trunk encapsulation dot1q
switchport mode trunk
...
!
interface GigabitEthernet 0/3
description ###PC###
no switchport
ip address x.x.x.209 255.255.255.240
These interfaces has already configured. I want use trunk, because I want connect clients to Linksys.
12-04-2007 11:34 PM
Hi Zakini ,
I would like to know few things..
1.you have configured same ip on 3560g on two interfaces ..i.e
interface Vlan201
ip address x.x.x.209 255.255.255.240
and
interface GigabitEthernet 0/3
description ###PC###
no switchport
ip address x.x.x.209 255.255.255.240
how come it is possible.
have you got any message saying that ip conflict or host flapping on 3560g switch...
assign different ip subnet on g0/3 and do the routing on linksys switch and check the issue...
Thanks,
satish
12-05-2007 01:01 AM
Sorry, I mistake, I try two ways. Now config is:
!
ip routing
...
!
interface GigabitEthernet0/2
description ###LinkSYS###
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet 0/3
description ###PC###
no switchport
ip address x.x.x.209 255.255.255.240
...
!
interface Vlan553
ip address 10.0.77.65 255.255.255.224
#sh ip route | i 10.0.77
C 10.0.77.64/27 is directly connected, Vlan553
#sh ip route | i x.x.x
x.x.x.0/28 is subnetted, 1 subnets
C x.x.x.208 is directly connected, GigabitEthernet0/3
I'm not have ping from PC to LinkSYS
12-05-2007 01:28 AM
Hi ,
Then configuration on routers must be like ...
ip routing
interface g0/3
no switchport
ip address x.x.x.209 255.255.255.240
...
interface Vlan553
ip address 10.0.77.65 255.255.255.224
Pc ip's :
x.x.x.210 255.255.255.240.
gateway x.x.x.209
ip route 0.0.0.0 0.0.0.0 10.0.77.66
configure default route on linksys switch
ip route 0.0.0.0 0.0.0.0 10.0.77.65.
Check the issue...
Thanks,
satish
12-05-2007 01:43 AM
Ok, but I'm not have ping Linksys from PC
12-05-2007 01:49 AM
Hi ,
have you configured default route on both the switches ..
why did you configure g0/3 as a routing port..
have yoy tried same thing by configuring vlan x with x.x.x.209 ip addrress...by removing x.x.x.209 from g0/3 interface.
g0/3 --- switchport mode access
switchport access vlan x.
and assign one port of 3560g in vlan x and
try to ping to linksys switch.
Thanks,
satish
allow these two vlans through trunk.
Thanks,
satish
12-05-2007 11:43 PM
Hi!
I have default route on Linksys and my PC has static route to network Linksys. I can ping from PC to gateway of network linksys.
I change my config:
!
ip routing
...
!
interface GigabitEthernet0/2
description ###Linksys###
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/3
switchport access vlan 201
switchport mode access
!
...
!
interface Vlan201
ip address x.x.x.209 255.255.255.240
...
!
interface Vlan553
ip address 10.0.77.65 255.255.255.224
I'm not have ping from PC to Linksys
12-05-2007 08:20 AM
Can you please configure the switchports as suggested ?
_________________
Assign a port membership on G0/3 for Vlan 201
switchport mode access
switchport access vlan 201
and G0/2 should be assigned to 553
switchport mode access
switchport access vlan 553
___________________
The Linksys may be having problems with the trunk configuration and actually, you don't need a trunk port (LinkSys isn't holding more than one Vlan).
On an invalid trunk configuration on the Cisco switch, it may be default back to native vlan 1 which is not the desired vlan on this case.
12-06-2007 12:09 AM
My config
!
ip routing
...
!
interface GigabitEthernet0/2
description ###Linksys###
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/3
switchport access vlan 201
switchport mode access
!
...
!
interface Vlan201
ip address x.x.x.209 255.255.255.240
...
!
interface Vlan553
ip address 10.0.77.65 255.255.255.224
I ping from PC to Linksys. I enable span session and analyze packets. I see echo requests from pc and echo replies from linksys on gigabitethernet 0/2 (Linksys), but I'm not see echo replies from Linksys on port connected to my PC...
12-06-2007 06:22 AM
One more time ... Please change the interface g0/2 to access mode.
interface GigabitEthernet0/2
description ###Linksys###
switchport access vlan 553
switchport mode access
12-06-2007 06:48 AM
Interface vlan 553 is state to down when I changed the gigabitethernet0/2 to mode access. I see tag 553 in packet echo reply from linksys. I think the trunk work is fine.
12-06-2007 11:54 AM
Again, you don't need a trunk configuration between these 2 link partners. You aren't carrying more than one Vlan so please don't complicate things.
If the linksys was configure for trunking, please change it.
When you changed the g0/2 to access, did you assign it to vlan 553 as well ?
Can I see the output from typing
show interface g0/2 and show vlan after making the changes I suggested ?
12-07-2007 12:35 AM
New config:
...
!
ip routing
!
...
!
interface GigabitEthernet0/2
description ###LINKSYS###
switchport access vlan 553
switchport mode access
!
interface GigabitEthernet0/3
description ###PC###
switchport access vlan 201
switchport mode access
...
!
interface Vlan201
ip address x.x.x.209 255.255.255.240
...
!
interface Vlan553
ip address 10.0.77.65 255.255.255.224
sh int gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 001a.a2ac.db02 (bia 001a.a2ac.db02)
Description: ###LINKSYS###
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:22, output 00:00:04, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
193 packets input, 28798 bytes, 0 no buffer
Received 41 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 35 multicast, 0 pause input
0 input packets with dribble condition detected
386 packets output, 30374 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
sh int vlan 553
Vlan553 is up, line protocol is up
Hardware is EtherSVI, address is 001a.a2ac.db7f (bia 001a.a2ac.db7f)
Internet address is 10.0.77.65/27
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:02:21, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
152 packets input, 20218 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
327 packets output, 22578 bytes, 0 underruns
0 output errors, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
I ping successfull Linksys from PC after changed my config.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide