cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
421
Views
15
Helpful
3
Replies
iamroot80
Beginner

Issue with vPC (2 x n3500) and ESXi 7 Host

Hi,

I've two n3500 connected and running 4 x ESX Hosts (6.5) via vPC trunk without issues - the hosts are reachable from both switches and from other networks - the vmkernel uses the mac from old network card, not the one connected to n3500 and the management vmkernel is without configured VLAN (uses the native vlan set on the vPC).

Now i want to add additional ESX Hosts (with ESX 7.01), made new vPC exactly configured like the other four existing and now i'm running in the issue that the Management vmkernel IP is only reachable from one of the two n3500, when i disable the interface on the other switch it's working fine. Funny that after adding a second vmkernel (which got directly a virtual mac and didn't take one of the physical macs from vmnic) this one was reachable from both switches. The MAC from first vmkernel with management IP was already changed to a virtual mac but still the same issue - as soon i've enable the the network interface on second vPC switch only the second vmkernel is reachable but not the first one.

The vPC status is success, so no issues shown there.

 I think it's something with ARP cache (in show ip arp the IP is not shown with MAC on the second n3500) but i'm stuck somehow.

Any hints maybe? I guess it's just some small missing setting but i'm running out of ideas now.

Thanks,

Thomas

1 ACCEPTED SOLUTION

Accepted Solutions
balaji.bandi
VIP Master

Can you post vPC config of both the switch connected port to Esxi - is the ESXi configured as LACP ? or just trunk ?

what are you running in esxi vSwitch or dSwitch ?

 

also, post the output of

 

show vpc X 

show port-channel summary  interface port-channel X

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

3 REPLIES 3
balaji.bandi
VIP Master

Can you post vPC config of both the switch connected port to Esxi - is the ESXi configured as LACP ? or just trunk ?

what are you running in esxi vSwitch or dSwitch ?

 

also, post the output of

 

show vpc X 

show port-channel summary  interface port-channel X

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

View solution in original post

Maybe it sounds strange but your questions saved my life

I went through all settings and commands you provided, did screenshot of the vSwitch and VMKernel and then i found a very strange setting.

I'm sure i've never ever changed the VMKernel adapter to have other "Teaming and failover" settings than the vSwitch but when i checked the screenshots i did for you i saw that the Teaming was NOT on "Route based on IP hash" and for all settings there was "override" selected ..... - removed the overrides, confirmed and everything seems working now.

Was just searching for the past 40h for that problem

Many thanks for your help!

balaji.bandi
VIP Master

glad all went well. some time new version have changed they may have different settings.

 

worth checking each step when things going wrong or not working as expected.

 

Good to know and it was helpful for my advice to resolve the issue.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help