cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
942
Views
10
Helpful
6
Replies

Labbing Static Route? Packet Tracer

johnmcgrath29
Level 1
Level 1

I have setup a static route between a L3 switch and a Route however I cannot ping from my PC's to the router interface I can ping between the two interfaces on the L3 Switch and Router I can ping the interface from my PC's to the switch interface connected to the router I have added the PKT File below I think?? It's to do with my static routes??

1 Accepted Solution

Accepted Solutions

Hello,

 

on your router, you need these static routes:

 

ip route 0.0.0.0 0.0.0.0 200.1.1.0
ip route 192.168.1.0 255.255.255.0 200.1.1.1
ip route 192.168.2.0 255.255.255.0 200.1.1.1
ip route 192.168.3.0 255.255.255.0 200.1.1.1

 

Attached the working file...

View solution in original post

6 Replies 6

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

I suspect the router does not have a route table entry for the subnet which the PC is connected to. I assume this is subnet is routed on the switch, so the router will need a static route directing traffic to the switch IP of the transit link (switch <-> router link) for the PC subnet.

Ideally you would use a dynamic IGP to automate this process.

 

cheers,

Seb.

I have a DHCP Server setup and Inter-vlan routing on the L3 Switch I will take a look at that Seb thanks 

I have made some changes however it's not working I will add the core switch config and then the Router Config 

hostname CORE_SW1
!
!
ip routing
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree vlan 1,10,20,30 priority 24576
!
interface FastEthernet0/1
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/2
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/3
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/4
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/5
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/6
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/7
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/8
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/9
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/10
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/11
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/12
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/13
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/14
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/15
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/16
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/17
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/18
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/19
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/20
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/21
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/22
no switchport
no ip address
duplex auto
speed auto
shutdown
spanning-tree bpduguard enable
!
interface FastEthernet0/23
switchport trunk native vlan 30
switchport trunk allowed vlan 10,20,30
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree guard root
!
interface FastEthernet0/24
switchport trunk native vlan 30
switchport trunk allowed vlan 10,20,30
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree guard root
!
interface GigabitEthernet0/1
no switchport
ip address 200.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
no switchport
ip address 192.168.4.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0060.2f1c.2801
ip address 192.168.1.10 255.255.255.0
ip helper-address 192.168.4.40
!
interface Vlan20
mac-address 0060.2f1c.2802
ip address 192.168.2.20 255.255.255.0
ip helper-address 192.168.4.40
!
interface Vlan30
mac-address 0060.2f1c.2803
ip address 192.168.3.30 255.255.255.0
ip helper-address 192.168.4.40
!
ip nat inside source list 10 interface GigabitEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip route 0.0.0.0 0.0.0.0 200.1.1.0
ip route 192.168.1.0 255.255.255.0 200.1.1.0
ip route 192.168.2.0 255.255.255.0 200.1.1.0
ip route 192.168.3.0 255.255.255.0 200.1.1.0
ip route 0.0.0.0 0.0.0.0 0.0.0.0
ip route 200.1.1.0 255.255.255.0 192.168.4.0
!
ip flow-export version 9
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.2.0 0.0.0.255
access-list 10 permit 192.168.3.0 0.0.0.255
access-list 10 permit 192.168.4.0 0.0.0.255
access-list 10 permit 200.1.1.0 0.0.0.255
access-list 10 permit 200.1.2.0 0.0.0.255
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
end

hostname R_1
!
no ip cef
no ipv6 cef
!
license udi pid CISCO2901/K9 sn FTX1524656I-
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
no ip address
ip nat outside
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
ip address 200.1.1.2 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
no ip address
!
interface Serial0/0/0
ip address 200.1.2.2 255.255.255.0
clock rate 2000000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 10 interface GigabitEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 200.1.1.0
ip route 0.0.0.0 0.0.0.0 0.0.0.0
ip route 200.1.1.0 255.255.255.0 192.168.4.0
!
ip flow-export version 9
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.2.0 0.0.0.255
access-list 10 permit 192.168.3.0 0.0.0.255
access-list 10 permit 200.1.1.0 0.0.0.255
access-list 10 permit 192.168.4.0 0.0.0.255
access-list 10 permit 200.1.2.0 0.0.0.255
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Hello,

 

on your router, you need these static routes:

 

ip route 0.0.0.0 0.0.0.0 200.1.1.0
ip route 192.168.1.0 255.255.255.0 200.1.1.1
ip route 192.168.2.0 255.255.255.0 200.1.1.1
ip route 192.168.3.0 255.255.255.0 200.1.1.1

 

Attached the working file...

Thanks Again for your help Georg I now understand where i went wrong 

Review Cisco Networking for a $25 gift card