06-29-2021 03:46 PM
I have two SG350-28 switches seven miles apart, connected by two microwave radio links (around 150mbps each). Each wireless radio is connected to an SG350 via 1G copper and a 3-port LAG is built to aggregate the throughput of both microwave links for a total throughput of around 300mbps. So far, so good.
The LAG has three members on each end: one to radio link #1, and one to each of two radios that comprise link #2 (redundant radios). At any one time, two ports are capable of carrying traffic - radio link #1, and either radio A or B of link #2, so I expect the SG350 switches to show that two members are active in each LAG, but try as I may, only the port that is running across radio link #1 shows as active, while the two ports that comprise radio link #2 show as being in standby.
Here are snippets from the config files of each switch:
interface Port-Channel1
description "LAG-1"
spanning-tree link-type point-to-point
switchport mode trunk
switchport general allowed vlan add 9 untagged
switchport access vlan 9
switchport protected-port
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface Port-Channel1
flowcontrol auto
description "LAG-1"
spanning-tree link-type point-to-point
switchport mode trunk
switchport access vlan 9
switchport protected-port
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
Any thoughts would be appreciated.
06-29-2021 06:56 PM
Please share the interface config and
show command output for port-channel : show lacp port-channel 1
Also this ref doc may come handy if you need to check : https://www.cisco.com/c/en/us/support/docs/smb/switches/Cisco-Business-Switching/kmgmt-2239-configuring-lag-settings-on-a-switch-through-cli.html
06-30-2021 07:58 AM
Switch #1:
interface GigabitEthernet22
description "Cambium to Transmitter"
spanning-tree link-type point-to-point
channel-group 1 mode auto
switchport mode trunk
switchport access vlan 9
switchport general pvid 9
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet23
description "SAF1 to Transmitter"
channel-group 1 mode auto
switchport mode trunk
switchport access vlan 9
switchport general pvid 9
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
!
interface GigabitEthernet24
description "SAF2 to Transmitter"
channel-group 1 mode auto
switchport mode trunk
switchport access vlan 9
switchport general pvid 9
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
!
#show lacp port-channel 1
Port-Channel Po1
Port Type Gigabit Ethernet
Attached Lag id:
Actor
System Priority:1
MAC Address: 2c:57:41:6c:4c:b1
Admin Key: 1000
Oper Key: 1000
Partner
System Priority:0
MAC Address: 00:00:00:00:00:00
Oper Key: 0
------------------------------
Switch #2:
interface GigabitEthernet22
description "Cambium to Studio"
channel-group 1 mode auto
switchport mode trunk
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
!
interface GigabitEthernet23
description "SAF1 to Studio"
channel-group 1 mode auto
switchport mode trunk
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
!
interface GigabitEthernet24
description "SAF2 to Studio"
channel-group 1 mode auto
switchport mode trunk
switchport trunk native vlan 9
switchport trunk allowed vlan 1,9,150,253
!
#sho lacp port-channel1
Port-Channel Po1
Port Type Gigabit Ethernet
Attached Lag id:
Actor
System Priority:1
MAC Address: 2c:57:41:6c:54:bc
Admin Key: 1000
Oper Key: 1000
Partner
System Priority:0
MAC Address: 00:00:00:00:00:00
Oper Key: 0
------------------------
06-30-2021 06:33 PM
Hey,
Few things to note.
1. Why do we still have access port config on the ports
"switchport access vlan 9"
2. You are missing LACP config on the ports, you have to set Lacp priority
Use the following commands
int gi <port number as per your setup>
lacp port-priority 1
lacp system-priority value
Check the LACP stats to see if the packets are transmitting.
show lacp ge1/0/1 statistics
show lacp port-channel 1
Give it a shot let us know what happened.
06-30-2021 11:09 PM - edited 06-30-2021 11:10 PM
Hello
Looks like your using Pagp for link negotiation and those commands seems to suggest there are HP/Del
In any case try creating the PC from scratch using LACP, without protected ports and PVID applied.
no interface port-channel1
default interface range gig22-24
interface range gig22-24
shut
channel-group 1 mode active
interface port-channel1
description "LAG-1"
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk native vlan 9
switchport trunk allowed vlan 1,150,253
no shut
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide