02-05-2013 11:26 AM - edited 03-07-2019 11:31 AM
Hi everybody
I am trying to perform a lab on etherchannel
host1---- > Layer 2 switch----ethetchannel----R1
host 2---- >
On switch site, we want f1/1-3 to be in layer2 port channel 1 and on router site, we want f0/0,0/1 f1/0 be in layer 3 port channel 1
I am able to configure etherchannel on switch site as shown below:
sw#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
R - Layer3 S - Layer2
U - in use
Group Port-channel Ports
-----+------------+-----------------------------------------------------------
1 Po1(SU) Fa1/1(P) Fa1/2(P) Fa1/3(P)
However iam unable to configure the etherchannel on router site:
R1#show etherchannel summary
Flags: D - down P - in port-channel
I - stand-alone s - suspended
R - Layer3 S - Layer2
U - in use
Group Port-channel Ports
-----+------------+-----------------------------------------------------------
R1 running -config:
R1#show running-config
Building configuration...
Current configuration : 1105 bytes
!
version 12.4
hostname R1
!
ip cef
multilink bundle-name authenticated
interface Port-channel1
ip address 199.199.199.10 255.255.255.0
full-duplex
hold-queue 225 in
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
channel-group 1
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
channel-group 1
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
channel-group 1
!
ip forward-protocol nd
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
Sw config :
sw#show running-config
Building configuration...
Current configuration : 1547 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
interface Port-channel1
duplex full
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/1
duplex full
channel-group 1 mode on
!
interface FastEthernet1/2
duplex full
channel-group 1 mode on
!
interface FastEthernet1/3
duplex full
channel-group 1 mode on
!
!
!
interface Vlan1
no ip address
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
===========================================================================
I appreciate your help.
Thanks and have a great day
Solved! Go to Solution.
02-05-2013 01:54 PM
Hi Sarah,
A portchannel can be a layer-2 portchannel or a layer-3 portchannel and not a combination of both. In your config the switch is just a layer-2 po and on the router is layer-3.
So, since you are connecting to a router, I assume you want a later-3 po. In that case under the po interface add an IP address on the same segment as the router side.
sw
interface Port-channel1
ip address 199.199.199.11 255.255.255.0
HTH
Reza
02-05-2013 02:40 PM
Hello Reza,
A portchannel can be a layer-2 portchannel or a layer-3 portchannel and not a combination of both.
This depends on what you exactly have in mind. You can do a combination of both if you pay attention how the L3 segment is terminated on both devices. Let's move EtherChannels aside for a moment and consider the following configuration:
Router:
interface FastEthernet0/0
ip address 192.0.2.1 255.255.255.0
no shutdown
Switch:
interface FastEthernet0/1
switchport mode access
switchport access vlan 5
!
interface Vlan5
ip address 192.0.2.2 255.255.255.0
This configuration will run just fine - the router would have a working IP connectivity with the switch. Now, we do this:
Router:
interface FastEthernet0/0
channel-group 1
no shutdown !
interface FastEthernet0/1
channel-group 1
no shutdown
!
interface Port-channel1
ip address 192.0.2.1 255.255.255.0
Switch:
interface FastEthernet0/1
switchport mode access
switchport access vlan 5
channnel-group 1 mode on
!
interface FastEthernet0/2
switchport mode access
switchport access vlan 5channnel-group 1 mode on
!
interface Port-channel1
switchport mode access
switchport access vlan 5 !interface Vlan5
ip address 192.0.2.2 255.255.255.0
This should work as well because instead of a single Ethernet link between these devices, we now are using EtherChannel which is a transparent technology to the applications that are using it. You are of course absolutely correct that if there is an L3 connectivity assumed over this EtherChannel then the IP addresses must be configured somewhere. In case of an L3 EtherChannel, it would be the Port-channel interface itself. In case of L2 EtherChannel, the IP address would be associated on the appropriate SVI.
Sarah, I believe that the router provides you with an empty output in the show etherchannel summary command because this command shows you only the status of EtherChannels configured on an additional switching module(s) in this router. EtherChannels configured on routed ports do not show up in this output. So far, I haven't found a command that would show a similar listing - then again, as these routers have very few routed ports, the show interface Po1 usually is enough (it contains info about the member ports).
Best regards,
Peter
02-05-2013 01:54 PM
Hi Sarah,
A portchannel can be a layer-2 portchannel or a layer-3 portchannel and not a combination of both. In your config the switch is just a layer-2 po and on the router is layer-3.
So, since you are connecting to a router, I assume you want a later-3 po. In that case under the po interface add an IP address on the same segment as the router side.
sw
interface Port-channel1
ip address 199.199.199.11 255.255.255.0
HTH
Reza
02-05-2013 02:40 PM
Hello Reza,
A portchannel can be a layer-2 portchannel or a layer-3 portchannel and not a combination of both.
This depends on what you exactly have in mind. You can do a combination of both if you pay attention how the L3 segment is terminated on both devices. Let's move EtherChannels aside for a moment and consider the following configuration:
Router:
interface FastEthernet0/0
ip address 192.0.2.1 255.255.255.0
no shutdown
Switch:
interface FastEthernet0/1
switchport mode access
switchport access vlan 5
!
interface Vlan5
ip address 192.0.2.2 255.255.255.0
This configuration will run just fine - the router would have a working IP connectivity with the switch. Now, we do this:
Router:
interface FastEthernet0/0
channel-group 1
no shutdown !
interface FastEthernet0/1
channel-group 1
no shutdown
!
interface Port-channel1
ip address 192.0.2.1 255.255.255.0
Switch:
interface FastEthernet0/1
switchport mode access
switchport access vlan 5
channnel-group 1 mode on
!
interface FastEthernet0/2
switchport mode access
switchport access vlan 5channnel-group 1 mode on
!
interface Port-channel1
switchport mode access
switchport access vlan 5 !interface Vlan5
ip address 192.0.2.2 255.255.255.0
This should work as well because instead of a single Ethernet link between these devices, we now are using EtherChannel which is a transparent technology to the applications that are using it. You are of course absolutely correct that if there is an L3 connectivity assumed over this EtherChannel then the IP addresses must be configured somewhere. In case of an L3 EtherChannel, it would be the Port-channel interface itself. In case of L2 EtherChannel, the IP address would be associated on the appropriate SVI.
Sarah, I believe that the router provides you with an empty output in the show etherchannel summary command because this command shows you only the status of EtherChannels configured on an additional switching module(s) in this router. EtherChannels configured on routed ports do not show up in this output. So far, I haven't found a command that would show a similar listing - then again, as these routers have very few routed ports, the show interface Po1 usually is enough (it contains info about the member ports).
Best regards,
Peter
02-05-2013 02:56 PM
Hi Peter,
You are correct. In this case, this config should work fine too. What I was trying to say is that you need IPs on both sides. It could be under the SVI or PO interface.
Thanks,
Reza
02-05-2013 02:58 PM
Hi Reza,
What I was trying to say is that you need IPs on both sides.
Yes, absolutely. I also acknowledged that.
Best regards,
Peter
02-05-2013 03:01 PM
Hi Reza and Peter.
Please correct me if I am wrong.
Hosts-------sw-------ethechannel-------Router
We can configure at router site as :
int f0/1
channel-group 1
int f0/2
channel-group 1
int port-channel 1
ip address 199.199.199.1/24
at sw site:
Int range f1/1-3
channel-group 1 mode on
switchport
As long as hosts and router are on same subnet, they should be able to reach router over etherchannel regardless of the ip address under svi at switch.
I appreciate your help
02-05-2013 02:56 PM
Thanks Peter and Reza.
Let suppose we have two slots on our switch i.e slot 0 and slot 1
Slot 0 has f0/0, f0/1
slot 1 1 has f1/0,f1/1
Can we put ports from these both slots into a same etherchannel bundle say port channel 1 ?
Thanks and have a great day.
02-05-2013 03:02 PM
Hi Sarah,
It depends on the hardware and the IOS.
Most newer devices support Etherchannel within the same blade, between multiple blades and now for example with 6500 VSS between switches or in a case of 3750 stacked also between switches.
Can you provide the type router/switch and the IOS version you are using?
HTH
Reza
02-05-2013 01:59 PM
Hi
i suggest tht u assign any vlan to the interfaces and check if it works as i can see default config for u r interfaces
Sent from Cisco Technical Support iPhone App
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide