10-20-2023 02:38 PM
Hi,
I'm testing this new topology, i know better option are available, like stacking, but i want to know if in a real environnement this can work.
I have 2 or more layer 3 switch that i will use to route different network to each other. I usa VLAN to segregate the traffic for every network. Every switch should be capable to do routing. So i configure every VLAN in the layer 3 switch to have 192.168.1.1/24 and 192.168.2.1/24 as main IP of the VLAN 10 and 20 and it seems to work. No IP conflict right ? do you think a situtation with more device this will work or a bad option ? i'm sharing one configuration, the other switch are configure pretty the same.
Switch#show running-config
Building configuration...
Current configuration : 1553 bytes
!
version 12.2(37)SE1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
ip routing
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/2
switchport trunk allowed vlan 10,20
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access
switchport nonegotiate
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address 0002.1694.e701
ip address 192.168.1.1 255.255.255.0
!
interface Vlan20
mac-address 0002.1694.e702
ip address 192.168.2.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
!
end
10-20-2023 05:14 PM
looks good; as long as the other L3 switch has different IPs but still on the same subnet / range of 192.168.1.x/24 and 192.168.2.x/24. Like 2 in place of x. Make those 2 IPs reserved ones;
PCs on left point to 1.1 and 2.1 as default gateway -closest switch but not on right side; no reason to go all the way to left switch if closer gateway is available. Right PCs should point to right switch with 192.168.1.2/24 and 192.168.2.2/24
Regards, ML
**Please Rate All Helpful Responses **
10-21-2023 03:35 AM
Sorry is not clear. Actually i have configured the vlan 10 and 20 in the main switch with this IP 192.168.1.1/24 for VLAN 10 and 192.168.2.1/24 for VLAN 20. The ip of the vlan are defined in the same way in both switch is this a problem ?
10-21-2023 09:51 AM
Yes, it is like 2 different places (people) have the same address; How will post office delver mail ? who get what ?
you can find here some PT labs with examples of networks, subnets, switches and vlans to compare and study.
Regards, ML
**Please Rate All Helpful Responses **
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide