cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
546
Views
0
Helpful
5
Replies

limit bandwidth

faamin011
Beginner
Beginner

        Switch 3750x (IP Services)

         

policy-map test

class class-default

  police 512000 16000 exceed-action drop


interface GigabitEthernet1/0/23
switchport access vlan 595
switchport mode access
spanning-tree portfast
service-policy input test
end


interface GigabitEthernet1/0/24
uplink port

no switchport
ip address 10.100.100.2 255.255.255.252
end

policay map is working but not limit truely bandwidth to 512K, above config provide max 1.4 to 2MB Mb/sec. But when ever I applied the same service-policy on Gi1/0/24 it limit bandwidth to 50 to 100K.

interface GigabitEthernet1/0/24

uplink port

no switchport

service-policy input test
ip address 10.100.100.2 255.255.255.252
end

Please advice the correct way which limit bandwidth to 512K.

5 Replies 5

nathan demers
Beginner
Beginner

Let me ask you this.

Do you want to limit bandwidth going into the interface or out an interface?

both, but I think 3750x only allow input interface to configure.

Any one has idea

Hello Fahad

You can usually find this kind of issues when applying policying in hardware-based units as switches are. As a matter fact QoS documentation under policing and marking section states:

  • The accuracy of the policer configured is +/- 1.5 percent.

The best advise I can give is to play with the burst rate, decrease it, tune the configuration to accomplish better results... I have learnt this from experience. Not sure if there's any bug ID for something but I have never been able to find one that justifies this behaviour. I'm also interested in hearing a better response, if there's one.

Regards : )

Wilson B

Hello Fahad,

If you are testing with jperf change to udp and test again. The TCP sessions are dropping the sessions speed dramatically when some packets are dropped or you may use multiple TCP sessions. You may need to review the way you are testing. I would suggest to use shaper on output if you will use TCP for testing.

HTH,

Alex

*Please rate helpful posts

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers