cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3521
Views
0
Helpful
12
Replies

Migration from Hp procurve to Cisco Catalyst 9300

Eahwar34
Beginner
Beginner

Hi All, We have a requirement of migrating all the HP procurve to Cisco Catalyst 9300 . I have few questions regarding the same

1. Is there any migration tool designed by Cisco ? If yes please let me know the link.

2. Our environment is designed in a such a way that all these HP switches which are subjected to migration are Layer 2 switches mostly and they have their gateway and layer 3 details in HP primary and secondary core. Now when we migrate the layer 2 HP switch to Cisco catalyst 9300, can we still have the primary and Secondary HP core in place or these layer 2 Cisco switches ( Converted from HP ) have to point to another Cisco primary and Secondary core ?

3. Can we have a cross connection between Layer 2 and Layer 3 models, that is can Cisco layer 2 switch can point to HP core for its layer 3 and other information ?

12 Replies 12

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Hi Balaji,

Thanks for the commands PDF. It will be really helpful. Also the thread is somewhat related to the context. I will definitely look in detail. 

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Please do let us know if you need any further assistance here when you doing config form HP to cisco (i myself did some migration in the past, its easy just need to understand TAG and UNTAG rest all same.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you for your response. Could you please ping to the below email ID and I will revert if there are any more clarifications regarding this migration from HP to Cisco. Thanks. 

Mail ID: eashr3461@gmail.com

Hi Balaji,

Did you used any automation service for this migration ? I plan to use some automation service like Ansible for pushing some of the common template configurations like Snmp, AAA etc. However for the Vlan, Access list configurations I think it has to be done manually as they are different from each switch .

If this is first deployment make sure you make it manually rather automation, at the stage this is first setup you doing.

 

automation required if you have mass deployment - hope that is not your case here.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

We have mass deployment . However as said before each switch is having a different VLAN, access list configurations but as far as SNMP, AAA configurations all switch has the same type and I think this can be done via some scripting. Thanks.

yes once PoC switch tested as working, then you can to automation with right tool you choose (python, ansible, or which every suites,)

 

i follow below steps:

 

1. Just fix the command syntax from HP to Cisco

2. if that is working. with out any issue and tested.

3. i will choose 1 test device make sure automation works as expected with out any issue.

4. do limited numbers with human access to device in case anything go wrong.

5. once process is proven you can do any number or device since you know the process works.

 

Monitor the device of post implementation for certain time see all work as expected.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi @balaji.bandi 

 

I have similar issue to migrate from HP Switch to C9300, See below my configs

 

interface 1
name "Link to IPSECVPN FW"
exit
interface 3
name "Link to IDS for Port Mirroring"
exit
interface 6
name "Link to HQ Router-001 Interface FE0/1"
exit
interface 13
name "Partner Network-Device"
exit
interface 15
name "to HQ_FW On Partner Interface"
exit
interface 25
name "HQ to Branch "
speed-duplex 10-full
exit
interface 31
name "HQ to Branch-1"
exit
interface 33
name "HQ to Branch-2"
exit
interface 35
name "HQ to Branch-3"
exit
interface 36
name "HQ to Branch-4"
speed-duplex 100-full
exit
interface 37
name "HQ to Branch-5"
exit
interface 48
name "Trunk to HQ Brach router"
exit

ip default-gateway 192.168.10.253

vlan 1
name "DEFAULT_VLAN"
untagged 7,9-12,21,30,32,48
ip address 192.168.10.10 255.255.255.0
no untagged 1-6,8,13-20,22-29,31,33-47
exit
vlan 6
name "FIBER"
untagged 1-6,8
ip address 192.168.10.252 255.255.255.0
exit
vlan 202
name "Branch-1"
untagged 25
tagged 48
no ip address
exit
vlan 203
name "Branch-2"
untagged 31
tagged 48
no ip address
exit
vlan 204
name "Branch-3"
untagged 33
tagged 48
no ip address
exit
vlan 205
name "Branch-3"
untagged 35
tagged 48
no ip address
exit
vlan 206
name "Branch-4"
untagged 37
tagged 48
no ip address
exit

 

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

the biggest 'issue' you will probably face is that each vendor runs its own spanning tree algorithm, so make you sure that you select one that is compatible between both vendors.

 

The below link might also be useful:

 

https://www.itcentralstation.com/products/comparisons/cisco-catalyst-switches_vs_hpe-procurve

Hi Georg Pauwen,

Thanks for the article. I will definitely look into that.

Any update for my 3rd question ?

paul driver
VIP Expert VIP Expert
VIP Expert

Hello 

regards question 3

yes you can -

you could go either two ways

1-

attach cisco core and migrate the hp l3 leaving the old ho core with its layer connections to migrate at your will

or 

2- attach the cisco core at layer 2 and migrate the hp layer2 switches first leaving  the hp l3 core until all distribution/access layer have been migrated and the finally  migrate the hp l3 to cisco 

 

as regards stp - i would suggest use mst as i am assuming the hp environment is mst at present- (usually it is ) when i have done HP/Aruba to cisco and vice-versa lan migrations

Any further query’s need happy to assist.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers