Showing results for 
Search instead for 
Did you mean: 

MSTP On Devices Utilizing Etherchannel


I have been doing lab work in preparation for the 300-115 test schedule for next week. Specifically, I was working on Ether-channel configurations and then transitioned to configuring MSTP utilizing the previously configured links (2 ports bundled into and Ether-channel). It's a basic config with 6 VLAN's and 3 MST instances (0,1,2) and the VLAN's distributed evenly between instance 1 and 2 . After successfully configuring MSTP, the stp info for instance 1 & 2 comes back with "No mst information available for instance(s) 1 or 2.

This happened whether I used PAgP, LACP or the "On" configuration

When I utilized 802.1q trunks between the devices, MSTP worked as expected.

I've searched and read a bunch of documentation and can't find a specific statement that MSTP can or can't be used over Ether-channel.

Can anyone help upgrade my knowledge in this area? Thank you in advance.

HW: 3X3560G running 12.2(55)SE10

Associated Info"

Group Port-channel Protocol Ports
13 Po13(SU) LACP Gi0/43(P) Gi0/44(P)
23 Po23(SU) LACP Gi0/45(P) Gi0/46(P)

SW3#sh spann
SW3#sh spanning-tree mst 0

##### MST0 vlans mapped: 1-9,11-19,21-29,31-39,41-49,51-59,61-4094
Bridge address 0021.a1b8.1680 priority 32768 (32768 sysid 0)
Root address 0019.30d1.0880 priority 32768 (32768 sysid 0)
port Po23 path cost 0
Regional Root address 0019.30d1.0880 priority 32768 (32768 sysid 0)
internal cost 10000 rem hops 19
Operational hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured hello time 2 , forward delay 15, max age 20, max hops 20

Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po13 Desg FWD 10000 128.152 P2p
Po23 Root FWD 10000 128.232 P2p

SW3#sh spanning-tree mst 1

No mst information available for instance(s) 1.

SW3#sh spanning-tree mst 2

No mst information available for instance(s) 2.

2 Replies 2


Figured it out. Had a bad config on the individual ports. Weren't set up as trunks.


I did the same test on VMware, I found the same issue as yours. I could not find any evidence to show MST can or cannot run over Ethernetchannel. 5 years passed, seems like there is still no answer, lol

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers