06-19-2015 02:32 AM - edited 03-08-2019 12:37 AM
here is the scenario;
i have a 3560 switch which i use as videoswitch i have 5 channels coming from 5 different encoders via 172.x.x.x, all of these 5 channels connect from video switch(3560 to Prostream 1000 then further to uplink;
I have created 5 differnet vlans for each channel but i am having problem going out on a sigle port to connet to prostream 1000, i have tried trunk and via ip route defaut getaway but no luck so far.
Can someone out there tell me how can i manage to put all five stream (coz they are video streams) from five differnet vlan to go out on a single port to connect to ProStream which is also IP in.
no aaa new-model
system mtu routing 1500
vtp mode transparent
ip subnet-zero
ip routing
!
ip dhcp snooping vlan 10-50
ip dhcp snooping
ip igmp snooping querier
!
!
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10
name CH1
!
vlan 20
name CH2
!
vlan 30
name CH3
!
vlan 40
name CH4
!
vlan 50
name CH5
!
interface GigabitEthernet0/1
description PROSTREAM_INTERFACE
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/2
description PROSTREAM_BACKUP_PORT
no switchport
ip address dhcp
!
interface GigabitEthernet0/3
description CH1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
description CH1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
description CH2
switchport access vlan 20
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/6
description CH2
switchport access vlan 20
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/7
description CH3
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/8
description CH3
switchport access vlan 30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/9
description CH4
switchport access vlan 40
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
description CH4
switchport access vlan 40
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/11
description CH5
switchport access vlan 50
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/12
description CH5
switchport access vlan 50
switchport mode access
spanning-tree portfast
.
.
.
!
interface GigabitEthernet0/24
no switchport
ip address 192.168.0.153 255.255.255.0
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description
ip address 172.16.0.1 255.255.255.0
!
interface Vlan20
description
ip address 172.17.0.1 255.255.255.0
!
interface Vlan30
description
ip address 172.18.0.1 255.255.255.0
!
interface Vlan40
description
ip address 172.19.0.1 255.255.255.0
!
interface Vlan50
description I
ip address dhcp
!
ip default-gateway 172.15.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.15.0.1
ip route 172.15.0.0 255.255.0.0 172.15.0.1
ip http server
!
!
control-plane
!
banner motd ^C
!
line con 0
exec-timeout 0 0
password 123
logging synchronous
line vty 0 4
password 123
login
line vty 5 10
password 123
login
line vty 11 15
login
!
end
thanks
Solved! Go to Solution.
06-19-2015 03:05 PM
Its confusing, because you have port g0/1 configured as trunk, but than you have all the SVIs on the switch. You also have a default-gateway command and a default route command. If the switch is layer-2 only than you only need a default-gateway. If the switch is layer-3 with SVIs than you need a default route only.
Is the ProStream 1000 connected to another switch/router besides the 3560 switch?
Are you trying to use the switch to route between your vlans?
Can you provide a diagram of your network?
Also, what is the IP segment for vlan 50?
HTH
06-19-2015 03:05 PM
Its confusing, because you have port g0/1 configured as trunk, but than you have all the SVIs on the switch. You also have a default-gateway command and a default route command. If the switch is layer-2 only than you only need a default-gateway. If the switch is layer-3 with SVIs than you need a default route only.
Is the ProStream 1000 connected to another switch/router besides the 3560 switch?
Are you trying to use the switch to route between your vlans?
Can you provide a diagram of your network?
Also, what is the IP segment for vlan 50?
HTH
06-19-2015 03:49 PM
It is a bit confusing maybe and it is because im new to cisco switching world.
Switch is 3560 and it is layer3,
Reza, picture this:
vlan10 (port2) ip-in from DVBT encoder ip 172.16.0.10 255.255.255.0 ip socket out 239.0.0.3
vlan20 (port4) ip-in from DVBT2 encoder IP 172.17.0.10 255.255.255.0 ip socket out 239.0.0.4
and so with other 3 vlans
g0/1 has to be the port the streams out all these SVIs to ProStream IP 172.15.0.10
( now i have a config file of the same switch but i only has one vlan and streams multicast to all ports and i want to prevent that, the old config file is attached)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide