cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
938
Views
0
Helpful
12
Replies
CERKYR
Beginner

Native VLAN : change / impacts

Hello,

I have these switchs : 

2 x 9300  : already configured by a other person

4 x 2960-x : new, out of the box
--

I configure IP, VLAN,Trunk,ports, ..., etc... for the 2960-x
And it"s OK.
Then, I connect one the 2960-x with the 9300, on the same configuration trunk port .

But, no ping.
(I already open a other issue for that)

--

Then, I see on the 9300, that the default VLAN (native) was not 1 but a other value, on the entire switch for all the ports.
Then, I decide to change on the 2960-x this kind of value "native vlan" with the same new value.
And just after that, all my switchs 2960-x can't be connected between them; no ping, nothing !
A big mess !

Then, I reset this evening all of them (2960-x), to reconfigure them later.

I would like to understand why this kind of change (value from 1 to X for "native vlan) can crash the network ?

Regards,

 

 

 

12 REPLIES 12
Oleg Volkov
Contributor

Please show us:

show Ip int br

show vlan

show int trunk

from 2960 and 9300

--------------------------------------------------------------------------

Helping seriously ill children, all together. All information about this, is posted on my blog

https://community.cisco.com/t5/switching/changing-native-vlan/m-p/1392492#M129765

 

I read it; and I have the feeling that it's NOT recommandend to change the value of the "native vlan" from 1 to X on a TRUNK port.
It's mandatory to use the value 1.
Is it correct ?

 

No, in specific case, vlan1 may be not native. But in common case, yes, native vlan may be 1.

in Your case, what VLAN You use I will can tell anything after view config (VLAN’s and interfaces)

--------------------------------------------------------------------------

Helping seriously ill children, all together. All information about this, is posted on my blog
Reza Sharifi
Hall of Fame Expert

Vlan 1 is the default native vlan that comes with all switches. If you want to keep the native vlan as vlan 1, there is no need for any configuration. If you want to configure a different vlan as native vlan (say 50), than you need to configure it on all switches including the trunk ports.

HTH 

Jaderson Pessoa
VIP Collaborator

Hello

Change native vlan will not crash your entire network, you will lost access on device. To change it without lost access on device. Try steps below;

1. Change native vlan from one that you want or remove it on switch access firtly.
2. Change native vlan on distribution/core switch under the port that connect to your access switch.
Jaderson Pessoa
*** Rate All Helpful Responses ***

Then apply the New value for "native vlan" on all the network port interfaces for all the switchs ?

 

Conf t

Int all  (instead gi/...)

Switchport trunk native vlan 50

Do wr mem

End

 

Is it correct  ?

 

 

 

I would suggest the start from Core to all devices as @Reza Sharifi suggested this required all switches.

 

create VLAN 50 on all the switched and amend the config as you described.

 

As i have seen some Cat 9300 if the native VLAN Mismatches/VLAN not available in the database - the Port-channel go down. so make sure you have enough access to the device before changing anything.

 

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Hello,

 

On the 9300, the "native vlan" is 50.
And, I just update the trunk port and add this "native vlan" 50 to the trunk on the 9300 (port 24) and on the 2960-X (port 24); and just after that, all the ping don't work.

Isi it something like that ?

PC2<<Port_1/50>>9300<<<<TRUNK/50>>>2960-X<<Port_1/50>>PC1

But inside the web page of the 9300, I can see the link with 2960-X.

 

Then, I need to change the "native vlan" value from 1 to 50, on all the network ports before change it on the TRUNK port, for the 2 switchs (2960-X and 9300).
What are the commands ?

conf t

int all     (is it correct ?)   or     int Gi/1-Gi/23

(because do "int Gi/1", "int Gi/2", ...for each port is a long way)
switchport native vlan 50   (Is it correct ?)

do wr mem

end

show running-config

 

 

No, If You wnt to configure multiple ports You must use:

Int range gig0/1-24

Example for configure ports from Gig0/1 to Gig0/24

Also access port must be configured like:

switchport mode access

switchport access vlan 50

And may be You have phones and separate VLAN for it then

swichport voice vlan XX

--------------------------------------------------------------------------

Helping seriously ill children, all together. All information about this, is posted on my blog

Hello
FYI - Native vlan ISNT switch specific, its port specific, meaning you can have multiple native vlans on various switch trunk interconnects on the same switch, only the two sides of each trunk need to have the same native vlan ID.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Can you post the full configuration look? for all the switches.

 

do you also have command other than native vlan allowed VLAN List in the port-channel like below on the port-channel connected to parent switch?

 

Note : this command not required to add to the Access ports, i saw you have added this command to all the interfaces.

 

the command for native VLAN as below example only :

 

interface port-channel 1

switchport trunk native vlan 50

switchport trunk allowed vlan 50, 60,70 ...So on

 

Access port config should remain as same as access port the port belong to which VLAN

 

interface g 1/1

switchport mode access

switchport access vlan 60

 

 

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Yes.. just it. :)
Jaderson Pessoa
*** Rate All Helpful Responses ***