Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Nexus 93180YC-EX data broker NDB embedded NXAPI - error during install

I'm trying a proof of concept with the NDB on a nexus 98180YC-EX. It is a single switch topology and I'm going down the path of NXAPI with the embedded manager. The 93180 is running nxos version 7.0(3)I7(5a).

I have python script and ndb file in the root of bootflash:

My Virtual Service List shows guestshell active.

Name                    Status             Package Name
guestshell+             Activated          guestshell.ova

My role and privilege are good:

show user-account
    this user account has no expiry date
account created through REMOTE authentication
Credentials such as ssh server key will be cached temporarily only for this user
Local login not possible
show privilege
User name: admin
Current privilege level: 15
Feature privilege: Disabled

When I run the following command:

python -v guestshell+ /bootflash/

I get the following error:

2019-01-11 14:47:48,474 - __main__ - INFO - Validating Guestshell version
2019-01-11 14:47:52,634 - __main__ - INFO - Resized the guestshell resources
2019-01-11 14:47:52,635 - __main__ - ERROR - Something went wrong while extracting zip file


I have plenty of space in bootflash: (51GB).

Any ideas?


Accepted Solutions



curious to know what is causing this...


Are there any errors logged in  /var/nxapi/logs/error.log ?

View solution in original post

Georg Pauwen
VIP Expert



try and add the '-force' keyword:


python -v guestshell+ /bootflash/ -force


Also make sure that the file in bootflash matches exactly the name of the file you are referencing (check if the file in bootflash is named by any chance)...

Georg, thank you for taking the time to respond. The --force keyword simply suppressed the 2nd message "Resized the guestshell resources", but I had the same error message regarding the zip file. I did a cut/copy paste of the filename directly from the dir bootflash: output into the python command, so I know I have the filename correct. I was also able to go into the bash shell and manually unzip the file (just to verify the integrity of the zip file).

Lastly, I downgraded to I6-1 image just to see if that had an effect - which is also supported by the same python script, and I had the same problem.

I also verified the roles and privledge were correct. I was originally using TACACS to authenticate to the CLI, but to remove that factor, I used local authentication - with the same result.

Since this is a proof of concept, I'm not able to open a TAC case, but my local SE is going to do that on Monday.



curious to know what is causing this...


Are there any errors logged in  /var/nxapi/logs/error.log ?

View solution in original post

Errors are logged to the NDB log....but they are not debug level errors.....just the messages I showed you.

When defining ZIP file path, make sure you define it in linux way and not IOS was. 

See my command:

python -v guestshell+ /bootflash/