cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15803
Views
0
Helpful
7
Replies

Nexus vPC to Arista MLAG

tporembski
Level 1
Level 1

Can you connect an Arista switch using their MLAG technology to a nexus 5K or 2K using vPC?

2 Accepted Solutions

Accepted Solutions

Cisco vPC to Arista MLAG works fine in my experience. I've used Cisco vPC to Arista MLAG using only two links as you're proposing, and also four links e.g., Nexus 1 to Arista 1 and 2, Nexus 2 to Arista 1 and 2.

Here's a sample configuration for the two link option. I have port-channel 1 as the peer link (for both Cisco and Arista) and port-channel 200 as the link between the Cisco and Arista:

! Arista 1
!
vlan 4094
   trunk group MLAG_Peer
!
interface Vlan4094
   ip address 172.17.255.1/30
!
mlag configuration
   domain-id MLAG1
   local-interface Vlan4094
   peer-address 172.17.255.2
   peer-link Port-Channel1
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group MLAG_Peer
!
interface Ethernet47
   channel-group 1 mode active
!
interface Ethernet48
   channel-group 1 mode active
!
interface Port-Channel200
   switchport mode trunk
   mlag 200
!
interface Ethernet10
  switchport mode trunk
  channel-group 200 mode active
!
! Arista 2
!
vlan 4094
   trunk group MLAG_Peer
!
interface Vlan4094
   ip address 172.17.255.2/30
!
mlag configuration
   domain-id MLAG1
   local-interface Vlan4094
   peer-address 172.17.255.1
   peer-link Port-Channel1
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group MLAG_Peer
!
interface Ethernet47
   channel-group 1 mode active
!
interface Ethernet48
   channel-group 1 mode active
!
interface Port-Channel200
   switchport mode trunk
   mlag 200
!
interface Ethernet10
  switchport mode trunk
  channel-group 200 mode active
!
# Nexus 5K1
#
interface mgmt0
  vrf member management
  ip address 192.168.1.7/25
#
feature vpc
#
vpc domain 11
  peer-switch
  role priority 1
  peer-keepalive destination 192.168.1.8
  delay restore 60
  peer-gateway
#
interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
#
interface Ethernet2/1
  switchport mode trunk
  channel-group 1 mode active
#
interface Ethernet2/2
  switchport mode trunk
  channel-group 1 mode active
#
interface port-channel200
  switchport mode trunk
  vpc 200
#
interface Ethernet1/27
  switchport mode trunk
  channel-group 200 mode active
#
# Nexus 5K2
#
interface mgmt0
  vrf member management
  ip address 192.168.1.8/25
#
feature vpc
#
vpc domain 11
  peer-switch
  role priority 1
  peer-keepalive destination 192.168.1.7
  delay restore 60
  peer-gateway
#
interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
#
interface Ethernet2/1
  switchport mode trunk
  channel-group 1 mode active
#
interface Ethernet2/2
  switchport mode trunk
  channel-group 1 mode active
#
interface port-channel200
  switchport mode trunk
  vpc 200
#
interface Ethernet1/27
  switchport mode trunk
  channel-group 200 mode active
#

 

And here's a couple of show commands on the Arista for good measure:

a7150s-1#sh mlag
MLAG Configuration:
domain-id           :               MLAG1
local-interface     :            Vlan4094
peer-address        :        172.17.255.2
peer-link           :       Port-Channel1

MLAG Status:
state               :              Active
negotiation status  :           Connected
peer-link status    :                  Up
local-int status    :                  Up
system-id           :   02:1c:73:42:6d:31

MLAG Ports:
Disabled            :                   0
Configured          :                   0
Inactive            :                   0
Active-partial      :                   0
Active-full         :                   1

a7150s-1#sh mlag interfaces
                                                                 local/remote
   mlag       desc             state       local       remote          status
---------- ---------- ----------------- ----------- ------------ ------------
    200                  active-full       Po200        Po200           up/up
a7150s-1#sh mlag interfaces detail
                                                          local/remote
  mlag            state       local       remote        oper        config               last change    changes
--------- ---------------- ----------- ------------ ----------- ------------- ------------------------- -------
   200      active-full       Po200        Po200       up/up       ena/ena       1 day, 22:30:04 ago         14

a7150s-1#show port-channel 200 traffic
ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
   200      Et10  42.27%   0.00%  46.62%  16.29%   0.00% 100.00%

a7150s-2#show port-channel 200 traffic
ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
   200      Et10  29.51%  81.42%  53.13%   6.64% 100.00% 100.00%

 

Regards

View solution in original post

Hi,

I've connected switches off Nexus 2K host interfaces, but not Nexus 2232. I've only done this as a last resort to connect legacy blade switches at 1GE to Nexus 2248T.

As you're probably aware, the FEX operates with Spanning Tree BPDU Guard on the host interfaces, and unless it's changed in recent releases, this cannot be disabled.

What that means is that to connect a switch to a FEX you need to enable Spanning Tree BPDU filter (spanning-tree bpdufilter enable). This essentially disables Spanning Tree on the interface and can obviously be a little dangerous as any loop that was introduced would never be blocked.

If you're absolutely certain there can be no loops introduced this is an option, but I'd consider it only when there are no other options.

Personally I'd rather try and use ports on the Nexus 5K directly and run in a supported and standard approach than connect the Arista to a FEX and have to disable spanning tree.

Regards

View solution in original post

7 Replies 7

Reza Sharifi
Hall of Fame
Hall of Fame

So, your design is one Arista switch and 2 Cisco Nexus 5ks or 2 Arista switches?

The design is 2 Arista switches and 2 Cisco Nexus 5K.  Each Arista has one connection to each Nexus switch.

Cisco vPC to Arista MLAG works fine in my experience. I've used Cisco vPC to Arista MLAG using only two links as you're proposing, and also four links e.g., Nexus 1 to Arista 1 and 2, Nexus 2 to Arista 1 and 2.

Here's a sample configuration for the two link option. I have port-channel 1 as the peer link (for both Cisco and Arista) and port-channel 200 as the link between the Cisco and Arista:

! Arista 1
!
vlan 4094
   trunk group MLAG_Peer
!
interface Vlan4094
   ip address 172.17.255.1/30
!
mlag configuration
   domain-id MLAG1
   local-interface Vlan4094
   peer-address 172.17.255.2
   peer-link Port-Channel1
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group MLAG_Peer
!
interface Ethernet47
   channel-group 1 mode active
!
interface Ethernet48
   channel-group 1 mode active
!
interface Port-Channel200
   switchport mode trunk
   mlag 200
!
interface Ethernet10
  switchport mode trunk
  channel-group 200 mode active
!
! Arista 2
!
vlan 4094
   trunk group MLAG_Peer
!
interface Vlan4094
   ip address 172.17.255.2/30
!
mlag configuration
   domain-id MLAG1
   local-interface Vlan4094
   peer-address 172.17.255.1
   peer-link Port-Channel1
!
interface Port-Channel1
   switchport mode trunk
   switchport trunk group MLAG_Peer
!
interface Ethernet47
   channel-group 1 mode active
!
interface Ethernet48
   channel-group 1 mode active
!
interface Port-Channel200
   switchport mode trunk
   mlag 200
!
interface Ethernet10
  switchport mode trunk
  channel-group 200 mode active
!
# Nexus 5K1
#
interface mgmt0
  vrf member management
  ip address 192.168.1.7/25
#
feature vpc
#
vpc domain 11
  peer-switch
  role priority 1
  peer-keepalive destination 192.168.1.8
  delay restore 60
  peer-gateway
#
interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
#
interface Ethernet2/1
  switchport mode trunk
  channel-group 1 mode active
#
interface Ethernet2/2
  switchport mode trunk
  channel-group 1 mode active
#
interface port-channel200
  switchport mode trunk
  vpc 200
#
interface Ethernet1/27
  switchport mode trunk
  channel-group 200 mode active
#
# Nexus 5K2
#
interface mgmt0
  vrf member management
  ip address 192.168.1.8/25
#
feature vpc
#
vpc domain 11
  peer-switch
  role priority 1
  peer-keepalive destination 192.168.1.7
  delay restore 60
  peer-gateway
#
interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
#
interface Ethernet2/1
  switchport mode trunk
  channel-group 1 mode active
#
interface Ethernet2/2
  switchport mode trunk
  channel-group 1 mode active
#
interface port-channel200
  switchport mode trunk
  vpc 200
#
interface Ethernet1/27
  switchport mode trunk
  channel-group 200 mode active
#

 

And here's a couple of show commands on the Arista for good measure:

a7150s-1#sh mlag
MLAG Configuration:
domain-id           :               MLAG1
local-interface     :            Vlan4094
peer-address        :        172.17.255.2
peer-link           :       Port-Channel1

MLAG Status:
state               :              Active
negotiation status  :           Connected
peer-link status    :                  Up
local-int status    :                  Up
system-id           :   02:1c:73:42:6d:31

MLAG Ports:
Disabled            :                   0
Configured          :                   0
Inactive            :                   0
Active-partial      :                   0
Active-full         :                   1

a7150s-1#sh mlag interfaces
                                                                 local/remote
   mlag       desc             state       local       remote          status
---------- ---------- ----------------- ----------- ------------ ------------
    200                  active-full       Po200        Po200           up/up
a7150s-1#sh mlag interfaces detail
                                                          local/remote
  mlag            state       local       remote        oper        config               last change    changes
--------- ---------------- ----------- ------------ ----------- ------------- ------------------------- -------
   200      active-full       Po200        Po200       up/up       ena/ena       1 day, 22:30:04 ago         14

a7150s-1#show port-channel 200 traffic
ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
   200      Et10  42.27%   0.00%  46.62%  16.29%   0.00% 100.00%

a7150s-2#show port-channel 200 traffic
ChanId      Port Rx-Ucst Tx-Ucst Rx-Mcst Tx-Mcst Rx-Bcst Tx-Bcst
------ --------- ------- ------- ------- ------- ------- -------
   200      Et10  29.51%  81.42%  53.13%   6.64% 100.00% 100.00%

 

Regards

Just discovered the Arista switches are connecting to Nexus 2232(FEX)  off a N5K.  I know the 2232 is not designed for switch connectivity.  Do you have any experience connecting to 2232.  I have connectivity but the vlans on the trunk are not forwarding.

Hi,

I've connected switches off Nexus 2K host interfaces, but not Nexus 2232. I've only done this as a last resort to connect legacy blade switches at 1GE to Nexus 2248T.

As you're probably aware, the FEX operates with Spanning Tree BPDU Guard on the host interfaces, and unless it's changed in recent releases, this cannot be disabled.

What that means is that to connect a switch to a FEX you need to enable Spanning Tree BPDU filter (spanning-tree bpdufilter enable). This essentially disables Spanning Tree on the interface and can obviously be a little dangerous as any loop that was introduced would never be blocked.

If you're absolutely certain there can be no loops introduced this is an option, but I'd consider it only when there are no other options.

Personally I'd rather try and use ports on the Nexus 5K directly and run in a supported and standard approach than connect the Arista to a FEX and have to disable spanning tree.

Regards

Thanks.  I knew about that and we found out that it does cause issues so we will be running to N5K.

tporembski
Level 1
Level 1

Thanks.  that's the confirmation I needed.

Review Cisco Networking for a $25 gift card