cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
557
Views
0
Helpful
1
Replies
spencerondrusek
Beginner

No MLS command options available on IE-4000-8GT8GP4G-E

I am unable to issue any 'mls cos' commands in global configuration or on a specific interface. I have never configured a IE4000 before and am attempting to configure it similarly to our IE3000s.

Thank you in advance

1 ACCEPTED SOLUTION

Accepted Solutions
Kallol Bosu
Cisco Employee

IE4K uses MQC, not MLS. So the qos commands are different and you cant' use the IE3000 configuration guide as a reference. It's like Cat2k/3K switches are MLS based switch but Cat4K is not. 

Sample QOS related configuration on the IE4000 -

class-map match-any first-class-Network
match access-group name first-class

class-map match-any second-class-Network
match access-group name second-class

class-map match-any third-class-Network
match access-group name third-class
!
!! MQC can use QOS grouping, which is set on ingress and matched in a
class-map on egress
!! as another way to match traffic to egress queues.
!! these are egress class maps.


class-map match-all qos-group-0
match qos-group 0
class-map match-all qos-group-1
match qos-group 1
class-map match-all qos-group-2
match qos-group 2
!
!!!! straight forward traffic matching is also supported.
class-map match-all voip-data
match ip dscp ef
class-map match-any voip-control
match ip dscp cs3 af31
class-map match-any cos-56
match cos 5 6

!
!! sample ingress policy that sets DSCP based on ACL with range
command
!
policy-map Policy-set-dscp-example
class first-class-Network
set ip dscp 47
class second-class-Network
set ip dscp 31
class third-class-Network
set ip dscp 58
class class-default
set ip dscp default

ip access-list extended first-class
permit tcp 10.218.9.0 0.0.0.255 any range 100 200
ip access-list extended second-class
permit tcp 10.198.46.0 0.0.0.127 any range 400 500
ip access-list extended third-class
permit tcp 10.218.0.0 0.0.0.255 any range 700 800

!

Config guide reference- 

http://www.cisco.com/c/en/us/td/docs/switches/lan/cisco_ie4000/software/release/15-2_2_ea/configuration/guide/scg-ie4000/swqos.pdf

Thanks

View solution in original post

1 REPLY 1
Kallol Bosu
Cisco Employee

IE4K uses MQC, not MLS. So the qos commands are different and you cant' use the IE3000 configuration guide as a reference. It's like Cat2k/3K switches are MLS based switch but Cat4K is not. 

Sample QOS related configuration on the IE4000 -

class-map match-any first-class-Network
match access-group name first-class

class-map match-any second-class-Network
match access-group name second-class

class-map match-any third-class-Network
match access-group name third-class
!
!! MQC can use QOS grouping, which is set on ingress and matched in a
class-map on egress
!! as another way to match traffic to egress queues.
!! these are egress class maps.


class-map match-all qos-group-0
match qos-group 0
class-map match-all qos-group-1
match qos-group 1
class-map match-all qos-group-2
match qos-group 2
!
!!!! straight forward traffic matching is also supported.
class-map match-all voip-data
match ip dscp ef
class-map match-any voip-control
match ip dscp cs3 af31
class-map match-any cos-56
match cos 5 6

!
!! sample ingress policy that sets DSCP based on ACL with range
command
!
policy-map Policy-set-dscp-example
class first-class-Network
set ip dscp 47
class second-class-Network
set ip dscp 31
class third-class-Network
set ip dscp 58
class class-default
set ip dscp default

ip access-list extended first-class
permit tcp 10.218.9.0 0.0.0.255 any range 100 200
ip access-list extended second-class
permit tcp 10.198.46.0 0.0.0.127 any range 400 500
ip access-list extended third-class
permit tcp 10.218.0.0 0.0.0.255 any range 700 800

!

Config guide reference- 

http://www.cisco.com/c/en/us/td/docs/switches/lan/cisco_ie4000/software/release/15-2_2_ea/configuration/guide/scg-ie4000/swqos.pdf

Thanks

View solution in original post