09-15-2011 03:34 PM - edited 03-07-2019 02:15 AM
Hi,
I am trying to configure OSPF between Four Router
R1---------) R2---------------) R3---------------) R4
R2 and R3 is ABR.
Area 1 is between R1 and R2
Area 10 is between R3 and R4
Area 0 is between R2 and R3
===============================================================================================
R1
interface FastEthernet0/0
ip address 192.168.30.9 255.255.255.248
des connected to R2
duplex auto
speed auto
end
router ospf 10
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 1
*Apr 7 10:38:37.947: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.20.1, FastEthernet0/0
===========================================================================================
R2
nterface FastEthernet0/1
ip address 192.168.20.1 255.255.255.252
des connected to R3
duplex auto
speed auto
end
interface FastEthernet0/0
ip address 192.168.30.10 255.255.255.248
des connected to R1
duplex auto
speed auto
end
router ospf 20
log-adjacency-changes
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 1
R2(config-router)#do show ip os int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/1 20 0 192.168.20.1/30 1 DR 0/0
Fa0/0 20 1 192.168.30.10/29 1 BDR 1/1
*Sep 15 22:42:31.787: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.20.1, FastEthernet0/0
--------------------------------------------------------------------------------------------------------------------------------
R3
interface FastEthernet0/0
ip address 192.168.20.2 255.255.255.252
des connected to R2
duplex auto
speed auto
interface FastEthernet0/1/0
ip address 192.168.10.1 255.255.255.224
des connected to R4
duplex auto
speed auto
router ospf 30
log-adjacency-changes
network 192.168.10.0 0.0.0.31 area 10
network 192.168.20.0 0.0.0.0 area 0
Sep 15 22:29:18.813: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.20.1, FastEthernet0/1/0
----------------------------------------------------------------------------------------------------------------------------
R4
interface FastEthernet0/1
ip address 192.168.10.2 255.255.255.224
duplex auto
speed auto
end
interface FastEthernet0/0
ip address 192.168.10.33 255.255.255.240
duplex auto
speed auto
end
router ospf 40
log-adjacency-changes
network 192.168.10.33 0.0.0.0 area 10
network 192.168.10.0 0.0.0.255 area 10
R4# show ip os int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/1 40 10 192.168.10.2/27 1 DR 1/1
Fa0/0 40 10 192.168.10.33/28 1 DR 0/0
ep 15 22:37:20.685: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.20.1, FastEthernet0/1
--------------------------------------------------------------------------------------------------------------------------------------
Please let me know how to avoid this OSPF error. Where i am doing the misake.
This is a lab setup in which all the four routers are connected in layer 2 in the same VLAN.
Thanks in Advance.
Solved! Go to Solution.
09-16-2011 06:13 AM
Even with point to point on ethernet multicast is still used - this time just 224.0.0.5
Unless you are doing this just to experiment then this is not the way to setup OSPF. Each IP subnet should be in it's own vlan. Because you have them all in the same L2 vlan the multicast updates are seen by each router and that is why you are getting all the error messages.
Jon
09-15-2011 03:39 PM
Are you saying all the interfaces are in the same L2 vlan ?
If so you need to use a vlan per IP subnet and not have all interfaces in the same vlan.
OSPF on ethernet networks will be using DR/BDR and sending updates using 224.0.0.5 & 224.0.0.6 multicast messages. These messages will flood within the same vlan so that is why you are getting all these messages.
Jon
09-15-2011 08:10 PM
Hi,
thanks for the reply, if this is because of DR/BDR. I have tried by making all the interface point-to-point
ip os network point-to-point
but still i am getting the same error.
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/1 40 10 192.168.10.2/27 1 P2P 1/1
Fa0/0 40 10 192.168.10.33/28 1 P2P 0/0
Please guide me why after p-2-p network still this is happening.
09-16-2011 06:13 AM
Even with point to point on ethernet multicast is still used - this time just 224.0.0.5
Unless you are doing this just to experiment then this is not the way to setup OSPF. Each IP subnet should be in it's own vlan. Because you have them all in the same L2 vlan the multicast updates are seen by each router and that is why you are getting all the error messages.
Jon
09-16-2011 01:30 PM
Hi,
Thanks for the reply, Actually this is a lab in book (Routing TCP/IP Vol 2) Configuration of OSPF page 412.
09-18-2011 01:32 PM
Hi,
I am able to configure OSPF and no error mesage is coming after creating the VLAN.
But now one more problem is coming I have created 5 loopbacks in Router A and I am advertising the summary route but the neighboring routers are not able to see the summary route.
interface Loopback0
ip address 10.0.0.1 255.255.0.0
!
interface Loopback1
ip address 10.1.0.1 255.255.0.0
!
interface Loopback2
ip address 10.2.0.1 255.255.0.0
!
interface Loopback3
ip address 10.3.0.1 255.255.0.0
!
interface Loopback4
ip address 10.4.0.1 255.255.0.0
!
interface Loopback5
ip address 10.5.0.1 255.255.0.0
!
interface Loopback6
ip address 10.6.0.1 255.255.0.0
!
interface Loopback7
ip address 10.7.0.1 255.255.0.0
router ospf 1
log-adjacency-changes
no discard-route
area 15 range 10.0.0.0 255.248.0.0
network 10.8.1.0 0.0.0.255 area 0
network 172.17.1.0 0.0.0.255 area 15
show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.17.1.0/24 is directly connected, FastEthernet0/1
O 172.17.0.1/32 [110/2] via 172.17.1.2, 00:03:33, FastEthernet0/1
172.16.0.0/32 is subnetted, 2 subnets
O IA 172.16.27.195 [110/3] via 10.8.1.1, 00:13:12, FastEthernet0/0
O IA 172.16.27.1 [110/3] via 10.8.1.1, 00:13:12, FastEthernet0/0
172.20.0.0/30 is subnetted, 2 subnets
O IA 172.20.1.0 [110/2] via 10.8.1.1, 00:13:12, FastEthernet0/0
O IA 172.20.1.4 [110/2] via 10.8.1.1, 00:13:12, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
C 10.8.1.0/24 is directly connected, FastEthernet0/0
C 10.2.0.0/16 is directly connected, Loopback2
C 10.3.0.0/16 is directly connected, Loopback3
C 10.0.0.0/16 is directly connected, Loopback0
S 10.0.0.0/13 is directly connected, Null0
C 10.1.0.0/16 is directly connected, Loopback1
C 10.6.0.0/16 is directly connected, Loopback6
C 10.7.0.0/16 is directly connected, Loopback7
C 10.4.0.0/16 is directly connected, Loopback4
C 10.5.0.0/16 is directly connected, Loopback5
interface Loopback0
ip address 10.0.0.1 255.255.0.0
!
interface Loopback1
ip address 10.1.0.1 255.255.0.0
!
interface Loopback2
ip address 10.2.0.1 255.255.0.0
!
interface Loopback3
ip address 10.3.0.1 255.255.0.0
!
interface Loopback4
ip address 10.4.0.1 255.255.0.0
!
interface Loopback5
ip address 10.5.0.1 255.255.0.0
!
interface Loopback6
ip address 10.6.0.1 255.255.0.0
!
interface Loopback7
ip address 10.7.0.1 255.255.0.0
router ospf 1
log-adjacency-changes
no discard-route
area 15 range 10.0.0.0 255.248.0.0
network 10.8.1.0 0.0.0.255 area 0
network 172.17.1.0 0.0.0.255 area 15
ip route 10.0.0.0 255.248.0.0 Null0
I have created the null 0 route as well but no luck.
#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.17.1.0/24 is directly connected, FastEthernet0/1
O 172.17.0.1/32 [110/2] via 172.17.1.2, 00:03:33, FastEthernet0/1
172.16.0.0/32 is subnetted, 2 subnets
O IA 172.16.27.195 [110/3] via 10.8.1.1, 00:13:12, FastEthernet0/0
O IA 172.16.27.1 [110/3] via 10.8.1.1, 00:13:12, FastEthernet0/0
172.20.0.0/30 is subnetted, 2 subnets
O IA 172.20.1.0 [110/2] via 10.8.1.1, 00:13:12, FastEthernet0/0
O IA 172.20.1.4 [110/2] via 10.8.1.1, 00:13:12, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
C 10.8.1.0/24 is directly connected, FastEthernet0/0
C 10.2.0.0/16 is directly connected, Loopback2
C 10.3.0.0/16 is directly connected, Loopback3
C 10.0.0.0/16 is directly connected, Loopback0
S 10.0.0.0/13 is directly connected, Null0
C 10.1.0.0/16 is directly connected, Loopback1
C 10.6.0.0/16 is directly connected, Loopback6
C 10.7.0.0/16 is directly connected, Loopback7
C 10.4.0.0/16 is directly connected, Loopback4
C 10.5.0.0/16 is directly connected, Loopback5
Topology is mention in page 435 Routing TCP/IP Routing Vol 1
Please assist me.
09-18-2011 02:41 PM
Hi,
In your config below, you have deployed the area range command, but have not not actually advertised the Loopback addresses of the interfaces 0 through 7 using the network command.
router ospf 1
log-adjacency-changes
no discard-route
area 15 range 10.0.0.0 255.248.0.0
network 10.8.1.0 0.0.0.255 area 0
network 172.17.1.0 0.0.0.255 area 15
If you go to router B and do a "sh ip route" do you see for example 10.3.0.0 ?
HTH
09-18-2011 11:27 PM
Hi,
NO I am not able to see any loopback route on Router B.
B#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
O IA 172.17.1.0/24 [110/2] via 10.8.1.2, 10:04:06, FastEthernet0/1/0
O IA 172.17.0.1/32 [110/3] via 10.8.1.2, 10:04:06, FastEthernet0/1/0
172.16.0.0/32 is subnetted, 2 subnets
O 172.16.27.195 [110/2] via 172.20.1.6, 10:04:06, FastEthernet0/1
O 172.16.27.1 [110/2] via 172.20.1.2, 10:04:06, FastEthernet0/0
172.20.0.0/30 is subnetted, 2 subnets
C 172.20.1.0 is directly connected, FastEthernet0/0
C 172.20.1.4 is directly connected, FastEthernet0/1
10.0.0.0/24 is subnetted, 1 subnets
C 10.8.1.0 is directly connected, FastEthernet0/1/0
192.168.50.0/32 is subnetted, 1 subnets
C 192.168.50.4 is directly connected, Loopback0
Actually I am following the steps mention in the Routing TCP/IIP Vol book that is why I didnt advertise loopback into OSPF.
I have a doubt. Do I need to advertise every network in the OSPF of Router A. Only summary advertise will not be enough. If i will advertise individual loopback then Router B will have the summary as well as specific route as well and always prefer the specific not the summary then what wil be use of Summary Route.
Please assist
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide