cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
851
Views
3
Helpful
3
Replies
Highlighted
Contributor

OSPF Default Route Problem

Hi all,

I'm working on a little OSPF setup in my lab and having a problem pinging out to the internet...

I have a setup with (3) 3550's running ip routing. I'm configuring OSPF but I can't ping the internet from any L3 switch except the switch with the actual uplink to the internet. Here is my setup...

Internet --> SW1 (fa0/47)

SW1 (fa0/46) --> SW2 (fa0/47)

SW1 (fa0/46) --> SW3 (fa0/47)

Here is my 'sh ip route' from each switch...

SW1#sh ip route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

O 192.168.30.0/24 [110/2] via 10.10.10.6, 01:28:43, FastEthernet0/46

10.0.0.0/30 is subnetted, 2 subnets

C 10.10.10.0 is directly connected, FastEthernet0/48

C 10.10.10.4 is directly connected, FastEthernet0/46

C 192.168.1.0/24 is directly connected, FastEthernet0/47

S* 0.0.0.0/0 [1/0] via 192.168.1.1

SW2#sh ip route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

O 192.168.30.0/24 [110/3] via 10.10.10.1, 01:29:09, FastEthernet0/47

10.0.0.0/30 is subnetted, 2 subnets

C 10.10.10.0 is directly connected, FastEthernet0/47

O 10.10.10.4 [110/2] via 10.10.10.1, 01:29:09, FastEthernet0/47

O*E2 0.0.0.0/0 [110/1] via 10.10.10.1, 01:29:09, FastEthernet0/47

SW3#sh ip route

Gateway of last resort is 10.10.10.5 to network 0.0.0.0

C 192.168.30.0/24 is directly connected, FastEthernet0/1

10.0.0.0/30 is subnetted, 2 subnets

O 10.10.10.0 [110/2] via 10.10.10.5, 01:29:33, FastEthernet0/47

C 10.10.10.4 is directly connected, FastEthernet0/47

O*E2 0.0.0.0/0 [110/1] via 10.10.10.5, 01:29:33, FastEthernet0/47

Here is some more information from all the switches...

(SW1)

interface FastEthernet0/46

no switchport

ip address 10.10.10.5 255.255.255.252

!

interface FastEthernet0/47

no switchport

ip address 192.168.1.90 255.255.255.0

!

interface FastEthernet0/48

no switchport

ip address 10.10.10.1 255.255.255.252

!

router ospf 10

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

default-information originate

(SW2)

interface FastEthernet0/47

no switchport

ip address 10.10.10.2 255.255.255.252

!

router ospf 10

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

network 192.168.20.0 0.0.0.255 area 0

(SW3)

interface FastEthernet0/47

no switchport

ip address 10.10.10.6 255.255.255.252

!

router ospf 10

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

network 192.168.30.0 0.0.0.255 area 0

From SW2 and SW3, I can ping SW1 on all IPs (192.168.1.90, 10.10.10.1, 10.10.10.5) but I can't ping 192.168.1.1 which is my gateway to the internet.

Not sure what I'm doing wrong.... Any help would be appreciated! Thanks!

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Advisor

OSPF Default Route Problem

Hi,

192.168.1.1 must know about these subnets from where you are sourcing your pings so either it runs OSPF and knows about them or you need to configure static routes to them.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
3 REPLIES 3
Contributor

Re: OSPF Default Route Problem

Hi Matt,

on switch 1 the prefix 192.168.1.0/24 is not advertised. As per show ip route you can see that the switch can work this network only as "Connected" . Advertise it below the OSPF process so to make aware all the infrastructure about it  or redistribute the static to 192.168.1.1 below the OSPF process. Do not forget the "subnet" keyword

Alessio

      

PS: check the static to 10.10.10.1 ... Do you really need it? that should be an internal OSPF network. Why did you write a static for it?

Contributor

OSPF Default Route Problem

Thanks for the reply.  Why would I need to advertise my 192.168.1.0/24 network?  That is technically the "WAN" isn't it?  If these 3550's were routers, SW1 would have the connection to the ISP (192.168.1.90) and all the other routers would go through it for the connection to the internet.  If they were all routers, I wouldn't advertise my WAN IP, correct?

Advisor

OSPF Default Route Problem

Hi,

192.168.1.1 must know about these subnets from where you are sourcing your pings so either it runs OSPF and knows about them or you need to configure static routes to them.

Regards.

Alain.

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards