cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

546
Views
0
Helpful
4
Replies
Highlighted
Beginner

Ospf + NAT

Hi,

I'm studying for my CCNA exam

I'm busy seting up a lab with ospf + nat in GNS3.

I'm having problems getting R2 and R3 and clients C2 C3 to be translated true NAT.

I get destination unreachable. So this means i don't have route for them.

This is my config

Can somebody tell me what route i have to add to get this working.

This is config R1

ip dhcp pool chris

   network 10.10.10.0 255.255.255.0

   lease 7

!

!

ip domain name lab.local

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

no ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 10.10.10.254 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 10.10.20.254 255.255.255.0

!

interface Serial0/0

ip address 172.16.50.1 255.255.255.252

ip nat inside

ip virtual-reassembly

clock rate 2000000

!

interface FastEthernet0/1

description Connection to internet

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Serial0/1

no ip address

shutdown

clock rate 2000000

!

router ospf 5

log-adjacency-changes

network 10.10.10.0 0.0.0.255 area 0

network 10.10.20.0 0.0.0.255 area 0

network 172.16.50.0 0.0.0.3 area 0

!

!

!

no ip http server

no ip http secure-server

ip nat inside source list 5 interface FastEthernet0/1 overload

!

access-list 5 permit any

Int f0/1 is the connection to internet.

It passes true 192.168.0.1(gateway ISP home network) and has address 192.168.0.240

These are the routes

Gateway of last resort is 192.168.0.1 to network 0.0.0.0

     172.16.0.0/30 is subnetted, 2 subnets

O       172.16.50.4 [110/128] via 172.16.50.2, 00:09:14, Serial0/0

C       172.16.50.0 is directly connected, Serial0/0

     10.0.0.0/24 is subnetted, 4 subnets

C       10.10.10.0 is directly connected, FastEthernet0/0.10

C       10.10.20.0 is directly connected, FastEthernet0/0.20

O       10.10.30.0 [110/74] via 172.16.50.2, 00:09:14, Serial0/0

O       10.10.40.0 [110/138] via 172.16.50.2, 00:09:14, Serial0/0

C    192.168.0.0/24 is directly connected, FastEthernet0/1

S*   0.0.0.0/0 [254/0] via 192.168.0.1

This is route R2

Gateway of last resort is not set

     172.16.0.0/30 is subnetted, 2 subnets

C       172.16.50.4 is directly connected, Serial0/1

C       172.16.50.0 is directly connected, Serial0/0

     10.0.0.0/24 is subnetted, 4 subnets

O       10.10.10.0 [110/74] via 172.16.50.1, 00:10:04, Serial0/0

O       10.10.20.0 [110/74] via 172.16.50.1, 00:10:04, Serial0/0

C       10.10.30.0 is directly connected, FastEthernet0/0.30

O       10.10.40.0 [110/74] via 172.16.50.6, 00:10:04, Serial0/1

Do i need to at a default network or static route of 0.0.0.0 ?

Kind regards

Christ

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Ospf + NAT

Hello Chris,

Yes you need to have default route configured on R2 and R3

On R2 you configure default route towards 172.16.50.1

and on R3 you can do it towards the other end  IP of the point to point serial connected to R2

Please let me know if you have further questions

Harish

Please rate all helpful posts!

View solution in original post

4 REPLIES 4

Ospf + NAT

Hello Chris

Where is your clients connected to I mean behind which router ?

regards

harish.

Beginner

Ospf + NAT

hi thx for fast reply

there behind R2 and R3

i've added pic in attachment (lab design)

Ospf + NAT

Hello Chris,

Yes you need to have default route configured on R2 and R3

On R2 you configure default route towards 172.16.50.1

and on R3 you can do it towards the other end  IP of the point to point serial connected to R2

Please let me know if you have further questions

Harish

Please rate all helpful posts!

View solution in original post

Beginner

Ospf + NAT

thank you very much Harish

CreatePlease to create content
Content for Community-Ad