cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2319
Views
0
Helpful
5
Replies

OSPF not enabled on GigabitEthernet

Hi,

I have to configure OSPF between the two devices. GigabitEthernet9/1 is the interface which is connected to device to which I have establish OSPF neighbourship. Do I need to assign IP address to the access port to enable the OSPF Neighbourship.

1#sh ip ospf interface gigabitEthernet 9/1

%OSPF: OSPF not enabled on GigabitEthernet9/1

Below is the inteface configuration:

#sh run interface gigabitEthernet 9/1
Building configuration...

interface GigabitEthernet9/1
switchport
switchport access vlan 20
switchport mode access
end

#sh run interface vlan 20

interface Vlan20
ip address 10.57.0.251 255.255.255.248

Regards,

T.K

5 REPLIES 5
Rising star

Re: OSPF not enabled on GigabitEthernet

Hi,

What is your OSPF router config.

router ospf 1

network 10.57.0.251 0.0.0.7 i suppose widlcard mask

Thanks

Highlighted
Rising star

Re: OSPF not enabled on GigabitEthernet

Hi,

as long as your access switchport is a member of the VLAN 20 in this case, with proper OSPF config, there should be no problems.

Hope it Helps,

Soroush.

Hope it Helps!

Soroush.
Beginner

Re: OSPF not enabled on GigabitEthernet

Hi please correct me if I'm wrong I i look at your command you are using a switch. You can neighbour the switch using no switch port command on the switch interface then it will neighbour it

Sent from Cisco Technical Support iPad App

Beginner

Re: OSPF not enabled on GigabitEthernet

Hi T.K,

Just as long as your OSPF router config and network config between VLAN 20 and the OSPF enabled layer 3 device that is connected to gigabitEthernet 9/1 is correct and both belong to the same network then it should come online just fine.

Can you post the OSPF router config of both devices?

is that a layer 3 switch and does it support OSPF?

Hall of Fame Expert

OSPF not enabled on GigabitEthernet

Hello Thiyagarajankalaiselvan.

use

show ip ospf interface vlan20

as the SVI is your layer3 interface not gi9/1 that is a layer 2 port

the device is just telling you this basic fact OSPF is not enabled on a L2 port but this is not a real problem

Hope to help

Giuseppe

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards