cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6424
Views
5
Helpful
41
Replies
ed.crawford
Beginner

OSPF shows FULL but one route is not picking routes

I have two 2911 routers and one 2901 router running OSPF between them.

Router 1.1.1.1 is connected to router 2.2.2.2  via G0/1

Router 1.1.1.1 is connected ro router 3.3.3.3 via G0/2

As you can see from the snippets below all the neighbors come up as full and two routers get the routes from the router in the middle (1.1.1.1), however the middle one is not picking up any routes.  Everything else is set to default.  Any ideas as to what is going on here?

Configuration for Router 1.1.1.1

router ospf 1
router-id 1.1.1.1
network 10.10.1.0 0.0.0.255 area 0
network 10.100.1.0 0.0.0.255 area 0
network 128.11.0.0 0.0.255.255 area 0
network 192.168.17.0 0.0.0.3 area 0
network 192.168.17.8 0.0.0.3 area 0

Neighbors for Router 1.1.1.1

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           1   FULL/DR         00:00:39    192.168.17.10   GigabitEtherne
t0/2
2.2.2.2           1   FULL/DR         00:00:34    192.168.17.2    GigabitEtherne
t0/1

Database for 1.1.1.1

           OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1247        0x80000006 0x003837 4
2.2.2.2         2.2.2.2         1253        0x80000061 0x00F4D4 1
3.3.3.3         3.3.3.3         1248        0x8000005C 0x007343 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.17.2    2.2.2.2         1248        0x80000050 0x00A7B5
192.168.17.10   3.3.3.3         1243        0x80000052 0x0057F3

Route table for Router 1.1.1.1

    1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback1
      10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
C        10.10.1.0/24 is directly connected, GigabitEthernet0/0.10
L        10.10.1.1/32 is directly connected, GigabitEthernet0/0.10
C        10.10.10.0/29 is directly connected, GigabitEthernet0/0
L        10.10.10.1/32 is directly connected, GigabitEthernet0/0
C        10.100.1.0/24 is directly connected, GigabitEthernet0/0.100
L        10.100.1.1/32 is directly connected, GigabitEthernet0/0.100
C        10.200.1.0/24 is directly connected, GigabitEthernet0/0.200
L        10.200.1.1/32 is directly connected, GigabitEthernet0/0.200
      192.68.117.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.68.117.0/24 is directly connected, GigabitEthernet0/0.117
L        192.68.117.1/32 is directly connected, GigabitEthernet0/0.117
      192.168.17.0/24 is variably subnetted, 4 subnets, 2 masks
C        192.168.17.0/30 is directly connected, GigabitEthernet0/1
L        192.168.17.1/32 is directly connected, GigabitEthernet0/1
C        192.168.17.8/30 is directly connected, GigabitEthernet0/2
L        192.168.17.9/32 is directly connected, GigabitEthernet0/2

Configuration for 2.2.2.2

router ospf 1
router-id 2.2.2.2
network 10.10.2.0 0.0.0.255 area 0
network 10.100.2.0 0.0.0.255 area 0
network 192.168.17.0 0.0.0.3 area 0

Neighbors for Router 2.2.2.2

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:35    192.168.17.1    GigabitEtherne
t0/1

Dtabase for Router 2.2.2.2

           OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1528        0x80000006 0x003837 4
2.2.2.2         2.2.2.2         1533        0x80000061 0x00F4D4 1
3.3.3.3         3.3.3.3         1528        0x8000005C 0x007343 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.17.2    2.2.2.2         1528        0x80000050 0x00A7B5
192.168.17.10   3.3.3.3         1525        0x80000052 0x0057F3

Route Table for Router 2.2.2.2

     2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback1
      10.0.0.0/24 is subnetted, 2 subnets
O        10.10.1.0 [110/2] via 192.168.17.1, 00:26:37, GigabitEthernet0/1
O        10.100.1.0 [110/2] via 192.168.17.1, 00:26:37, GigabitEthernet0/1
      192.168.17.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.17.0/30 is directly connected, GigabitEthernet0/1
L        192.168.17.2/32 is directly connected, GigabitEthernet0/1
O        192.168.17.8/30
           [110/2] via 192.168.17.1, 00:26:27, GigabitEthernet0/1

Configuration for Router 3.3.3.3

router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 10.100.3.0 0.0.0.255 area 0
network 10.200.3.0 0.0.0.255 area 0
network 192.168.17.8 0.0.0.3 area 0

Neighbors for Router 3.3.3.3

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:35    192.168.17.9    GigabitEtherne
t0/1

Database for Router 3.3.3.3

           OSPF Router with ID (3.3.3.3) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1854        0x80000006 0x003837 4
2.2.2.2         2.2.2.2         1860        0x80000061 0x00F4D4 1
3.3.3.3         3.3.3.3         1853        0x8000005C 0x007343 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.17.2    2.2.2.2         1855        0x80000050 0x00A7B5
192.168.17.10   3.3.3.3         1849        0x80000052 0x0057F3

Route Table for Routerr 3.3.3.3


      3.0.0.0/32 is subnetted, 1 subnets
C        3.3.3.33 is directly connected, Loopback1
      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O        10.10.1.0/24 [110/2] via 192.168.17.9, 00:31:29, GigabitEthernet0/1
C        10.10.3.0/24 is directly connected, GigabitEthernet0/0.10
L        10.10.3.1/32 is directly connected, GigabitEthernet0/0.10
O        10.100.1.0/24 [110/2] via 192.168.17.9, 00:31:29, GigabitEthernet0/1
      192.168.17.0/24 is variably subnetted, 3 subnets, 2 masks
O        192.168.17.0/30
           [110/2] via 192.168.17.9, 00:31:29, GigabitEthernet0/1
C        192.168.17.8/30 is directly connected, GigabitEthernet0/1
L        192.168.17.10/32 is directly connected, GigabitEthernet0/1

1 ACCEPTED SOLUTION

Accepted Solutions

Thats because when you redistribute they will be external. If you don't want this, and what I can see from your config, you need to advertise the networks. You seem to be missing some but I don't know if that is by design / your requirements.

Remeber in OPSF your network commands really just tell the router which interfaces will participate in OSPF and the networks you want to advertise. You only need to "speak" OSPF on those interfaces directly involved in establishing neigbor relationships and so I would add the passive default command. I used GNS3 to make my lab so my interfaces are different to your, but you should get the idea.

For exmaple, if you want full connectivity I would do the following (and this way you don't get external routes).

1.1.1.1

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0                ----> I add this to be able to ping the loopback addresses.

network 10.10.1.0 0.0.0.255 area 0

network 10.100.1.0 0.0.0.255 area 0

network 128.11.0.0 0.0.255.255 area 0

network 192.168.17.0 0.0.0.3 area 0

network 192.168.17.8 0.0.0.3 area 0

network 10.10.10.0 0.0.0.255 area 0       ----> I add this, missing?.

passive-interface default                        -----> Added. I only want to advertise OSPF to my neighbors so I turn off by default on all interfaces

no passive-interface FastEthernet0/0      -----> And tun on again here on this interface 

no passive-interface FastEthernet0/1      -----> And this one.

2.2.2.2
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0                ----> I add this to be able to ping the loopback addresses.
network 10.10.2.0 0.0.0.255 area 0
network 10.100.2.0 0.0.0.255 area 0
network 128.10.0.0 0.0.255.255 area 0    ----> I added this, missing?
network 192.168.17.0 0.0.0.3 area 0
passive-interface default
no passive-interface FastEthernet0/0
3.3.3.3
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0                ----> I add this to be able to ping the loopback addresses.
network 10.10.3.0 0.0.0.255 area 0
network 10.100.3.0 0.0.0.255 area 0
network 10.200.3.0 0.0.0.255 area 0
network 192.168.17.8 0.0.0.3 area 0
passive-interface default
no passive-interface FastEthernet0/0
Doing this I get full routing tables and full connectivity:
R7 - My HUB routers
R7(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 192.168.17.2, 00:05:38, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 192.168.17.10, 00:05:38, FastEthernet0/1
O    128.10.0.0/16 [110/2] via 192.168.17.2, 00:05:38, FastEthernet0/0
C    128.11.0.0/16 is directly connected, FastEthernet1/0.200
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C       10.10.1.0/24 is directly connected, FastEthernet1/0.10
O       10.10.2.0/24 [110/2] via 192.168.17.2, 00:05:38, FastEthernet0/0
O       10.10.3.0/24 [110/2] via 192.168.17.10, 00:05:38, FastEthernet0/1
C       10.10.10.0/29 is directly connected, FastEthernet1/0
O       10.100.2.0/24 [110/2] via 192.168.17.2, 00:05:39, FastEthernet0/0
C       10.100.1.0/24 is directly connected, FastEthernet1/0.100
     192.168.17.0/30 is subnetted, 2 subnets
C       192.168.17.8 is directly connected, FastEthernet0/1
C       192.168.17.0 is directly connected, FastEthernet0/0
C    192.68.117.0/24 is directly connected, FastEthernet1/0.117
So the question is, doing it htis way, what still sin't working for you? It should all work. Maybe you need to redistribute static subnets on one of your routers because you have networks declared in the network statement, but no interfaces in those networks. So you could put a static route in the table and redistribute? But then why are you advertising these networks anyway on router 3.3.3.3? (network 10.100.3.0 & 10.200.3.0). OK I see one is your voice vlan but you have no dot1q interface in this vlan at the momet so it doesn't advertise...
Hope all this is making sense.
Regards,
Ian

View solution in original post

41 REPLIES 41
IAN WHITMORE
Enthusiast

Make sure your router 1.1.1.1 is the DR.

Regards,

Ian

How can I force that?

ip ospf priority <0-255> under your routing process. Sorry my mistake I meant interface. It won't let you put ip ospf priority under the routing process.

you should set your spokes with priority of 0 so they don't take part in the DR/BDR election. then you can leave the 1.1.1.1 as default OR you can just put a higher priority on your 1.1.1.1 (hub) router.

you will need to restart the ospf processes so the "election" takes place again. you can use the #clear ip ospf process

but if you have the option to you can reload the routers.

don't forget after making the changes to #wr mem.

Hi,

To achieve what Ian said, the quickest way is to issue on R2 and R3 interfaces connected to R1 the following command:

ip ospf priority 0

Then instantaneously R1 will be the DR and the other 2 will be DROTHERS.

But there is something I'd like to know: how come in a broadcast multiaccess media the DR election went so wrong?

Can you post  sh run | s ospf as well as sh ip os in br and sh run int gix/x  for  on the 3 routers.

Regards.

Alain.

Don't forget to rate helpful posts.

Here are the requested shows.  I have set the priority to 0 on 2.2.2.2 and 3.3.3.3 and have verified this with show ip os top.  I have rebooted all of the routers and it sill shows BDR on these two.

1.1.1.1

NGHA-RH-RTR-01#sh run | s ospf
router ospf 1
router-id 1.1.1.1
network 10.10.1.0 0.0.0.255 area 0
network 10.100.1.0 0.0.0.255 area 0
network 128.11.0.0 0.0.255.255 area 0
network 192.168.17.0 0.0.0.3 area 0
network 192.168.17.8 0.0.0.3 area 0

NGHA-RH-RTR-01#sh ip os in br
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Gi0/2        1     0               192.168.17.9/30    1     BDR   1/1
Gi0/1        1     0               192.168.17.1/30    1     BDR   1/1
Gi0/0.100    1     0               10.100.1.1/24      1     DR    0/0
Gi0/0.10     1     0               10.10.1.1/24       1     DR    0/0

NGHA-RH-RTR-01#sh run int g0/1  (to 2.2.2.2)
Building configuration...

Current configuration : 102 bytes
!
interface GigabitEthernet0/1
ip address 192.168.17.1 255.255.255.252
duplex auto
speed auto
end

GHA-RH-RTR-01#sh run int g0/2  (to 3.3.3.3)
Building configuration...

Current configuration : 137 bytes
!
interface GigabitEthernet0/2
description Link to Vulcan Street
ip address 192.168.17.9 255.255.255.252
duplex auto
speed auto
end

2.2.2.2

NGHA-BD-RTR-01#sh run | s ospf
router ospf 1
router-id 2.2.2.2
priority 0
network 10.10.2.0 0.0.0.255 area 0
network 10.100.2.0 0.0.0.255 area 0
network 192.168.17.0 0.0.0.3 area 0

NGHA-BD-RTR-01#sh ip os in br
Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Gi0/1        1     0               192.168.17.2/30    1     DR    1/1
Gi0/0.100    1     0               10.100.2.1/24      1     DOWN  0/0
Gi0/0.10     1     0               10.10.2.1/24       1     DOWN  0/0

NGHA-BD-RTR-01#sh run int g0/1  (to 1.1.1.1)

!
interface GigabitEthernet0/1
description Link to Reidhouse
ip address 192.168.17.2 255.255.255.252
duplex auto
speed auto
end

3.3.3.3

NGHA-VS-RTR-01#sh run | s ospf

router ospf 1
router-id 3.3.3.3
priority 0
log-adjacency-changes
network 10.100.3.0 0.0.0.255 area 0
network 10.200.3.0 0.0.0.255 area 0
network 192.168.17.8 0.0.0.3 area 0

NGHA-VS-RTR-01#sh ip os in br

Interface    PID   Area            IP Address/Mask    Cost  State Nbrs F/C
Gi0/1        1     0               192.168.17.10/30   1     DR    1/1

NGHA-BD-RTR-01#sh run int g0/1  (to 1.1.1.1)

NGHA-BD-RTR-01#sh run int g0/1  (to 1.1.1.1)

interface GigabitEthernet0/1
description Link to Reidhouse
ip address 192.168.17.10 255.255.255.252
duplex auto
speed auto

Hi,

I have rebooted and 2.2.2.2 and 3.3.3.3 still show as BDR.  I have verified with sho os top and both 2.2.2.2 and 3.3.3.3 are set to 0 andd 1.1.1.1 is set to default of 64.

the default ospf priority is 1, not 64 and when the priority is set to 0 then the router must be DROTHER for this segment and the effect is immediate,

there is no need to clear the ospf process.

2.2.2.2

NGHA-BD-RTR-01#sh run | s ospf
router ospf 1
router-id 2.2.2.2
priority 0        this must be an interface command not a routing process command  and the command is ip ospf priority 0
network 10.10.2.0 0.0.0.255 area 0
network 10.100.2.0 0.0.0.255 area 0
network 192.168.17.0 0.0.0.3 area 0

I've never seen this command in router ospf process !  what version of IOS are you running? in pre-15.x this command doesn't exist and so shouldn't appear in any show command.

Regards.

Alain.

Don't forget to rate helpful posts.
Mahesh Gohil
Rising star

Hello,

Do you really need DR/BDR selection for this network type. I can see there is p2p link from 1.1.1.1 to two other

routers.

For me the routes in database and not in routing table have one solution and that is putting below two command

on all the interface enabled for ospf.

ip ospf network point-to-point

ip mtu 1500

But remember by putting command "ip ospf network point-to-point" will force ospf process to treat this ethernet link as p2p for ospf.

regards

Mahesh

No you don't really "need" it, but there is no harm in it if configured correctly.

I have added this to all of the interfaces using OSPF, cleared ip os proc and still having issue.

ed.crawford
Beginner

I have forced the other routers and it  showws that 1.1.1.1 is the DR and the others are BDRs, but is still is not working.

If you put them to 0 they shouldn't be BDR they should be DROTHERS as Alain says. Given them a restart if you can.

Regards,

Ian

I have rebooted and 2.2.2.2 and 3.3.3.3 still show as BDR.  I have verified with sho os top and both 2.2.2.2 and 3.3.3.3 are set to 0 andd 1.1.1.1 is set to default of 64.

ed.crawford
Beginner

    Here is the show ip os top  I didn't change to priority on 1.1.1.1

     OSPF Router with ID (1.1.1.1) (Process ID 1)


                Base Topology (MTID 0)

Topology priority is 64
Router is not originating router-LSAs with maximum metric
Number of areas transit capable is 0
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
    Area BACKBONE(0)
        SPF algorithm last executed 00:09:51.040 ago
        SPF algorithm executed 2 times
        Area ranges are

        

OSPF Router with ID (2.2.2.2) (Process ID 1)

                Base Topology (MTID 0)

Topology priority is 0
Router is not originating router-LSAs with maximum metric
Number of areas transit capable is 0
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
    Area BACKBONE(0)
        SPF algorithm last executed 00:10:49.392 ago
        SPF algorithm executed 4 times
        Area ranges are


            OSPF Router with ID (3.3.3.3) (Process ID 1)


                Base Topology (MTID 0)

Topology priority is 0
Router is not originating router-LSAs with maximum metric
Number of areas transit capable is 0
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
    Area BACKBONE(0)
        SPF algorithm last executed 00:12:36.696 ago
        SPF algorithm executed 3 times
        Area ranges are

Hi,

I've never seen this show command before and I don't know the meaning of this topology priority.

Can you explain what it does

UPDATE:  now I know what it is but still must search what this topology priority means but I'm fairly confident that it has nothing to do with the DR election

So can you change the ospf priority under interface and tell us if it is ok now.---> sh ip os nei should show DROTHER for R2 and R3.

Regards.

Alain.

Don't forget to rate helpful posts.