10-18-2019 10:09 AM - edited 10-18-2019 05:58 PM
There is this small problem with my setup that I can't figure out. What I want to achieve simply is gain remote access to my switch from the laptop.
I have two VLAN's for Data and Management,
Data VLAN 60 (10.60.0.230/24)
Management VLAN 99 (10.61.0.230/24).
I have configured a sub interface on the router for VLAN 99 and there is no issue pinging to that interface (g0/0.99). But I can't seem to figure out why I cannot ping the other router interface (s0/1/0).
Heres the link to the Packet tracer file - https://drive.google.com/file/d/1_EUBH4uAQzhdn2rgPA2fif3LnCcZ5FtU/view?usp=sharing
Solved! Go to Solution.
10-19-2019 01:45 AM - edited 10-19-2019 06:16 AM
Hi,
Why is it happening?
As I checked that Switch is taking source VLAN 60 for sending a ping command but the router is denying because it will unable to understand the VLAN for VLAN 60 because of no VLAN 60 on the router. This issue must be resolved if you will choose a source keyword with ping command but due to limitation in the PT, this source keyword is not supported.
Here are the logs:
interface Vlan60
mac-address 0001.6407.7701
ip address 10.60.0.230 255.255.255.0
!
interface Vlan99
mac-address 0001.6407.7702
ip address 10.61.0.230 255.255.255.0
Note: Shutdown the SVI VLAN 60 and ping will working start.
This is the reason that we guide to configure only a management SVI with IP address on Layer 2 switches.
10-19-2019 04:59 AM
Yes indeed. There can only be one management interface on a layer 2 switch. That management interface could be Vlan 60 as well, IF you configure a corresponding layer 3 subinterface on the router, and then change the default gateway on the layer 2 switch. So the below would work as well (changes marked in bold):
Switch0
interface Vlan60
mac-address 0001.6407.7701
ip address 10.60.0.230 255.255.255.0
!
interface Vlan99
mac-address 0001.6407.7702
ip address 10.61.0.230 255.255.255.0
shutdown
!
ip default-gateway 10.60.0.100
Router 1
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.60
encapsulation dot1Q 60
ip address 10.60.0.100 255.255.255.0
!
interface GigabitEthernet0/0.99
encapsulation dot1Q 99
ip address 10.61.0.100 255.255.255.0
10-18-2019 10:19 AM
10-18-2019 10:35 AM
10-18-2019 12:07 PM
10-18-2019 05:42 PM
10-18-2019 06:40 PM
It works if I configure a static route to 172.16.1.0/24 network with a L3 switch. Why can't I use a L2 switch without the need for a route even though I have added the ip default-gateway????
10-18-2019 11:46 PM
Hi,
I noticed two things:
1. No default gateway configured on the PC0. You must define a default gateway.
2. You are using Layer 2 switch for VLAN routing but Layer 2 switch can't perform Inter-VLAN routing. Here, You must select the Layer 3 switch for InterVLAN routing or extend the VLANs till to Router so the router can perform InterVLAN routing.
A layer 2 switch is Send packet to a destination on the basis of MAC address means it is totally working on the MAC address list but InterVLAN routing is required Route a Packet with help of IP address and Routing table. This is a basic difference between Layer 2 and Layer 3 switch.
10-19-2019 12:20 AM
10-19-2019 01:43 AM
Hello,
I am kind of lost on what you are asking...
Either way, in order to reach 10.61.0.230 (the management IP address in Vlan 99 on the switch) from the laptop, you need to shut the interface Vlan 60 down:
Switch0#conf t
Switch0(config)#interface Vlan 60
Switch0(config-if)#shut
That also allows you to ping 10.61.0.100 and 172.16.1.2 from the switch...
10-19-2019 04:46 AM
10-19-2019 04:59 AM
Yes indeed. There can only be one management interface on a layer 2 switch. That management interface could be Vlan 60 as well, IF you configure a corresponding layer 3 subinterface on the router, and then change the default gateway on the layer 2 switch. So the below would work as well (changes marked in bold):
Switch0
interface Vlan60
mac-address 0001.6407.7701
ip address 10.60.0.230 255.255.255.0
!
interface Vlan99
mac-address 0001.6407.7702
ip address 10.61.0.230 255.255.255.0
shutdown
!
ip default-gateway 10.60.0.100
Router 1
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.60
encapsulation dot1Q 60
ip address 10.60.0.100 255.255.255.0
!
interface GigabitEthernet0/0.99
encapsulation dot1Q 99
ip address 10.61.0.100 255.255.255.0
10-19-2019 05:04 AM
10-19-2019 01:45 AM - edited 10-19-2019 06:16 AM
Hi,
Why is it happening?
As I checked that Switch is taking source VLAN 60 for sending a ping command but the router is denying because it will unable to understand the VLAN for VLAN 60 because of no VLAN 60 on the router. This issue must be resolved if you will choose a source keyword with ping command but due to limitation in the PT, this source keyword is not supported.
Here are the logs:
interface Vlan60
mac-address 0001.6407.7701
ip address 10.60.0.230 255.255.255.0
!
interface Vlan99
mac-address 0001.6407.7702
ip address 10.61.0.230 255.255.255.0
Note: Shutdown the SVI VLAN 60 and ping will working start.
This is the reason that we guide to configure only a management SVI with IP address on Layer 2 switches.
10-19-2019 04:42 AM
10-19-2019 04:46 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide