03-07-2012 07:29 PM - edited 03-07-2019 05:25 AM
I need to setup my 6509 with PBR going to two different Firewalls. The 6509 has vlans and multiple serial interfaces. What/where do I install the policy-maps? I want to direct one of the vlans to one firewall and the other vlans and wan subnets to the other firewall.
03-10-2012 07:37 AM
Here is what I would do.
ip route 0/0 FW1(100.1.100.2)
ip access-list extended PBRoute
deny ip 10.133.3.0 0.0.0.255
permit ip 10.133.3.0 0.0.0.255 any
route-map SOME_RTE_MAP permit 10
match ip address PBRoute
set ip next-hop "FW2"
int vlan 30
ip policy route-map PBRoute
This is what I would do if I were you, apart from redoing the network in a better way.
Hope this helps
03-10-2012 07:41 AM
This line I am stuggling with: deny ip 10.133.3.0 0.0.0.255
I have so many
03-10-2012 07:49 AM
This is policy routing, deny on an ACL applied to policy means the deny line is NOT processed as part of policy, whatever the policy that may be, do not think of it as an ACL applied to access-group. As part of stop-gap measure I had to do the something this similar, but it required policy based routing with PAT.
03-10-2012 08:05 AM
so let me understand this:
the deny rule in the acl tells the policy to allow traffic from the
other subnets?
for configuration sake what would I put for: ??
03-10-2012 08:11 AM
Yep, you are correct.
Attributes like match, set parameters are LOGICAL AND statements in a route-map, if there is a deny on the ACL that is part of the match clause, nothing else is processed on the route-map and it exits the policy, there by no PBR i.e. it is a normal packet. That is my understanding and that is the way I've made this work before.
Hope this helps.
03-10-2012 08:17 AM
so last question,
for this statement: deny ip 10.133.3.0 0.0.0.255
should I write as: deny ip 10.133.3.0 0.0.0.255 any
03-10-2012 08:19 AM
No, on your ACL:
deny ip 10.133.3.0/24
permit ip 10.133.3.0/24 any (Do PBR routing for packets going to anywhere but internal networks)
03-10-2012 02:27 PM
ok, I know I am struggling with this but I am confused about one line:
Ip access-list ext 150
deny ip 10.133.3.0/24 is not a Cisco option.....
so should the line look like this:
deny ip 10.133.3.0/24 10.133.2.0/24 10.133.1.0/24 10.133.4.0/23 ?
03-10-2012 06:30 PM
Oh Wow, I was under the impression that you would be able to expand /24 to its corresponding wildcard.
Example:
ip access-list ext 150
deny ip 10.133.3.0 0.0.0.255 10.133.2.0 0.0.0.255
so on and so forth.
03-10-2012 06:39 PM
The problem I have with your solution is I would have to deny all subnets except 10.133.3.0/24 not sure how to go about that
03-10-2012 08:49 PM
I do not know how else you would like to acheive it apart from re-architecting the network in a better way, if all your internal routes are 10/8 (i.e. 10.0.0.0 255.0.0.0) then use that network instead of all your individual subnets. or use the entire RFC 1918 spectrum.
03-11-2012 06:39 AM
That is what I was thinking. We have 10/8 and 172/16 rfc1918 subnets.
I am going to test this Wednesday night.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide