07-28-2016 08:45 AM - edited 03-08-2019 06:48 AM
I have a 4500 switch connected to a 2960 via a 1GB connection. I want to setup port aggregation so that I can increase my bandwidth to 2GB. When I connect the second connection, I only get a link light on the 4500 side. If I do a show spanning-tree, the 4500 port does show up, so it is as if the 4500 thinks the connection is good, but the 2960 doesn't. I have the same configuration on both of the 4500 ports:
interface TenGigabitEthernet1/15 (this is the secondary port I want to add)
switchport mode trunk
mtu 9198
interface TenGigabitEthernet1/16 (this is the currently active port)
switchport mode trunk
mtu 9198
Here are the port configs on the 2960:
interface GigabitEthernet1/0/26 (this is the currently active port)
switchport trunk allowed vlan 1-3,5,6,10,11,15,16,20,21,25,26,30,31,35,36,40
switchport trunk allowed vlan add 41,45,46,50,51,55,60-62,64-68,70,75,77,78,80
switchport trunk allowed vlan add 81,85-91,95,96,99-101,105-108,110,111,115
switchport trunk allowed vlan add 116,124,125,130,135,140,145,150,151,155,160
switchport trunk allowed vlan add 165,170,171,180-191,200,207,229,230,242,299
switchport mode trunk
interface GigabitEthernet1/0/28 (this is the secondary port I want to add)
switchport mode trunk
I'm not sure why the 2960 will not see the link as up. Any help would be appreciated!
Thanks,
Tom
07-28-2016 09:02 AM
You have to create a port-channel since STP will only allow one active port to prevent loops in the network.
Interface Po1
switchport mode trunk
mtu 9198
interface TenGigabitEthernet1/15
channel-group 1 mode active
interface TenGigabitEthernet1/16
channel-group 1 mode active
!Then on the access switches
Interface po1
switchport trunk allowed vlan 1-3,5,6,10,11,15,16,20,21,25,26,30,31,35,36,40
switchport trunk allowed vlan add 41,45,46,50,51,55,60-62,64-68,70,75,77,78,80
switchport trunk allowed vlan add 81,85-91,95,96,99-101,105-108,110,111,115
switchport trunk allowed vlan add 116,124,125,130,135,140,145,150,151,155,160
switchport trunk allowed vlan add 165,170,171,180-191,200,207,229,230,242,299
switchport mode trunk
interface GigabitEthernet1/0/26
switchport trunk allowed vlan 1-3,5,6,10,11,15,16,20,21,25,26,30,31,35,36,40
switchport trunk allowed vlan add 41,45,46,50,51,55,60-62,64-68,70,75,77,78,80
switchport trunk allowed vlan add 81,85-91,95,96,99-101,105-108,110,111,115
switchport trunk allowed vlan add 116,124,125,130,135,140,145,150,151,155,160
switchport trunk allowed vlan add 165,170,171,180-191,200,207,229,230,242,299
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet1/0/28
switchport trunk allowed vlan 1-3,5,6,10,11,15,16,20,21,25,26,30,31,35,36,40
switchport trunk allowed vlan add 41,45,46,50,51,55,60-62,64-68,70,75,77,78,80
switchport trunk allowed vlan add 81,85-91,95,96,99-101,105-108,110,111,115
switchport trunk allowed vlan add 116,124,125,130,135,140,145,150,151,155,160
switchport trunk allowed vlan add 165,170,171,180-191,200,207,229,230,242,299
switchport mode trunk
channel-group 1 mode active
-Smalley
07-28-2016 09:41 AM
Disclaimer
07-28-2016 10:42 AM
Thanks Greg,
I set that up, but some of those ports are still showing as down. Specifically:
4500 port T1/15: up/down
4500 port T1/16: up/up (original active port)
2960 port G1/0/26: up/up (original active port)
2960 port G1/0/28: down/down
I had a port channel setup already for 2 different ports aside from the issue, and both those ports show as up, so I was expecting the same behavior with this new port channel.
07-28-2016 10:48 AM
A port that is down/down usually indicates a physical problem. Did you try to "shut,no shut" the interfaces to get them to come up?
show etherchannel summary
show int T1/15
show int G1/0/28
07-28-2016 11:02 AM
I'll check the physical layer. Might have a bad fiber, haven't used it previously. Thanks again.
07-28-2016 11:12 AM
show int t1/15 transceiver detail
Will show you if it's seeing light or not, sometimes it can be necessary to flip the polarity on the send/receive.
Please rate this comment if it was helpfull
07-28-2016 11:16 AM
07-28-2016 11:23 AM
Either don't have a DOM "Digital Optical Monitoring" transceiver or the SFP+ is not being recognized.
07-29-2016 07:41 AM
OK I checked physical and that is ok. Current status is:
4500 interface T1/15: up/down (suspended)
config:
interface TenGigabitEthernet1/15
switchport mode trunk
mtu 9198
bandwidth 10000
channel-group 2 mode active
2960 interface G1/0/28: down/down (not connect)
config:
interface GigabitEthernet1/0/28
description LINK TO 675
switchport trunk allowed vlan 1-3,5,6,10,11,15,16,20,21,25,26,30,31,35,36,40
switchport trunk allowed vlan add 41,45,46,50,51,55,60-62,64-68,70,75,77,78,80
switchport trunk allowed vlan add 81,85-91,95,96,99-101,105-108,110,111,115
switchport trunk allowed vlan add 116,120,124,125,130,135,140,145,150,151,155
switchport trunk allowed vlan add 160,165,170,171,180-191,200,207,229,230,242
switchport trunk allowed vlan add 299
switchport mode trunk
channel-group 1 mode active
error message on 4500: Te1/15 suspended: LACP currently not enabled on the remote port.
I don't see a difference. Do the channel-group numbers have to be the same? I already had a channel-group on the 4500, so I had to use number 2.
07-29-2016 09:51 AM
Hi;
First you need to remove the speed 10000 command from int T1/15 on 4500X switch.
Second the Port-channel are locally significant, no need to match, for better understanding you can put same no.
Now your configuration should be as follows:
4500X:
int po2
switchport mode trunk
mtu 9198
interface range TenGigabitEthernet1/15 - 16
channel-group 2 mode active
2960:
int po 1
description LINK TO 675
switchport trunk allowed vlan 1-3,5,6,10,11,15,16,20,21,25,26,30,31,35,36,40
switchport trunk allowed vlan add 41,45,46,50,51,55,60-62,64-68,70,75,77,78,80
switchport trunk allowed vlan add 81,85-91,95,96,99-101,105-108,110,111,115
switchport trunk allowed vlan add 116,120,124,125,130,135,140,145,150,151,155
switchport trunk allowed vlan add 160,165,170,171,180-191,200,207,229,230,242
switchport trunk allowed vlan add 299
switchport mode trunk
interface range G1/0/26, G1/0/28
channel-group 1 mode active
Note: Make sure you plug the 1G SFP on 4500X switch.
Thanks & Best regards;
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Just a usage note to what Greg has posted, when using Etherchannel, you should review and adjust the link hashing algorithm, on each platform, to be most suitable for your traffic.
Also keep in mind, with two gig links you have 2g of available bandwidth, but any one flow will only use one link, and even with multiple flows, there's no dynamic load balancing. On average, your effective bandwidth will probably be about 1.5g.
Lastly, if you decide you want to combine even more than 2 links for additional bandwidth, Etherchannel works best with a power of two number of links.