cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2658
Views
0
Helpful
3
Replies
Participant

port channel and sub interface

I have a router on  which I would like to create a port channel that spans two different Nexus 2248TP switches, and then create a couple subinterfaces on the router's po interface.  I've done this successfully on my primary router, but the config doesn't seem to work on the backup router.  The primary is running IOS 15, while the backup is running 12.4.25d advanced IP.  I do see the trunk come up from the switch side, and my router subinterfaces and po interface show up, however I'm not able to get anywhere from the router.  It's not even able to reach other hosts on the same network.  As soon as I remove the port channel config and use the physical interface and assign the same address used on the port channel interface, everything works as expected and I have connectivity.

interface Port-channel21

no ip address

hold-queue 150 in

!

interface Port-channel21.248

encapsulation dot1Q 248 native

ip address 100.100.100.1 255.255.255.0

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

channel-group 21

!

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

channel-group 21

!

!

thank you,

Bill

3 REPLIES 3
VIP Advocate

Re: port channel and sub interface

have you tried removing native from the encapsulation dot1Q 248 native command? is the native vlan the same on both ends of the link and on all etherchannel trunks?

could you post the interface and portchannel interface configurations for both ends of the link please

--
Please remember to rate and select a correct answer
Highlighted
Participant

Re: port channel and sub interface

Originally I set it up just using vlan 1 as the native vlan and only when that didn't work I tried using 248 as the native vlan.  So I've moved it back, same config that is working on my other router, to use vlan 1 as the native, but no change yet.

5548-1

interface Ethernet100/1/3

   description Public-Qwest-Secondary

   switchport mode trunk

   channel-group 21

interface port-channel21

   description Public-Qwest-Sec

   switchport mode trunk

   vpc 21

5548-2

interface Ethernet100/1/3

   description Public-Qwest-Secondary

   switchport mode trunk

   channel-group 21

interface port-channel21

   description Public-Qwest-Secondary

   switchport mode trunk

   vpc 21

HBG-Nexus5k-2(config-if)# sh int trunk

--------------------------------------------------------------------------------

Port          Native  Status        Port

               Vlan                  Channel

--------------------------------------------------------------------------------

Eth1/1        1       trnk-bndl     Po1000

Eth1/2        1       trnk-bndl     Po1000

Eth1/3        1       trnk-bndl     Po1000

Eth1/4        1       trnk-bndl     Po1000

Eth1/8        99      trunking      --

Eth1/10       99      trunking      --

Po20          1       trunking      --

Po21          1       trunking      --

HBG-Nexus5k-1# sh int trunk

--------------------------------------------------------------------------------

Port          Native  Status        Port

               Vlan                  Channel

--------------------------------------------------------------------------------

Eth1/1        1       trnk-bndl     Po1000

Eth1/2        1       trnk-bndl     Po1000

Eth1/3        1       trnk-bndl     Po1000

Eth1/4        1       trnk-bndl     Po1000

Eth1/8        99      trunking      --

Eth1/10       99      trunking      --

Po20          1       trunking      --

Po21          1       trunking      --

Router side

interface Port-channel21

no ip address

hold-queue 150 in

!

interface Port-channel21.1

encapsulation dot1Q 1 native

!

interface Port-channel21.248

encapsulation dot1Q 248

ip address 216.21.248.8 255.255.255.0

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

channel-group 21

!        

interface FastEthernet0/1

no ip address

duplex auto

speed auto

channel-group 21

VIP Advocate

Re: port channel and sub interface

try hard-coding LACP on the switch ports.

If you do a debug arp on th switches and ping from the router to the switches, do you see the switches receiving the packet?

--
Please remember to rate and select a correct answer
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards