ā12-21-2022 09:02 AM
Hi Gurus,
I need to establish a port-channel between a nexus and router. On the router side, I want to hardcode an IP address in port-channel, but I want to use vlan in the port-channel on the nexus side. I will config int vlan on nexus with an ip address in the same subnet as the hardcode Ip address of router port-channel.
is it possible to achieve with this config? Thank you.
ā12-21-2022 09:30 AM
On the nexus you can use L2 port-channel (if vPC, make sure you configure vPC) and use Layer 3 SVI for Layer 3 interface.
on the router you need to use Port-channel and sub interface with dot1q tagging vlan associated with the VLAN.
example :
port-channel 10
interface port-channel 10.100 (for vlan 100)
ā12-21-2022 09:42 AM - edited ā12-21-2022 09:43 AM
so on nexus i could do something like:
interface Vlan6
no shutdown
ip address 10.101.6.138/29
interface port-channel6
switchport access vlan6
interface Ethernet2/5
switchport access vlan6
channel-group 6 mode active
interface Ethernet2/6
switchport access vlan6
channel-group 6 mode active
-----------------------------------------------------
Why do i need "port-channel 10" command on router? what's the purpose?
Thank you.
ā12-21-2022 10:52 AM
is this only 1 VLAN ? or in the future you going to have more VLAN ?
now and furture only 1 VLAN then you can as below :
interface port-channel 6
no switchport
ip address 10.101.6.X /29
In the future you think going to be more VLAN (high level below command should work for you - depends IOS code some commands may vary)
nexus side
interface port-channel6
switchport
switchport mode trunk
switchport trunk allowed vlan 6
On the router
interface port-channel 6.6
encapsulation dot1Q 6
ip address 10.101.6.X /29
ā12-21-2022 11:01 AM - edited ā12-21-2022 11:03 AM
Thank you Balaji.
Good question for the vlan, ive been thinking about it as well.
Currently, we already have connection between the nexus and router, it only has access switchport on nexus side. on router side, it's config as below
interface GigabitEthernet0/0/0.6
encapsulation dot1Q 1 native
ip address 10.101.6.x 255.255.255.248
So i assume the interface on router is access mode because it doesn't have "encapsulation dot1Q 6".
There are multiple int vlan config on the nexus, but we don't have issue to route those vlan traffic out of the router.
so is it necessary for the trunk switchport config?
ā12-21-2022 11:22 AM
in cisco world by default native vlan is 1, if you do not mention.
the config you single interface acting as trunk so that should be ok.
if you looking port-channel required vlan6 , then i would change to dot1q 6 (if i assume your config and based on the information)
when you doing this changes - there will be small network convergency so understand before you change anythig in switch or router side.
so is it necessary for the trunk switchport config?
YES / NO depends on requirement, but you have not mentioned the issue ? please explain what is the issue or what is the requirment you looking to achieve.
ā12-21-2022 11:33 AM
if i understand correctly, i have trunk port on router side, even no command "encapsulation dot1Q 6"?
Current setup is router has one single link to one nexus, another single link to another nexus. two nexus connects via vpc
i want to bundle two links as port-channel to one nexus, same deal to the other nexus in order to increase throughput
For nexus port-channel, i understand i don't need vpc cause it's not cross connect.
so i need to make sure both port-channel on nx and router are in trunk mode?
ā12-21-2022 11:57 AM - edited ā12-21-2022 11:58 AM
If you have only 1 Interface, its not matter, that work as p2p link, if you looking more VLAN to accomidate then you need to tag the vlan to go right interface.
also suggest to make small diagram - what is current and what you looking to connect in teh future - so i can advise full config here.
some reference how nexus side works :
ā12-21-2022 09:40 AM
I run small lab and success ping from SVI in N9K to IP in router.
sorry may NSK have bug can not run port-channel.
ā12-21-2022 09:47 AM
Thank you MHM.
i have one site has hardcode IP on nexus side, and int vlan on router side. it was working without port-channel. kind of similar with what you setup, but reverse
ā12-21-2022 11:29 AM
int vlan on router side ?? which router you use ?
ā12-21-2022 11:37 AM
sorry, i mean router on stick
ā12-21-2022 11:46 AM
you can not config one side ruoter-port (NSK) and other subinterface (Router) that not work.
you need
SVI-trunk-subinterface
or
routerPort-access-routerPort
or
SVI-access-routerPort
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide