cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
14064
Views
0
Helpful
26
Replies
m-abooali
Enthusiast

port-channel flapping when two more links are added!?

Hello,

I have two Core 6509E SUP2T configued as VSS and has two 48 ports fiber blades. I have two 3750s, I have two gig on each 3750 port-channle to po1 and connected to both the core, one link to each core.

Now, I was asked ot add two more links on each 3750 switch to make it a total of 4 gigs on each 3750s (all 4 gig ports/uplinks will be in used an dtwo links to core one an dtwo links to core 2).

when i added two additional links on 3750s and bundled them to po1, I created another port channel on core and bundeled the additional two gigs on each core to accomodate for the two additional links (ports on core switches are not consequtives).

adding these two additional ports makes the 3750 switches flap between managemnet vlan and po1.

now, i am not sure if I must have added the two additional links on the core to teh current port-channel or core!? I have created another port-channel on core to accomodate for this currently!?

any thoughts on this is greatly appreciated.

Thanks,

Masood

2 ACCEPTED SOLUTIONS

Accepted Solutions

Ok Masood,

lets fix one 3750 switch first:

have a look at the config for po1 and the physical interfaces below

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/1/1

description description uplink to Core 6509 gi 1/1/24

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode passive

!

interface GigabitEthernet1/1/4

description description uplink to Core 6509 gi 2/1/24

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode passive

apply the same config on the 6500 but instead of passive use active see below

channel-group 1 mode active

make sure to shut the po1 first than apply the config and than bring up the po1

don't worry about shuting the physical interface

HTH

Reza

View solution in original post

do you think I must use Gi1/1/22 and Gi1/1/22 or any available gig interfaces on the core fiber blade will do?

No, they don't have to be consecutive, they can be any interface from the module, but if you can keep it consecutive, it makes it easier to remember.

The only restirication is that you can not have links with different speed in a portchannel.

example

you can't have a portchannel with one 1Gig interface and one 10Gig interface.  All interfaces in a portchannel must have the same speed and duplex.

HTH

View solution in original post

26 REPLIES 26
m-abooali
Enthusiast

Correction!:

I did not create new port channel on teh core to accomodate new links but added two more ports to each link to the current port channel at teh core side.

On the 3750 on the other hand, I frist added two links to po1 so made it a taotal of 4 but it flaped so I created a different po for teh new two additional link but still flapped!?

Hope this is clear!?

Thanks,

Masood

Masood,

The additional links in all switches (VSS pair and the 3750s) need to be added to the existing portchannel (po1).  You don't need to create any new portchannel.  The best way to do it is to shut the portchannel first.

int po1

sh

than add the additional physical ports to the portchannel, and than bring up the portchannel.

int po1

no sh

This should bring up all the physical ports and the portchannel.

HTH

Thanks Reza. I have shut the port channels already.

I have Po1 on 3750 (two links on each switch to core)

on teh core, I had Po5 for Sw1 (3750) and Po6 for Sw2 (3750) and all was working fine until they wanted two more ports on each 3750 added!?

So, on teh core I added additional ports/connectionand added to PO5 and Po6 respectively. On the 3750s, i added two more links and added to Po1 but i noticed flapping.

So I shut po1 and a created a new Po2 on 3750s for the two additionbal links but still got flapping. So I have now, shut all port channles to see what I need to do next!?

Regards,

Masood

on teh core, I had Po5 for Sw1 (3750) and Po6 for Sw2 (3750) and all was  working fine until they wanted two more ports on each 3750 added!?

by "for Sw1 and for Sw2, i mean on the core, I dded two more links to each current port-channles i.e. 5 and 6 whch was for connection to 3750 1 and 3750 2.

Sorry for the confusion if any!

Regards,

Masood

Ok,

so you have, lets call it 3750-A that has 2 links and these 2 links are connected to the VSS pair (one to each switch) and  this is portchannel 5 right?

you also have a lets call it 3750-B that is also connected to the 6500 VSS via 2 connections and that is portchannel 6 right?

Are you using LACP or PAGP?

If this is the case please post the configs from the VSS pair and both 3750s?

Reza

Reza, you are right. the configuration listed aboive by you was working fine until I added two additional links to 3750s to each have a 4 gig bundle port-channel and for that I had to add two more links on each cores and boubdle them to po5 and po6.

3750-A and 3750-B bothe had Po1.

Core prime and Core stby as one VSs pair had PO5 and PO6.

I currently don;t have the configs with new links added but the config when all was working fine is here:

Also as for LACP and PAGP, I left all at default as the config shows.

CR2#sh run

Building configuration...

Current configuration : 4105 bytes

!

! Last configuration change at 02:43:41 UTC Mon Mar 1 1993

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CR2

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

switch 1 provision ws-c3750x-48p

system mtu routing 1500

!

!

!

no ip domain-lookup

vtp domain manh2usca

vtp mode transparent

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

vlan 50

!

!

!

!

!

!

interface Port-channel1

!

interface Port-channel2

!

interface FastEthernet0

no ip address

shutdown

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface GigabitEthernet1/0/29

!

interface GigabitEthernet1/0/30

!

interface GigabitEthernet1/0/31

!

interface GigabitEthernet1/0/32

!

interface GigabitEthernet1/0/33

!

interface GigabitEthernet1/0/34

!

interface GigabitEthernet1/0/35

!

interface GigabitEthernet1/0/36

!

interface GigabitEthernet1/0/37

!

interface GigabitEthernet1/0/38

!

interface GigabitEthernet1/0/39

!

interface GigabitEthernet1/0/40

!

interface GigabitEthernet1/0/41

!

interface GigabitEthernet1/0/42

!

interface GigabitEthernet1/0/43

!

interface GigabitEthernet1/0/44

!

interface GigabitEthernet1/0/45

!

interface GigabitEthernet1/0/46

!

interface GigabitEthernet1/0/47

!

interface GigabitEthernet1/0/48

!

interface GigabitEthernet1/1/1

description description uplink to Core 6509 gi 1/1/24

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface GigabitEthernet1/1/2

switchport trunk encapsulation dot1q

shutdown

!

interface GigabitEthernet1/1/3

switchport trunk encapsulation dot1q

shutdown

!

interface GigabitEthernet1/1/4

description description uplink to Core 6509 gi 2/1/24

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface TenGigabitEthernet1/1/1

!

interface TenGigabitEthernet1/1/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan50

description DATA_SW-MGMT

ip address 156.x.x.6 255.255.255.128

shutdown

!

ip http server

ip http secure-server

logging esm config

!

banner motd ^C

!

line con 0

privilege level 15

password cisco

login

transport output all

line vty 0 4

privilege level 15

password cisco

login

transport input telnet ssh

transport output all

line vty 5 14

privilege level 15

password cisco

login

transport input telnet ssh

transport output all

line vty 15

login

!

end

CR1:

Current configuration : 4258 bytes

!

! Last configuration change at 02:16:30 UTC Mon Mar 1 1993

!

version 15.0

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CR1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

switch 1 provision ws-c3750x-48p

system mtu routing 1500

ip routing

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

!

!

!

interface Port-channel1

!

interface Port-channel2

!

interface FastEthernet0

no ip address

no ip route-cache

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

!

interface GigabitEthernet1/0/18

!

interface GigabitEthernet1/0/19

!

interface GigabitEthernet1/0/20

!

interface GigabitEthernet1/0/21

!

interface GigabitEthernet1/0/22

!

interface GigabitEthernet1/0/23

!

interface GigabitEthernet1/0/24

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface GigabitEthernet1/0/29

!

interface GigabitEthernet1/0/30

!

interface GigabitEthernet1/0/31

!

interface GigabitEthernet1/0/32

!

interface GigabitEthernet1/0/33

!

interface GigabitEthernet1/0/34

!

interface GigabitEthernet1/0/35

!

interface GigabitEthernet1/0/36

!

interface GigabitEthernet1/0/37

!

interface GigabitEthernet1/0/38

!

interface GigabitEthernet1/0/39

!

interface GigabitEthernet1/0/40

!

interface GigabitEthernet1/0/41

!

interface GigabitEthernet1/0/42

!

interface GigabitEthernet1/0/43

!

interface GigabitEthernet1/0/44

!

interface GigabitEthernet1/0/45

!

interface GigabitEthernet1/0/46

!

interface GigabitEthernet1/0/47

!

interface GigabitEthernet1/0/48

!

interface GigabitEthernet1/1/1

description description uplink to Core 6509 gi 1/1/23

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface GigabitEthernet1/1/2

description uplink to AT&T switch 02-CA02-NWYK-H-121-SW-01

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 2 mode on

!

interface GigabitEthernet1/1/3

description uplink to AT&T switch 02-CA02-NWYK-H-121-SW-02

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 2 mode on

!

interface GigabitEthernet1/1/4

description description uplink to Core 6509 gi 2/1/23

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode on

!

interface TenGigabitEthernet1/1/1

!

interface TenGigabitEthernet1/1/2

!

interface Vlan1

no ip address

!

interface Vlan50

description DATA_SW-MGMT

ip address 156.x.x.5 255.255.255.128

shutdown

!

ip http server

ip http secure-server

logging esm config

!

banner motd ^C

!

line con 0

privilege level 15

password xxxx

login

transport output all

line vty 0 4

privilege level 15

password xxxx

login

transport input telnet ssh

transport output all

line vty 5 14

privilege level 15

password xxxx

login

transport input telnet ssh

transport output all

line vty 15

login

!

end

hth

Thanks,

masood

Ok Masood,

lets fix one 3750 switch first:

have a look at the config for po1 and the physical interfaces below

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet1/1/1

description description uplink to Core 6509 gi 1/1/24

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode passive

!

interface GigabitEthernet1/1/4

description description uplink to Core 6509 gi 2/1/24

switchport trunk encapsulation dot1q

switchport mode trunk

shutdown

channel-group 1 mode passive

apply the same config on the 6500 but instead of passive use active see below

channel-group 1 mode active

make sure to shut the po1 first than apply the config and than bring up the po1

don't worry about shuting the physical interface

HTH

Reza

View solution in original post

Reza,

good Idea and if one works teh seocnd one must work too!?

what is the "passive" for on teh 3750s?

I will apply tomorrow and if that worked I will try the second switch.

on the core I have:

int Gi1/1/23 and Gi2/1/23 bounded to Po5

should I leave this as it except for the "active" command?

Please advise,

Regards,

Masood

Massod,

what is the "passive" for on teh 3750s?

With passive Command you are running LACP.  One side of the portchannel needs to be passive and one side needs to be active.  In this case the 3750 is passive and the 6500 is active.

int Gi1/1/23 and Gi2/1/23 bounded to Po5

Why are you using po5 on the 6500 and 1 on the 3750?  For simplicity, always use the same portchannel id on both sides of the connection

if the portchannel is 1 on the 3750 use 1 on the 6500.  If you are using 5 on the 6500 than use 5 on the 3750. (keep the numbers the same)

should I leave this as it except for the "active" command?

Not sure if I undestand the question

also, as I said before shut the po first do all the configs and than bring up the po.

no need to shut the physical interfaces.

HTH

Sure, since I have to use po5 on the core, i will use po5 on teh 3750s in new configuration.

"

should I leave this as it except for the "active" command?

Not sure if I undestand the question"

I meant, should leave the rest of the config on core the same but add "active" after port-channel 5 mode on?

Thanks,

Masood

I meant, should leave the rest of the config on core the same but add "active" after port-channel 5 mode on?

no, you need to delete the channel-group command completely and add active (see below)

example

int gi1/1/1

no channel-group 1

channel-group 1 mode active

HTH

Reza

shouldn't I add the additional interfaces in CR1?

that was the whole idea!?

it was working as it was without adding additional interfaces to po1 i.e. without adding

gi 1/1/2 and gi 1/1/3

So, I need to add the above interfaces and boundle to PO1 as it is a requirement.!?

Regards,

Masood

Yes, add the additional interfaces

you can have up to 8 physical interface in a portchannel

on teh core, after I added new interfaces on teh 3750s, I need to create uplinks so should those uplinks be consequtibe?

I current have :

int Gi1/1/23 and Gi2/1/23 bounded to Po5

but when I add two more interfaces on 3750s, i need to add two more on the core too.

do you think I must use Gi1/1/22 and Gi1/1/22 or any available gig interfaces on the core fiber blade will do?

Thanks and sorry for all these emails.

Best Regads,

Masood