cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2485
Views
0
Helpful
9
Replies

Port channel issue

mramirez-t
Level 1
Level 1

So I'm trying to connect an HP Blade Chassis to our core switch, a Cisco 4500, WS-C4500X-16.  These are set up as a stack.  The chassis has two NICs that need to connect, so I'm connecting them to te1/1/10 and te2/1/10.  If I connect the two NICs to each port without a port-channel, all VMs on the Chassis are communicable across all VLANs, since these ports are trunks.  If I add them to the port-channel, all communication fails.  Not sure what I'm missing.  This is the config that I have which is working.

XXX-4500INT-01#sh run int te1/1/10
Building configuration...

Current configuration : 158 bytes
!
interface TenGigabitEthernet1/1/10
description Uplink to HP Chassis
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
end

XXX-4500INT-01#sh run int te2/1/10
Building configuration...

Current configuration : 158 bytes
!
interface TenGigabitEthernet2/1/10
description Uplink to HP Chassis
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
end

XXX-4500INT-01#sh run int po5
Building configuration...

Current configuration : 100 bytes
!
interface Port-channel5
description Uplink to HP Chassis
switchport
switchport mode trunk
end

This is the config that I have when I was using port-channel:

XXX-4500INT-01#sh run int te1/1/10
Building configuration...

Current configuration : 158 bytes
!
interface TenGigabitEthernet1/1/10
description Uplink to HP Chassis
switchport mode trunk
channel-group 5 mode on
end

XXX-4500INT-01#sh run int te2/1/10
Building configuration...

Current configuration : 158 bytes
!
interface TenGigabitEthernet2/1/10
description Uplink to HP Chassis
switchport mode trunk
channel-mode 5 mode on
end

XXX-4500INT-01#sh run int po5
Building configuration...

Current configuration : 100 bytes
!
interface Port-channel5
description Uplink to HP Chassis
switchport
switchport mode trunk
end

9 Replies 9

GRANT3779
Spotlight
Spotlight

How is the other end configured? Have you tried 

channel-group 5 mode active?

Rather that just 'on'?

If I add channel-group 5 mode active to te1/1/10, the communication works.  As soon as I do the same for te2/1/10, te2/1/10 goes into suspended mode and communication fails.  So, it doesn't like the fact that I'm adding both interfaces to the channel-group.

Without the port channel configured and interfaces up, can you post output of

show int status

from the Cisco end. 

how is the HP end configured? 

Without port channel configured

Te1/1/10 Uplink to HP Chass connected trunk full a-10G 10GBase-Active cable 10M
Te1/1/11 disabled 1 full auto No XCVR
Te1/1/12 disabled 1 full auto No XCVR
Te1/1/13 Uplink to Forti connected trunk full a-10G 10GBase-Active cable 7M
Te1/1/14 --VSL--Dual Active connected 1 full a-1000 1000BaseT
Te1/1/15 Uplink to XXX-4500 connected trunk full a-10G 10GBase-CU 1M
Te1/1/16 Uplink to XXX-4500 connected trunk full a-10G 10GBase-CU 1M
Te2/1/1 Uplink to HQN-C304 connected trunk full a-10G 10GBase-CU 5M
Te2/1/2 Uplink to HQN-C304 connected trunk full a-10G 10GBase-CU 5M
Te2/1/3 Uplink to HQN-4948 disabled 1 full auto No XCVR

Port Name Status Vlan Duplex Speed Type
Te2/1/4 Uplink to HQN-C304 disabled 1 full auto No XCVR
Te2/1/5 disabled 1 full auto No XCVR
Te2/1/6 disabled 1 full auto No XCVR
Te2/1/7 disabled 1 full auto No XCVR
Te2/1/8 disabled 1 full auto No XCVR
Te2/1/9 disabled 1 full auto No XCVR
Te2/1/10 Uplink to HP Chass connected trunk full a-10G 10GBase-Active cable 10M

Hello

cisco
conf t
no interface port-channel 5
default int range te1/1/10 , te2/1/10
int range te1/1/10 , te2/1/10
shut
channel-protocol lacp
channel-group 5 mode active

int port-channel 5
switchport mode trunk

int range te1/1/10 , te2/1/10
no shut

HP
conf t
trunk 26-27 trk 5 lacp
vlan 1 tagged trk5
vlan 2 tagged trk5
vlan x etc....

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

You could run a debug also on the cisco end before bringing up the etherchannel and then look at the output.

From the cisco switch

debug etherchannel

debug lacp

(if using mode active)

term mon

bring up etherchannel and see any output that might give some idea if the issue.

I left te1/1/10 in the channel after the last post.  After adding te2/1/10, below.  No output for about 5 minutes.

XXX-4500INT-01#debug etherc
PAgP/LACP Shim/FEC debugging is on
XXX-4500INT-01#debug lacp
Link Aggregation Control Protocol debugging is on
XXX-4500INT-01#term mon
XXX-4500INT-01#conf t
Enter configuration commands, one per line. End with CNTL/Z.
XXX-4500INT-01(config)#int te2/1/10
XXX-4500INT-01(config-if)#channel-group 5 mode active
XXX-4500INT-01(config-if)#end
XXX-4500INT-01#sh etherc summ
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator

M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port

A - formed by Auto LAG


Number of channel-groups in use: 7
Number of aggregators: 7

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Te1/1/1(D) Te2/1/1(P)
2 Po2(SU) LACP Te1/1/2(P) Te2/1/2(P)
3 Po3(SU) LACP Te1/1/3(P) Te2/1/3(D)
4 Po4(RD) -
5 Po5(SU) LACP Te1/1/10(P) Te2/1/10(s)

Do you have any other port channels to the HP chassis?

Not that familiar with them tbh. How are the two nics on that end grouped? Nic Teaming or something else? Do you have access to the HP side also to check the configuration?

remember to remove the debugs for now on the Cisco switch.

undebug all

Hello,

I have an issue with port-channeling also.

I am trying to connect Dell SCv3020 to my core switch Cisco 4500-X. When I am creating port channel all ports from channel are going in suspended mode. In the switch log i see LACP currently not enabled on the remote port.

Also on the storage i have messages:

"Data Center Bridging is supported on this port but no TLVs have been received from the switch. Please make sure that DCB is enabled and configured on the switch."

and

"Link Layer Discovery Protocol is supported on this port but no TLVs have been received from the switch. Please make sure that LLDP is enabled and configured on the switch.

After hundred of tests i discover that this switch is not in compatibility list for this storage.

Any chance to still make a port group?

 

Review Cisco Networking for a $25 gift card