12-10-2014 04:38 PM - edited 03-07-2019 09:51 PM
Hi Everyone,
I need to config Port forwarding on Cisco Router so that users from outside world can access the server say 10.10.10.x on port TCP 8084.
Here is config
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname xxxx
ppp chap password xxxxxx
ppp ipcp dns request accept
ppp ipcp address accept
no cdp enable
crypto map S2SVPN
end
Current NAT config is
ip nat inside source route-map ISP1 interface Dialer0 overload
Router01#sh route-map ISP1
route-map ISP1, permit, sequence 10
Match clauses:
ip address (access-lists): 101
interface Dialer0
Set clauses:
Policy routing matches: 0 packets, 0 bytes
sh access-lists 101
Extended IP access list 101
5 deny ip 10.10.10.0 0.0.0.255 10.20.20.0 0.0.0.255 (444830 matches)
10 deny ip 10.10.10.0 0.0.0.255 10.31.1.0 0.0.0.255 (89272 matches)
20 permit ip 10.0.0.0 0.255.255.255 any (1182278 matches)
Regards
MAhesh
Solved! Go to Solution.
12-10-2014 04:53 PM
Hi Mahesh,
try something like this:
ip nat inside source static tcp 10.10.10.x 8084 <your public ip> 8084 extend
Thanks,
Reza
12-10-2014 04:53 PM
Hi Mahesh,
try something like this:
ip nat inside source static tcp 10.10.10.x 8084 <your public ip> 8084 extend
Thanks,
Reza
12-10-2014 05:08 PM
Hi Reza,
I did below
ip nat inside source static tcp 10.10.10.252 8084 public ip 8084 extendable
Does it make sense?
Regards
MAhesh
12-10-2014 06:24 PM
Hi Mahesh,
To test, try connecting to the server or have the server guys try it from outside (Internet).
HTH
12-10-2014 06:49 PM
Many thanks Reza.
Regards
MAhesh
12-10-2014 05:20 PM
Hi Reza,
I did as you said.
How can i test if router is allowing connection on port 8084?
is this right test
sh ip nat trans
tcp router public ip:8084 10.10.10.252:8084 88.198.46.51:44038 88.198.46.51:44038
Regards
MAhesh
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide