12-13-2023 05:15 PM
Hi,
If i need to add additional allowed vlans on trunk would i run command first on PortChannel interface or 2 physical interfaces?
Thanks.
Solved! Go to Solution.
12-13-2023 05:40 PM - edited 12-13-2023 05:41 PM
@toolshed1 you need to add to port channel interface. no need to allow in physical interface. you can do without down time
make sure you are using 'add' key word.
ex. Switch(config-if)#switchport trunk allowed vlan add vlan-id
12-13-2023 05:18 PM
@toolshed1 add to portchannel interface.
12-13-2023 05:21 PM - edited 12-13-2023 05:27 PM
Kasun,
Thanks for quick response. Just to confirm i already have existing PortChannel with allowed vlans and 2 Physical interfaces that are part of that PortChannel with same allowed vlans. I need to create additional vlans and add them to PortChannel and physical interfaces. I would have to add to PortChannel first and after that to 2 physical interfaces?
I should add that i want to do that without downtime.
12-13-2023 05:40 PM - edited 12-13-2023 05:41 PM
@toolshed1 you need to add to port channel interface. no need to allow in physical interface. you can do without down time
make sure you are using 'add' key word.
ex. Switch(config-if)#switchport trunk allowed vlan add vlan-id
12-13-2023 05:48 PM
For example, if you originally needed to add VLAN12 to vlan1, 2, and 3, you can configure it in the portchannel.
switchport trunk allowed vlan add 12
12-13-2023 05:24 PM
sw1:
interface Port-channel1
switchport mode trunk
interface GigabitEthernet1/1/1
switchport mode trunk
channel-group 1 mode on
interface GigabitEthernet1/1/2
switchport mode trunk
channel-group 1 mode on
sw2:
interface Port-channel1
switchport mode trunk
interface GigabitEthernet1/1/1
switchport mode trunk
channel-group 1 mode on
interface GigabitEthernet1/1/2
switchport mode trunk
channel-group 1 mode on
12-13-2023 05:26 PM
Verification View command:
show etherchannel summary
12-13-2023 06:37 PM
BTW and FYI, over the years (and decades) more and commands are applied on the PC interface.
With current gen IOS, if command applies logically to the bundle, it likely can be applied to the PC interface. If command deals with individual physical interfaces, then it may need to be applied to individual physical interfaces.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide