01-31-2015 10:57 PM - edited 03-07-2019 10:27 PM
Hi all, I need help with portwarding on cisco 1841 to my dvr.
DVR: ip- 192.168.146.5/24, server port - 7777, 8888(mobile), http port - 80
I am able to remote to the dvr via public public using static nat, the browser would load the camera and ask to sign in, but i am not able to login as the DVR doesn't show up on the search and when I specified the ip and port, it said fail to connect. Please help, I think something wrong with my static nat or acl, need something else add to the config. Also the clock is always wrong, it doesn't update the time but it does update the date...
NPCISCO#sh run
Building configuration...
Current configuration : 1845 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname NPCISCO
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$70h8$wYku6QKYlHlaS7GZpp6vz.
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.146.1 192.168.146.99
!
ip dhcp pool LAN
network 192.168.146.0 255.255.255.0
default-router 192.168.146.1
dns-server 8.8.8.8
!
!
ip name-server 8.8.8.8
!
!
!
interface FastEthernet0/0
no ip address
ip tcp adjust-mss 1452
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 192.168.146.1 255.255.255.0
ip access-group CAMERA in
ip nat inside
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip mtu 1452
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp pap sent-username 004b1d@biz password 7 04721F545F701F
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip nat inside source list NAT_ADDRESSES interface Dialer1 overload
ip nat inside source static udp 192.168.146.5 80 interface Dialer1 7777
ip nat inside source static tcp 192.168.146.5 80 interface Dialer1 8888
!
ip access-list standard NAT_ADDRESSES
permit 192.168.146.0 0.0.0.255
!
ip access-list extended CAMERA
permit ip 192.168.146.0 0.0.0.255 192.168.146.0 0.0.0.255
permit ip any any
!
!
control-plane
!
banner motd ^C### NETRO Authorized Personnel Ony ###^C
!
line con 0
exec-timeout 0 0
password 7 04753B2526126F61
logging synchronous
login
line aux 0
line vty 0 5
password 7 032A6B282F3C0263783D20
login
!
ntp server 118.67.200.10
end
Much thanks in advance,
01-31-2015 11:02 PM
Static Nat should be:
ip nat inside source static tcp 192.168.146.5 80 interface Dialer1 7777
02-10-2015 10:20 PM
Ahh finally got it to work on my own after much trials and errors. If those who having this issue, all I need was portwarding all the ports associated with the DVR hence 80, 7777, and 8888 like so
ip nat inside source static tcp/udp 192.168.146.5 80 interface Dialer1 80
ip nat inside source static tcp/udp 192.168.146.5 7777 interface Dialer1 7777
ip nat inside source static tcp/udp 192.168.146.5 8888 interface Dialer1 8888
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide