cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
287
Views
0
Helpful
7
Replies
Highlighted
Beginner

Possible loops

See some significant spikes on our network, running a few commands after some googling, Below are some examples on what I am seeing, any assistance on how to remediate these? 

 

show spanning-tree detail | inc ieee|occur|from|is exec
VLAN0001 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 25630 last change occurred 02:10:37 ago
from GigabitEthernet2/1/2
VLAN0010 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 24998 last change occurred 1d07h ago
from GigabitEthernet1/0/16
VLAN0011 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 217 last change occurred 1d07h ago
from GigabitEthernet1/0/16
VLAN0020 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 25062 last change occurred 1d07h ago
from GigabitEthernet1/0/16
VLAN0030 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 24696 last change occurred 1d07h ago
from GigabitEthernet1/0/16

 

interface GigabitEthernet1/0/16
description "WAP"
switchport trunk native vlan 130
switchport mode trunk
spanning-tree portfast
spanning-tree bpduguard enable

 

interface GigabitEthernet2/1/2
switchport mode trunk

 

Vlan130 is up, line protocol is up
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
5 minute input rate 643000 bits/sec, 144 packets/sec
5 minute output rate 1143000 bits/sec, 200 packets/sec

 

GigabitEthernet2/1/2 is up, line protocol is up (connected)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
5 minute input rate 84000 bits/sec, 32 packets/sec
5 minute output rate 96000 bits/sec, 52 packets/sec

7 REPLIES 7
Highlighted
Hall of Fame Expert

Where do you see significant spikes?

5 minute input rate 643000 bits/sec, 144 packets/sec
5 minute output rate 1143000 bits/sec, 200 packets/sec

1143000 is just over a 1Mbps (1.143) on a gig interface.

 

5 minute output rate 96000 bits/sec, 52 packets/sec

Also, the above number is less than 1Mbps

So, this interface does not have much load on it.

 

HTH

 

 

Highlighted

I am very new to cisco troubleshooting. the spikes itself is from a third party application (cacti). Where specific VLAN/ Trunk Ports Outbound/Inbound interfaces are hitting 100Mbps at the same time. I was looking to see where on the switch I can see this.  

 

Vlan20 is up, line protocol is up
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
5 minute input rate 545461000 bits/sec, 52591 packets/sec
5 minute output rate 1105733000 bits/sec, 106975 packets/sec

Highlighted

Cacti will show that the amount of traffic on the interface but it will not be able to tell you what device/application is causing high traffic. If you want to see what device/application is producing high traffic, you would need some sort of monitoring system like SolarWinds to see the top 5 or 10 talker on the dash. 

 

HTH

Highlighted

Are there any commands I can run on the switch to see why the suspected ports are affecting other ports that are also on the same vlan/trunked? These ports are directly connected to a single host some are WAP and some Servers. 

Highlighted

Hello

Make sure all your access-ports are spanning-tree edge ports ( spanning-tree portfast) as if they dont then this can cause unwarrented stp transitions.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Thank you. How about my uplink trunk ports? I am seeing a lot of TCNs for my uplink ports, how do I get rid of these?

 

Core:

interface GigabitEthernet1/0/24
description "uplink p48 from switch"
switchport access vlan 100
switchport mode trunk
channel-group 1 mode active
end

 

interface GigabitEthernet2/0/24
description "uplink p47 from switch"
switchport access vlan 100
switchport mode trunk
channel-group 1 mode active
end

 

Switch:

 

interface GigabitEthernet0/48
switchport mode trunk
channel-group 1 mode active

 

interface GigabitEthernet0/47
switchport mode trunk
channel-group 1 mode active

 

VLAN0090 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 24255 last change occurred 6d14h ago
from GigabitEthernet0/48
VLAN0100 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 24256 last change occurred 6d14h ago
from GigabitEthernet0/48

VLAN0200 is executing the ieee compatible Spanning Tree protocol
Number of topology changes 24256 last change occurred 6d14h ago
from GigabitEthernet0/48

Highlighted

Hi,

 

    As nowadays we should be running RSTP/MSTP, I've seen  lot of weird issues with plain old STP and TCN issues, where the STP Root Bridges fails to acknowledge these. The simplest solution for you is to:

         - run RSTP on all devices

         - configure all ports facing non-switches as portfast

 

Regards,

Cristian Matei.

Content for Community-Ad