cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
965
Views
0
Helpful
11
Replies
virgoboy009
Beginner

Problem in Configuring L2 Etherchanneling between two 6509 switches

Guys,

I am unbale to configure layer 2 Etherchanneling between two 6509 switches using the below commands.

Cs1:-

interface Port-channel30
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
end
!
int gi 13/14
description Connected HQ-Cs2
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
carrier-delay msec 0
channel-group 30 mode on
spanning-tree guard loop
!
int gi 13/15
description Connected HQ-Cs2
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
carrier-delay msec 0
channel-group 30 mode on
spanning-tree guard loop
!

Cs2:-

interface Port-channel30
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
end

int gi 3/1
description Connected HQ-Cs1
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
carrier-delay msec 0
channel-group 30 mode on
spanning-tree guard loop
!
int gi 3/2
description Connected HQ-Cs1
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30
carrier-delay msec 0
channel-group 30 mode on
spanning-tree guard loop

currently these two switches are connected with these two ports using trunk configuration, but after input the above config ...my ports are getting into error-disabled state and lossig connectivity between them.

I would like to know what is the need of using Layer 3 etherchanneling .....compared to Layer 2 ether channelling.

Appreciate your response.

~ KA.

11 REPLIES 11
fzamora
Cisco Employee

Please check the following document:

https://www.ciscotaccc.com/kaidara-advisor/lanswitching/showcase?case=K88041014

Links might be old so check this one out:

This chapter describes how to configure EtherChannels on the Catalyst 6500 series switch Layer 2 or Layer 3 LAN ports.

http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst6500/ios/12.1E/native/configuration/guide/channel.html

Regards,

Franco

Hello karim,

can you post output of sh etherchannel summary and show errdisable recovery

Regards

mahesh

Hello Mahesh,

Please see the output below -

HQ_6513_CS2#sh errdisable recovery 
ErrDisable Reason    Timer Status
-----------------    --------------
udld                 Disabled
bpduguard            Disabled
security-violatio    Disabled
channel-misconfig    Disabled
pagp-flap            Disabled
dtp-flap             Disabled
link-flap            Disabled
l2ptguard            Disabled
psecure-violation    Disabled
gbic-invalid         Disabled
dhcp-rate-limit      Disabled
mac-limit            Disabled
unicast-flood        Disabled
arp-inspection       Disabled

Timer interval: 300 seconds

HQ_6513_CS2#sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
Number of channel-groups in use: 7
Number of aggregators:           7

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)          -       
11     Po11(SD)         -       
30     Po30(SD)         -       
100    Po100(SU)        -        Gi13/1(P)  Gi13/2(P)  Gi13/3(P)  Gi13/4(P)

I put both side switchports in layer 2 mode  & Port-chan also layer 2mode....both side interfaces are gig ports.

Please suggest and thanks for your post.

Hello Karim,

Look like errdisable recovery is not configured in your switch. to configure the same please

put below commands in global mode

errdisable detect cause all
errdisable recovery cause all

Moreover it seems that output is taken when port are not configured under port-channel. I need output

when you faced problem. Appreciate if You can configure it again and provide output.

Additionally try with configuring only below command on both port at both sides

---on physical interface---

switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 30 mode on

Regards

Mahesh

Hello Karim,

could you please post the error message also that you get when the ports go to err disable so that we could get the reason of the same.

You can retrieve that output from " show log" .

Regards,

Swati

   Try bringing up the port channel at the same time.  "shut" the port channel SVI  then do a no shut .  You can't bring up the ports one at a time . Don't see an issue config wise.


Appreciate all your response guys.

I shall try these commands tomorrow on bothside switch interface and shall check the result

switchport

switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 30 mode on

I shall share the error logs after i re enter the commands on my Core switches.

What is the major need of using layer3 ether channels?

~ KA.

Hello Karim,

Will await for your reply.

Regarding l3 etherchannel..Say you are not having router and you have l3 switch only . In this case you give IP to port-channel interface

only and leave physical port as with vlan config.

Hope this helps

Regards

Mahesh

mahesh.gohil wrote:

Hello Karim,

Will await for your reply.

Regarding l3 etherchannel..Say you are not having router and you have l3 switch only . In this case you give IP to port-channel interface

only and leave physical port as with vlan config.

Hope this helps

Regards

Mahesh

Mahesh

Just to clarify. When you say apply IP to port-channel interface and "leave physical port as with vlan config".  I may be misunderstanding but, as far as i know, you can't do that. You have to make the physical ports "no switchport" as well as they are no longer L2 ports ?

Jon

Hi Jon,

Thanks for filling me. I missed that part.

Appreciate for the correction you made

Regards

Mahesh

letsgomets
Beginner

Shut down your port channel interfaces on both side

Set your channel-group mode to active on both sides

No shut your port channel interfaces

See if that fixes it. If you are using two 6509 switches there should be no need to force the channel group on. Allow them to negotiate the channel via LACP.