03-06-2017 05:41 AM - edited 03-08-2019 09:37 AM
One of my students create the attached diagram.
It uses RIP (v1 AFAIK) and for some odd reason, every PC can ping all the others. The way I understand RIP v1, this shouldn't be possible when using subnetting. What's wrong/right?
03-06-2017 03:41 PM
You may get help if you post as just an image file.
Jon
03-06-2017 06:39 PM
Hi
Yes, it should be a problem because it change the subnet mask to "native" example: /8, /16 and /24 into the routing table but on the attached scenario you are using different subnets behind the routers, that is the reason why you are able to make ping between the hosts, each router has 3 different subnets on their routing tables:
192.168.0.0/24
192.168.2.0/24
192.168.3.0/24
Note: The real mask is not included on the routing table, it was replaced by the native /24 because you are using RIP version 1.
There are no any problem because they are 3 different subnets so they are able to ping without any inconvenience but imagine the following scenario:
If you are using for example a subnet 192.168.1.0/24 and a subnetting is done and as result you configure the following subnets:
192.168.1.0/26 for R1
192.168.1.64/26 for R2
192.168.1.128/26 for R3
You will have problems, because the routers will not able to see the difference because for RIP v1 they look like 192.168.1.0/24, because v1 is classful, so the routers will learn via RIP other different subnets than 192.168.1.X/X. So you will not be able to see the subnets from each others.
Please let me share an example:
R4 ----- R1 ------ R2 ----- R3
R4 Configuration
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.128
duplex auto
speed auto
router rip
version 1
network 192.168.1.0
R4#SH IP ROUTE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:16, FastEthernet0/0
192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
R1 Configuration
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.12.0.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 1
network 10.0.0.0
network 192.168.1.0
R1#SH IP ROUTE
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.12.0.0 is directly connected, FastEthernet0/1
192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
R1#
R2 Configuration
interface FastEthernet0/0
ip address 192.168.1.129 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.12.0.2 255.255.255.0
duplex auto
speed auto
!
router rip
version 1
network 10.0.0.0
network 192.168.1.0
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.12.0.0 is directly connected, FastEthernet0/1
192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.128 is directly connected, FastEthernet0/0
R3 Configuration
interface FastEthernet0/0
ip address 192.168.1.130 255.255.255.128
duplex auto
speed auto
router rip
version 1
network 192.168.1.0
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 10.0.0.0/8 [120/1] via 192.168.1.129, 00:00:10, FastEthernet0/0
192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.128 is directly connected, FastEthernet0/0
#########################################################################
From R1
R1#sh ip route 192.168.1.129
% Subnet not in table
R1#sh ip route 192.168.1.130
% Subnet not in table
R1#sh ip route 192.168.1.1
Routing entry for 192.168.1.0/25
Known via "connected", distance 0, metric 0 (connected, via interface)
Redistributing via rip
Advertised by rip
Routing Descriptor Blocks:
* directly connected, via FastEthernet0/0
Route metric is 0, traffic share count is 1
R1#sh ip route 192.168.1.2
Routing entry for 192.168.1.0/25
Known via "connected", distance 0, metric 0 (connected, via interface)
Redistributing via rip
Advertised by rip
Routing Descriptor Blocks:
* directly connected, via FastEthernet0/0
Route metric is 0, traffic share count is 1
R1#
In few words the R1 knows the connected subnets and the point to point subnet only but not the subnet behind R2. R3 and R4 will only know the Point to point subnet between R1 and R2 but not other ones.
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 10.0.0.0/8 [120/1] via 192.168.1.1, 00:00:10, FastEthernet0/0
192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
R4#
R4#
R4#sh ip route 192.168.1.130
% Subnet not in table
R4#
R4#sh ip route 192.168.1.129
% Subnet not in table
R4#
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R 10.0.0.0/8 [120/1] via 192.168.1.129, 00:00:05, FastEthernet0/0
192.168.1.0/25 is subnetted, 1 subnets
C 192.168.1.128 is directly connected, FastEthernet0/0
R3#
R3#
R3#sh ip route 192.168.1.1
% Subnet not in table
R3#
R3#sh ip route 192.168.1.2
% Subnet not in table
If you configure each router with RIP ver 2 with no auto-summary, you will be able to see the other subnets.
R1 Config with version 2
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.12.0.1 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip forward-protocol nd
!
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.12.0.0 is directly connected, FastEthernet0/1
192.168.1.0/25 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
R 192.168.1.128 [120/1] via 10.12.0.2, 00:00:21, FastEthernet0/1
R1#
R1#sh ip route 192.168.1.129
Routing entry for 192.168.1.128/25
Known via "rip", distance 120, metric 1
Redistributing via rip
Last update from 10.12.0.2 on FastEthernet0/1, 00:00:04 ago
Routing Descriptor Blocks:
* 10.12.0.2, from 10.12.0.2, 00:00:04 ago, via FastEthernet0/1
Route metric is 1, traffic share count is 1
R1#
R1#sh ip route 192.168.1.130
Routing entry for 192.168.1.128/25
Known via "rip", distance 120, metric 1
Redistributing via rip
Last update from 10.12.0.2 on FastEthernet0/1, 00:00:08 ago
Routing Descriptor Blocks:
* 10.12.0.2, from 10.12.0.2, 00:00:08 ago, via FastEthernet0/1
Route metric is 1, traffic share count is 1
R1#
Hope it is useful
:-)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide