cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1261
Views
3
Helpful
15
Replies

QinQ Question

MaxStLedger
Level 1
Level 1

Switch Configuration

Switch 1 - Port 1/0/7 to CPE

Port 1/0/8 to Switch 2 Port 1/0/5

Switch 2 - Port 1/0/8 to Swith 3 Port 1/0/5

Switch 3 - Port 1/0/6 to untagged device on VLAN 1130

 

Port 1/0/5 & 1/0/8 - Trunk - Tagged 2500

Port 1/0/7 - Customer Mode - Untagged 2500

Port 1/0/6 - Access - 1130

I have three switches with the same configuration, I have one device tagged with VLAN 1130 connected to port 1/0/7 and one device untagged connected to port 1/0/6. However, I cant seem to have the two devices talking to each other is there any that I can get the two to talk. Port 1/0/7 must be in customer mode and port 1/0/6 connects to other devices in VLAN 1130. When both devices are tagged and in port 1/0/7 on the 2 end switches they talk, but I need the traffic to leave 1/0/6 in acces mode on VLAN 1130.

This is all new to me and cannot seem to find the right way to do it, any help would be appreciated! 

Thank you.

15 Replies 15

M02@rt37
VIP
VIP

Hello @MaxStLedger 

On the CPE side, its interface facing switch1 is a sub-interface ?

If yes, on Sw1 side, interface 1/0/7 facing this CPE, pelase share the configuration.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Hi, there is a basic configuration across the three switches here is the config file attacthed. 

Thanks @MaxStLedger 

I don't see the command:

switchport mode dot1q-tunnel 

You want QinQ between Switch 1 and Switch 3 ? You want two hosts, vlan 1130, discuss together throught QinQ Tunnel with TAG 2500 ?

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

can you share the topology ?
MHM

I have attacthed a simple topology, I am trying to get from R1 to R2 on VLAN 1130.

Thanks

Hello @MaxStLedger 

Thanks for that clear topology.

## Consider to change IP address on Routers R1 and R2 and the interfaces names ##

Example:

R1(config)#interface GigabitEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#interface fastEthernet 0/0.1130
R1(config-subif)#encapsulation dot1Q 1130
R1(config-subif)#ip address 192.168.113.1 255.255.255.0
!
SW1(config)#interface GigabitEthernet 1/0/7
SW1(config-if)#switchport access vlan 2500
SW1(config-if)#switchport mode dot1q-tunnel

SW1(config)#interface GigabitEthernet 1/0/5
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport mode trunk allowed vlan 2500
!
SW2(config)#interface GigabitEthernet 1/0/5
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport mode trunk allowed vlan 2500

SW2(config)#interface GigabitEthernet 1/0/8
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport mode trunk allowed vlan 2500
!
SW3(config)#interface GigabitEthernet 1/0/5
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk
SW3(config-if)#switchport mode trunk allowed vlan 2500

SW3(config)#interface GigabitEthernet 1/0/6
SW3(config-if)#switchport access vlan 2500
SW3(config-if)#switchport mode dot1q-tunnel
!
R2(config)#interface GigabitEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#interface fastEthernet 0/0.1130
R2(config-subif)#encapsulation dot1Q 1130
R2(config-subif)#ip address 192.168.113.2 255.255.255.0

 

The switchport mode dot1q-tunnel command tells the switch to tag the traffic and switchport access vlan command is required to specify the Q-in-Q VLAN of 2500. Make sure that VLAN 2500 is available on SW1, SW2, and SW3.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Hi M02@rt37, Thanks for the reply 

I am using CBS350 switches and these do not have the command:

SW1(config-if)#switchport mode dot1q-tunnel

I have the following options in switchport mode:

general
access
trunk
customer
vlan-mapping
private-vlan

I am also using standard routers with VLAN tag 1130, not cisco.

Could you please advise, many thanks

Ok @MaxStLedger 

M02rt37_0-1702378948696.png

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

It needs to come out the other end tagged or untagged as 1130 and not a customer port, do you know how this can be achieved?

Thanks

@MaxStLedger 

Selecting this option 'customer' places the interface in QinQ mode. This enables you to use your own VLAN arrangements (PVID) across the provider network. The device is in Q-in-Q mode when it has one or more customer ports.

switchport customer and add vlan 2500. This is the quivalent of switchport mode dot1q-tunnel command. Apply this, on Switch 1 interfaces Port 1/0/7 and Switch 2 Port 1/0/6 facing Routers.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

it one of three

using MPLS VPWS 
QinQ
or using VLAN Mapping 
Configuring VLAN Mapping (cisco.com)

check vlan  mapping since your one side SW can not config with QinQ
MHM

I am trying to follow the configure VLAn mapping guide on cisco and it is giving the following message:

'Cannot create new VLAN mapping due to insufficient resource allocation'

Do you have any idea why this is happening, I think this could be the way to make it work as QinQ will not

Thanks