cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

QoS and VoIP

Sergey Balyura
Beginner
Beginner

Hello, all!

I try to understand QoS statistics on my 2960.

I have 2 cisco phones on it and 1 uplink.

on cisco phones interfaces I have "mls qos trust device cisco-phone"

on the uplink I have:

priority-queue out

mls qos trust cos

when I look at stats of cisco phone interfaces I can see:

test2960#sh mls qos int f0/1 sta

FastEthernet0/1 (All statistics are in packets)

  dscp: incoming 

-------------------------------

  0 -  4 :         494            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0        38255 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0        41666 

35 - 39 :           0            0            0            0            0 

40 - 44 :           0            0            0            0            0 

45 - 49 :           0       560760            0         1302            0 

50 - 54 :           0            0            0            0          289 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  dscp: outgoing

-------------------------------

  0 -  4 :  1554485781            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0          806 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :         280            0            0            0            0 

45 - 49 :           0       333299            0           15            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :       22982            0            0        38255        41666 

  5 -  7 :      560760         1591            0 

  cos: outgoing

-------------------------------

  0 -  4 :  1581312448            1            0          863            2 

  5 -  7 :      334368           15            8 

  output queues enqueued:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:      334022           0           0

queue 1:  1575942222      165750     2073819

queue 2:         863           0           0

queue 3:          15           0     5279196

  output queues dropped:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:            0            0            0

queue 1:          113            0            0

queue 2:            0            0            0

queue 3:            0            0            0

Policer: Inprofile:            0 OutofProfile:            0

Well as you see this interface receives and transmits DSCP EF packets very well.

but on uplink interface I see the next picture:

test2960#sh mls qos int g0/1 sta

GigabitEthernet0/1 (All statistics are in packets)

  dscp: incoming 

-------------------------------

  0 -  4 :  1631038478            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0         1190 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :      658766            0            0            0            0 

45 - 49 :           0           68            0           71            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  dscp: outgoing

-------------------------------

  0 -  4 :     9068534            0            0            0            0 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            0            0            0            0 

20 - 24 :           0            0            0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0            0            0            0 

35 - 39 :           0            0            0            0            0 

40 - 44 :           0            0            0            0            0 

45 - 49 :           0            0            0            0            0 

50 - 54 :           0            0            0            0            0 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :  1660182932            0            0         1247            0 

  5 -  7 :      659623           31            0 

  cos: outgoing

-------------------------------

  0 -  4 :     9125010            0            0            0            0 

  5 -  7 :           0            0            8 

  output queues enqueued:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:        1161           0           0

queue 1:  1652973914      167817    12891044

queue 2:         409           0           0

queue 3:           0           0     5932235

  output queues dropped:

queue: threshold1 threshold2 threshold3

-----------------------------------------

queue 0:            0            0            0

queue 1:            0            0            0

queue 2:            0            0            0

queue 3:            0            0            0

Policer: Inprofile:            0 OutofProfile:            0

there is no DSCP EF packets in outgoing or incoming stats...

what's wrong with it? or maybe I misconfigured something?

please help me in understaning and/or resolving it.

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

Basically you are trusting the marking from the Cisco device, but what do we trust? The additional command mls qos trust cos, stipulates that we trust the cos marking from the Cisco device not dscp. If you don't trust the value it will not be place in the appropriate ingress/egress queue. Thus when you look at the statistics on the uplink all packets will be re-written with 0 as they weren't trusted on the egress.

Regards
Allan.

Please rate helpful posts. Thank you.

Sent from Cisco Technical Support iPad App

View solution in original post

9 REPLIES 9

mlund
Rising star
Rising star

Hi

if You look at the output You see

40 - 44 :      658766            0            0            0            0 

this means You have incoming packets marked with dscp 40

You also can see that on cos:incoming, there are a lot of packets in cos 5

In the output direction You have a lot of packet in Q3T3, if I rember it right, this is the priority Queue

The default cos-to-dscp mapp is 0 8 16 26 32 40 48 56, and as a result of trusting cos, the switch looks at this map and rewrites the frame according to this, the result is, a frame received with cos 5 will have it's dscp value rewrittrn to dscp 40.

The recomendation is to change this mapping with the command

mls qos map cos-dscp 0 8 16 26 32 46 48 56

I also recomend You to "trust dscp" on the uplinks

/Mikael

Hi, Mikael!

I have this statement in my config already:

mls qos map cos-dscp 0 8 16 24 32 46 48 56

singhaam007
Participant
Participant

Hello,

could you please post you cos-dscp and dscp-cos maps.

also here is the config for my uplink and it works fine , you migt want try it

switchport trunk allowed vlan XXXX

switchport mode trunk

  load-interval 30

media-type rj45

speed 100

duplex full

srr-queue bandwidth share 1 30 35 5

queue-set 2

priority-queue out

mls qos trust cos

auto qos trust

my try it and see.

thanks

allan.thomas
Collaborator
Collaborator

Hi,

It does appear that the egress scheduling on the outgoing interface is re-writing the cos value. As per the other post please post the output of dscp-cos map to determine whether there is a problem with classification, the only other explanation is if you are using policed dscp which is remarking the traffic upon congestion. Can you actually post the QoS running configuration including the interfaces.

Sent from Cisco Technical Support iPad App

Hello!

this is my "show mls qos map"

test2960#show mls qos map

   Policed-dscp map:

     d1 :  d2 0  1  2  3  4  5  6  7  8  9

     ---------------------------------------

      0 :    00 01 02 03 04 05 06 07 08 09

      1 :    10 11 12 13 14 15 16 17 18 19

      2 :    20 21 22 23 24 25 26 27 28 29

      3 :    30 31 32 33 34 35 36 37 38 39

      4 :    40 41 42 43 44 45 46 47 48 49

      5 :    50 51 52 53 54 55 56 57 58 59

      6 :    60 61 62 63

   Dscp-cos map:

     d1 :  d2 0  1  2  3  4  5  6  7  8  9

     ---------------------------------------

      0 :    00 00 00 00 00 00 00 00 01 01

      1 :    01 01 01 01 01 01 02 02 02 02

      2 :    02 02 02 02 03 03 03 03 03 03

      3 :    03 03 04 04 04 04 04 04 04 04

      4 :    05 05 05 05 05 05 05 05 06 06

      5 :    06 06 06 06 06 06 07 07 07 07

      6 :    07 07 07 07

   Cos-dscp map:

        cos:   0  1  2  3  4  5  6  7

     --------------------------------

       dscp:   0  8 16 24 32 46 48 56

   IpPrecedence-dscp map:

     ipprec:   0  1  2  3  4  5  6  7

     --------------------------------

       dscp:   0  8 16 24 32 40 48 56

   Dscp-outputq-threshold map:

     d1 :d2    0     1     2     3     4     5     6     7     8     9

     ------------------------------------------------------------

      0 :    02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01

      1 :    02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01

      2 :    03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01

      3 :    03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01

      4 :    01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01

      5 :    04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01

      6 :    04-01 04-01 04-01 04-01

   Dscp-inputq-threshold map:

     d1 :d2    0     1     2     3     4     5     6     7     8     9

     ------------------------------------------------------------

      0 :    01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01

      1 :    01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01

      2 :    01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01

      3 :    01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01

      4 :    02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01

      5 :    01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01

      6 :    01-01 01-01 01-01 01-01

   Cos-outputq-threshold map:

              cos:  0   1   2   3   4   5   6   7 

              ------------------------------------

  queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

   Cos-inputq-threshold map:

              cos:  0   1   2   3   4   5   6   7 

              ------------------------------------

  queue-threshold: 1-1 1-1 1-1 1-1 1-1 2-1 1-1 1-1

   Dscp-dscp mutation map:

   Default DSCP Mutation Map:

     d1 :  d2 0  1  2  3  4  5  6  7  8  9

     ---------------------------------------

      0 :    00 01 02 03 04 05 06 07 08 09

      1 :    10 11 12 13 14 15 16 17 18 19

      2 :    20 21 22 23 24 25 26 27 28 29

      3 :    30 31 32 33 34 35 36 37 38 39

      4 :    40 41 42 43 44 45 46 47 48 49

      5 :    50 51 52 53 54 55 56 57 58 59

      6 :    60 61 62 63

this is my qos portion of running config

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 18

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos

!

and here are interfaces

interface FastEthernet0/1

switchport mode access

switchport voice vlan 555

mls qos trust device cisco-phone

spanning-tree portfast

!

interface FastEthernet0/2

switchport mode access

switchport voice vlan 555

mls qos trust device cisco-phone

spanning-tree portfast

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!        

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport mode trunk

priority-queue out

mls qos trust dscp

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 10.0.10.10 255.0.0.0

no ip route-cache

Hi,

Can you add 'mls qos trust cos' on the ports connecting the ip phones and make some test calls to determine if the outbound values are correct.

Regards
Allan

Sent from Cisco Technical Support iPad App

Hello!

thanx to Allan - I found some stranges...

I have a very strange situation.

when I put int with cisco phone in "mls qos trust cos" the picture become very good - I receive packets with right dscp.

when I out it back to "mls qos trust device cisco-phone" the picture become good!!!

I don't understand!

I have 2 phones on different switches. between switches there are trunks with "mls qos trust dscp"

all my cisco phones are connected to the switch with "mls qos trust device cisco-phone"

I called from 1 to 2. i have outgoing packets with DSCP 0 on both.

I turned mls qos from "trust device cisco-phone" to "trust cos" - I get packets with DSCP 46 now.

I turned mls qos back to "trust device cisco-phone" - and I get packets with DSCP 46!!!

What does it mean?

Hi,

Basically you are trusting the marking from the Cisco device, but what do we trust? The additional command mls qos trust cos, stipulates that we trust the cos marking from the Cisco device not dscp. If you don't trust the value it will not be place in the appropriate ingress/egress queue. Thus when you look at the statistics on the uplink all packets will be re-written with 0 as they weren't trusted on the egress.

Regards
Allan.

Please rate helpful posts. Thank you.

Sent from Cisco Technical Support iPad App

Thanx a lot, Allan!

no't know why I missed such important moment. I wrote "mls qos trust cos" with "mls qos trust device cisco-phone" - and everythong is fine!

thank you again!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: