07-15-2016 06:48 AM - edited 03-08-2019 06:38 AM
I have a doubt i am implementing qos on my network from different remote sites to my hq connected through MPLS. the parent policy is applied to the output of two subinterfaces. the markingTraffic policy is appied to the input of the lan interface
do I have to or benefit from enable wred on each class ?
by this configuration does my classes get "priority" over the default class and the drop mechanisms is based on the dscp classification ?
ip access-list extended voip
permit udp any any range 16384 32767
permit tcp any any eq 1720
ip access-list extended first-Traffic
permit tcp any any range 34560 34567
ip access-list extended second-Traffic
permit tcp any any eq 81234
permit tcp any any range 65432 65439
!
class-map match-any VOIP
match access-group name voip
match ip dscp ef
match protocol h323
match protocol rtp audio
class-map match-any FT
match access-group name first-Traffic
class-map match-any ST
match access-group name second-Traffic
!
!
policy-map outTraffic
class VOIP
priority percent 10
class FT
bandwidth percent 30
random-detect dscp-based
class ST
bandwidth percent 30
random-detect dscp-based
class class-default
fair-queue
random-detect dscp-based
!
policy-map parent
class class-default
shape average 1000000
service-policy outTraffic
!
policy-map markingTraffic
class VOIP
set ip dscp ef
class FT
set ip dscp af31
class ST
set ip dscp af31
class class-default
set ip dscp default
07-15-2016 07:54 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
Different IOS versions (and sometimes platform differences) impact how CBWFQ apportions bandwidth. As you didn't name what platforms and IOS versions you're using, cannot say how non-default classes will compete with class-default, especially as the latter is using FQ (which operates quite a bit differently based on IOS version).
Your WRED settings apply to the class they are configured on. (BTW, unless you're a QoS expert, I suggest you don't use WRED. [In theory it's great - in practice, it's very often not so great.])
07-15-2016 11:58 AM
Cisco c881
Cisco IOS Software, C880 Software (C880VOICE-UNIVERSALK9-M), Version 15.1(4)M4
so you recommend leave it with tail drop
07-16-2016 05:13 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
With your router and software, my recommendation would be to use FQ per class. That supports per flow tail drop.
07-16-2016 06:19 AM
You mean drop wred and use fair queue per class ?
Can you briefly explain why
i know my implementation seems simple compared to others but will wred make problems in this case ?
07-16-2016 10:53 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages wha2tsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
You mean drop wred and use fair queue per class ?
Correct.
Can you briefly explain why
"briefly" - not easily.
Conversely could you briefly explain how WRED will serve your QoS goals?
I see you've only enabled WRED, so your router's default WRED settings are best possible for you?
i know my implementation seems simple compared to others but will wred make problems in this case ?
Unsure how your implementations compares to other implementations matters - what usually matters is does it do what you need it to do for you.
Will WRED make problems? Difficult to say. It might, it might not.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide