cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
352
Views
0
Helpful
2
Replies

QoS in c3850 not working

JRDIAZ758
Beginner
Beginner

Hey, ive been trying to get a simple QoS Implementation to work. we purchased a stack of 3850s  for incoming traffic from clients. so ive been trying to marking incoming packets from the client network with specific DSCP and then apply priority based on those DSCP values. it doesnt seem to be marking anything thus making the outbound policy-map restrict have lots of output drops. 

what am i missing here?

so its:

client ----------->  ( g1/0/23 .core. g1/1/4)  -------> MPLS Link

!!!! creating ACLs/Class Maps for traffic

 

ip access-list extended priority_mark_voip

permit udp any any range 5000 65535

 

ip access-list extended priority_mark_data

 permit tcp any any eq www

 permit tcp any any eq 443

 permit tcp any any eq 4172

 permit udp any any eq 4172

 

class-map match-any priority_Data

 match access-group name priority_mark_data

 

class-map match-any priority_voip_marking

 match access-group name priority_mark_voip

!

class-map match-any client_traffic_data

 match dscp cs2

 

class-map match-any client_traffic_voip

 match dscp ef

 

!!!!!! policy-Map for incoming traffic

 

policy-map classifying_traffic

 class priority_voip_marking

  set dscp ef

 class priority_data_marking

  set dscp cs2

 

!!!!!!!! policy map for outging traffic

 

policy-map priority_traffic_prod

 class client_traffic_voip

  priority percent 50

 class client_traffic_data

  priority percent 40

 

policy-map port_child_policy

 class non-client-nrt-class

  bandwidth remaining ratio 10

 

!!!!!!!!!! applying Policy-MAPs

 

interface g1/0/23

 service-policy input classifying_traffic

 

interface GigabitEthernet1/1/4

 service-policy output priority_traffic_prod

!!!! show policy-map show no packets being marked/classified.

 

GigabitEthernet1/0/23

 

  Service-policy input: classifying_traffic

 

    Class-map: priority_voip_marking (match-any)

      870640040 packets

      Match: access-group name priority_mark_voip

        0 packets, 0 bytes

        5 minute rate 0 bps

      QoS Set

        dscp ef

 

    Class-map: priority_data_marking (match-any)

      117512 packets

      Match: access-group name priority_mark_data

        0 packets, 0 bytes

        5 minute rate 0 bps

      QoS Set

        dscp cs2

 

    Class-map: class-default (match-any)

      13515093 packets

      Match: any

2 Replies 2

Dennis Mink
VIP Alumni
VIP Alumni

Tomas,

are you accesslist that define your intersting traffic getting hit?

do sh ip access list priority_mark_voip  for instance

Looking at the default traffic there is traffic getting passed on the service-policy input classifying_traffic

Please rate if useful

Please remember to rate useful posts, by clicking on the stars below.

i dont see any hits, but the traffic coming into the g1/0/23 is pretty much what its coming from the client, (RTP traffic and WMview traffic) is what i put in the ACL.  

show access-lists priority_mark_voip
Extended IP access list priority_mark_voip
80 permit udp any any range 5000 65535

show access-lists priority_mark_data
Extended IP access list priority_mark_data
80 permit tcp any any eq www
90 permit tcp any any eq 443
100 permit tcp any any eq 4172
110 permit udp any any eq 4172

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: