cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7811
Views
0
Helpful
12
Replies

QOS on 2960x for Microsoft Teams

romi tchou
Level 1
Level 1

HI Community,

 

I am completly new to Qos on Cisco.

we would like to implement QoS on our network (based on 2960X - 15.2(2)E7 - license LAN BASE in use)  for Teams communication so that to prioritize Teams traffic according to their specifications (port range and dscp value).

 

here is a my config :

 

EXTENDED  ACL

 

ip access-list extended ACL-AUDIO
permit udp any range 50000 50019 any
permit tcp any range 50000 50019 any


ip access-list extended ACL-SHARING
permit udp any range 50040 50059 any
permit tcp any range 50040 50059 any


ip access-list extended ACL-VIDEO
permit udp any range 50020 50039 any
permit tcp any range 50020 50039 any

 

CLASS MAP

class-map match-any SHARING
match access-group name ACL-SHARING
class-map match-any AUDIO
match access-group name ACL-AUDIO
class-map match-any VIDEO
match access-group name ACL-VIDEO

POLICY-MAP


policy-map QOS-TEAMS
class AUDIO
set dscp ef
class VIDEO
set dscp af41
class SHARING
set dscp af21

 

 

ON LINK TO DISTRIB just set : mls qos trust dscp on trunk port

 

this is the config on LAN ACCESS.

 

on DISTRIB And interlink switch i've just put mls qos trust dscp.

 

i have apply this on some user interface port with the command

 

servicice-policy input QOS-TEAMS

 

but the show policy-map interface GiXXX is empty despite ( no match)  some call  via teams.

 

Do someboding can tell me what i'm missing ?

 

Thhanks in advance for you help.

 

12 Replies 12

Joseph W. Doherty
Hall of Fame
Hall of Fame

Some of the older/smaller switches, like 2960s, don't show all the QoS stats using "higher level" IOS commands, like show policy-map.  For those switches, you often need to issue "lower level" IOS commands, that show QoS stats from the ASIC.

That said, you'll likely want an example of such a command.  Unfortunately, it has been so long since I've accessed such a switch, I don't recall the syntax for such commands, others likely do, especially someone like @Leo Laohoo .

Hi Joseph 

first of all Thanks for your reply 

 

It is not the first Time to read about this commands not showing What we expect ‘

 

i’ve already try the one with statistics and i can see some stats without details unfortunatelly.

 

If i find  somthing i will share here!

 

regards,


@romi tchou wrote:

I am completly new to Qos on Cisco.


Rule #1 in QoS:  If it ain't broke, don't fix it.  

I have been playing with Cisco switches for a decade and QoS is "dark magic" I leave to experts like @Joseph W. Doherty.  Even Cisco TAC no longer supports/assist people with QoS. 

That said, what issue(s) are encountered with QoS (that warrants the config)?

What is the WAN link?

"Rule #1 in QoS: If it ain't broke, don't fix it. "

Laugh, but often people don't realize it is broke.

"Even Cisco TAC no longer supports/assist people with QoS."

Ha, didn't know that.  But as I often would disagree with Cisco's QoS recommendations, maybe TAC not supporting QoS issues, is a good thing.  (laugh)

Leo, I recall there were some 3750 commands to display detail QoS stats, but these commands, I also recall, were unique to 2K and 3K switches.  I don't remember what the exact commands were.  I referenced your name, hoping you might know some, off the top-of-your-head.

BTW, if you find QoS "dark magic", I believe that's often because the QoS is so poorly presented.  Well that, and you need to know "a lot" for it to all make sense, more so then any deep complexity.

 

Again, it has been so long ago, I don't remember the commands.

If you cannot find them in your IOS documentation, other QoS related postd will have them, however probably within posts about the 3560/3750 series (similar architecture, I believe).

Hello,

 

I could be wrong, but as far as I recall, on these switches, anything ingress is not supported. Try:

 

service-policy output QOS-TEAMS

i'm afraid is the opposite : see the result when typing with output

 

service-policy output QOS-INBOUND
Warning: Assigning a policy map to the output side of an interface not supported

 

Thanks

Correct.  These 2k switches, like the 3560/3750 support an ingress policy, but have "hard" defined egress queues which you can (optionally) map CoS or ToS values into.

romi tchou
Level 1
Level 1

little upadate :

 

i've finally check the Qos with : show mls qos interface GiX/X/X statistics.

 

Here are some result.

it seems only my incoming traffic is classify. i don't know how to manage egress traffic

 

Ah, yes, that's one of the commands I was trying to remember!

There should be additional such commands to provide other stats, such as egress queue stats.

If you looking for markings, though, the command you used shows both ingress and egress counts for the various markings.  What else did you want to see and/or what else do you want to "manage"?

 

hi,

 

i want to know if the egress traffic is also marked/classified and have the correct priority.

 

but the outgoing traffic ( in the pic attached)  is not the same as the incoming

 

don't know how to do

"but the outgoing traffic ( in the pic attached) is not the same as the incoming "

The earlier attached pic only shows stats for one interface, correct?

If so, for the same interface, ingress and egress stats generally don't match.  You need to compare, for the same traffic, one interface's ingress with other interface's egress. This is pretty strait forward if all traffic flows just between a pair of interfaces.

Or, sometime compare multiple interfaces' ingress with an interface's egress.  The latter can be difficult, for multiple ingress interfaces, if some of their traffic might also go to other egress interfaces.

Review Cisco Networking products for a $25 gift card