cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
2337
Views
0
Helpful
5
Replies
Highlighted
Beginner

QoS shaping on Port Channel sub interface

Hi,

I have a 1921 in a 'router on a stick' configuration. It's connected to the switch using a redudant etherchannel.

interface Port-channel 1

no shut

interface GigabitEthernet0/0

no ip address

no mop enabled

channel-group 1

interface GigabitEthernet0/1

no ip address

no mop enabled

channel-group 1

interface Port-channel1.1

encapsulation dot1Q 1 native

ip address 10.1.0.1 255.255.255.0

interface Port-channel1.2

encapsulation dot1Q 2

ip address 10.2.0.1 255.255.255.0

Now I'd like to apply some shaping on the traffic exiting Port-channel1.2 so I tried:

policy-map policy_upload

class class-default

  shape average 100000

  set ip precedence 0

interface Port-channel1.2

service-policy output policy_upload

But that didn't work at all, no reduction in bandwidth.

If I try the same thing without the port channel, then it works fine.

Any suggestion ?

Cheers,

    Sylvain Munaut

Everyone's tags (4)
5 REPLIES 5
Highlighted
Advocate

QoS shaping on Port Channel sub interface

Virtual interfaces sometimes work in the opposite direction, so try it on the "inbound", also post the output of "show policy-map interface

Port-channel1.2"

Highlighted
Beginner

Re: QoS shaping on Port Channel sub interface

I can't put it as input because :

gw-a(config-subif)#service-policy input policy_upload                     

Traffic Shaping feature not supported in input policy.

Here's a show during a bandwidth test. You can see the offered rate is properly measured and is _way_ above the target shape rate.

gw-a#show policy-map interface Port-channel 1.2

Port-channel1.2

  Service-policy output: policy_upload

    Class-map: class-default (match-any)

      624006 packets, 842239036 bytes

      5 minute offered rate 12774000 bps, drop rate 0 bps

      Match: any

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 0/0

      shape (average) cir 100000, bc 400, be 400

      target shape rate 100000

Highlighted

Hi!did you find any solution

Hi!

did you find any solution on your problem? couse i have the same issue now

Highlighted
Beginner

It works now. AFAIR I just

It works now. AFAIR I just updated IOS ....

Highlighted

Huge THANKS for quick reply

Huge THANKS for quick reply!

This was my first guess, after i`ve tryed everythin, but this device has latest iOS from cisco.com

I`ll try on other device, which is not currently updated yet. 

 

Thanks!

CreatePlease to create content
Content for Community-Ad